Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 122
  • Last Modified:

Windows 7 - Default Programs for file types not saving - Excel Only

I have a user who we need to have it default to open Excel when she opens .txt files.
I have gone in and changed it to use Excel through Set Associations in Default Programs but once I close Excel and try to open the .txt file again it opens in Notepad even though it still says Excel in the Set Associations screen for that file type.
It lets me change it to Word or Wordpad, but not Excel.
It works fine on my PC as well as other user PCs.
Any thoughts on what I am doing wrong or a different way to approach this?
0
adam_daunhauer
Asked:
adam_daunhauer
  • 2
1 Solution
 
Sreejith SugathanCommented:
Check the following registry location :

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts

Inside that find the key .txt and check the OpenwithList  - see if Notepad is still there on the list - if yes, try deleting this or changing the MRUList order and log off and back and check again.
0
 
adam_daunhauerAuthor Commented:
I will try this and let you know. She could not give me time on her PC the rest of the week.
0
 
adam_daunhauerAuthor Commented:
500 - Worked
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now