SSL site not working with https, Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings

Hi,
I'm using IIS 7.5.  This Intranet website was installed with SSL last year and was working until now.  A co-worker changed the site name in the IIS when I was on leave and turned off the SSL so I went to IIS and turned it on by selecting "Accept' or "Required" but both didn't work when I type in https://mysite.com.

Is the SSL not working because the site name was changed in IIS?  But it's bind to the same domain name so it shouldn't break it right?

I checked the ssl certificate in Server Certificate and it expires on 1/2019 so it's still good.

At the web server, I checked and make sure port 443 is opened in the FireWall setting.  I used this, https://www.sslshopper.com/ssl-checker.html#hostname=researchlink.med.usc.edu ,  on the Internet and it says it can't find the SSL cert.  
"No SSL certificates were found on mySite.com. Make sure that the name resolves to the correct server and that the SSL port (default is 443) is open on your server's firewall."

In IE 11 I get error message "Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings....".  I checked in IE Advanced tab and those options were checked but grey out.  Please see the attached screen capture.  What does this mean?  Is it turned on?

In FF, I get "Secure Connection Failed"

Appreciate any help to fix this problem.  Thank you.

p.s.   http://mySite.com  is working
lapuccaAsked:
Who is Participating?
 
Dr. KlahnPrincipal Software EngineerCommented:
SSL certificates are issued for a specific name and are only valid on that site.  If the site name was changed, that may be the issue.
0
 
lapuccaAuthor Commented:
So if the site name under iis is changed, but the binding domain name hasn't changed, the SSL should still work correct?  So, what is causing the problem with my SSL for this site then?

ha, just got it working.  Checked on IIS site binding and the https is bind to port 444.  when I type in https://mySite.com it becomes https://mySite.com:444     Is this because port 443 can only be used for one other site's SSL?  Don't like the append :444   Any way to get rid of that?

Thank you.
0
 
lapuccaAuthor Commented:
Well, it's working in IE 11 but not in FF.  any suggestion to fix this?  thank you.
0
 
lapuccaAuthor Commented:
In FF it will work if I append the port number at the end of the url ":444".  But how can I get it to work without specifying the port number?  Thank you.
0
 
lapuccaAuthor Commented:
Thank you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.