Solved

bluetooth keyboard dropping connection

Posted on 2016-11-23
4
35 Views
Last Modified: 2016-11-29
Having an issue with a Microsoft Designer Bluetooth Desktop Keyboard and Mouse set. It works fine until you leave it for a while and also
overnight the connection will have dropped

You can get it back by going into devices and getting it discovered again. We have put a new, more powerful
power supply in it in case it is a power problem. The OS is Windows 10 Pro X64. Any thoughts

Thanks
0
Comment
Question by:jimmyfloyd
4 Comments
 
LVL 53

Expert Comment

by:McKnife
ID: 41899117
I guess the power options need to be adjusted to not let USB devices go to sleep.
0
 
LVL 35

Expert Comment

by:Kimputer
ID: 41899126
Usually, you also check this on the Bluetooth hardware, as described by MS: https://support.microsoft.com/en-us/kb/2758967
0
 
LVL 6

Accepted Solution

by:
DPatel earned 500 total points
ID: 41899151
Update Your Drivers

Most Bluetooth mice don’t have their own individual drivers and simply use the default drivers for a Windows Bluetooth/HID compliant device. That said, the first stop should always be to check for device drivers by searching for the devices name and your operating system. In the case of the Microsoft mouse you’re using there are no device-specific drivers as it uses the generic Windows ones.

There’s a good chance your Bluetooth radio itself, however, (whether you have an on-board one or a dongle) has drivers. There’s also a good chance that they’re out of date. Before attempting the manual fixes we’re about to outline you should ensure you have the most current drivers for your Bluetooth radio. If you’re using generic Windows drivers for the Bluetooth radio you’ll likely find several of the settings you need to toggle will be unavailable.

Enable Automatic Bluetooth Services

The first stop on the troubleshooting trail is the Services menu. Open your Windows start menu and type “Services” in the search box or hit WIN+R and type “services.msc” in the run dialog box to launch the Services menu. Sort the columns by name and look for the “Bluetooth Support Service” entry.

1.jpg
Right click on that entry and select “Properties.” In the Properties menu look for the “Startup type” entry under the “General” tab.

2.jpg
Switch the type to “Automatic” and hit apply. Close the Services menu.

Disable Bluetooth Power Management

The updated drivers and the Services tweak are moving us in the right direction. Now it’s time to finish the job. While poor drivers or poor Service management may have been the culprits, it’s also possible that your laptop is aggressively managing the power for Bluetooth devices and, in the process, dropping the Bluetooth connection.

Fire up the device manager by typing “Device Manager” in the Start Menu search box or by pressing WIN+R and typing “devmgmt.msc” in the run dialog box.

Checking the Device Manager is going to be the most tedious part of resolving this problem. You need to look down through the sections of the Device Manager for any mention of a Bluetooth device and/or mouse and check the properties of each instance.  Look under “Bluetooth Radios,” “Mice and other pointing devices,” and “System devices.” What you’re looking for is “Power Management” tabs like this one.

3.jpg
Any instance of “Allow the computer to turn off this device to save power” should be unchecked. You absolutely do not want to allow the computer to turn off either the Bluetooth radio or the attached Bluetooth devices to save power as this is the primary cause of the un-syncing issue you’re seeing with your mouse. In addition to checking through everything for anything Bluetooth related don’t neglect the USB section at the bottom if you have a mouse connected via any kind of USB dongle. If you do, you’ll have to comb through the USB devices listed in the “Universal Serial Bus controllers” section to ensure that the computer isn’t set to turn off USB ports/hubs to save power (which would cause communication problems with the USB-powered dongle and the mouse).

After you’ve updated the drivers, toggled the Services, and unchecked the power management options, reboot your computer. If you’re not enjoying interruption free mouse use at this point we’d strongly recommend finding another Bluetooth mouse to test the system with to rule out a faulty mouse and/or Bluetooth dongle.
0
 
LVL 14

Expert Comment

by:William Fulks
ID: 41899224
Have you paired that keyboard with any other devices, perhaps a tablet or even your phone? It could be that those devices are stealing the connection away from the PC.
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you upgrade from Windows 8 to 8.1 or to Windows 10 or if you are like me you are on the Insider Program you may find yourself with many 450MB recovery partitions.  With a traditional disk that may not be a problem but with relatively smaller SS…
Ever wondered why Windows 8 and 10 don't seem to accept your GPO-based software deployment while Windows 7 does? Read on.
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now