Solved

LibreNMS - unable to connect.

Posted on 2016-11-24
2
49 Views
Last Modified: 2016-12-28
Hey Guys

I am trying to setup LibreNMS and am stuck at the following point: (config.php)

ve a look in defaults.inc.php for examples of settings you can set here. DO NOT EDIT defaults.inc.php! ### Database config $config['db_host'] = 'localhost'; $config['db_user'] = 'librenms'; $config['db_pass'] = 'random pass'; $config['db_name'] = 'librenms'; $config['db']['extension'] = "mysqli";// mysql or mysqli // This is the user LibreNMS will run as //Please ensure this user is created and has the correct permissions to your install $config['user'] = 'librenms'; ### Memcached config - We use this to store realtime usage $config['memcached']['enable'] = FALSE; $config['memcached']['host'] = "localhost"; $config['memcached']['port'] = 11211; ### Locations - it is recommended to keep the default $config['install_dir'] = "/opt/librenms"; ### This should *only* be set if you want to *force* a particular hostname/port ### It will prevent the web interface being usable form any other hostname #$config['base_url'] = "http://librenms.company.com"; ### Enable this to use rrdcached. Be sure rrd_dir is within the rrdcached dir ### and that your web server has permission to talk to rrdcached. #$config['rrdcached'] = "unix:/var/run/rrdcached.sock"; ### Default community $config['snmp']['community'] = array("public"); ### Authentication Model $config['auth_mechanism'] = "mysql"; # default, other options: ldap, http-auth #$config['http_auth_guest'] = "guest"; # remember to configure this user if you use http-auth ### List of RFC1918 networks to allow scanning-based discovery #$config['nets'][] = "10.0.0.0/8"; #$config['nets'][] = "172.16.0.0/12"; #$config['nets'][] = "192.168.0.0/16"; # Uncomment the next line to disable daily updates #$config['update'] = 0;
MySQL Error

php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution

There are no DNS errors anywhere on my network and I can browse/ping hostnames without issue. I tried using these instructions here : http://docs.librenms.org/Installation/Installation-Ubuntu-1604-Apache/#install-configure-mysql

I was not able to make these changes:

Within the [mysqld] section please add:

innodb_file_per_table=1
sql-mode=""

Because when I did, the MySQL services wouldn't start.

Any ideas?
Robert
0
Comment
Question by:castellansolutions
2 Comments
 
LVL 40

Accepted Solution

by:
noci earned 500 total points
ID: 41901316
Can you mark the config as code in the question? that would make it readable.

sql-mode="" should have been sql_mode="" it think.

and does the lookup of localhost work?... ie. ping localhost
0
 
LVL 6

Author Comment

by:castellansolutions
ID: 41903282
Thanks for the response. I was able to get it figured out. The problem was with the PHP file. When I copied over the text of the php file the first part <PHP was missing. I added that and it all worked.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Expanding drive space on Dell server with PERC 6i RAID controller 8 75
DNS records 18 83
LINUX, CPANEL & WHM 5 44
server DNS address could not be found 22 127
This article is intended as an extension of a blog on Aging and Scavenging by the MS Enterprise Networking Team. In brief, Scavenging is used as follows: Each record in a zone which has been dynamically registered with an MS DNS Server will have…
This article explains how a domain name may be inadvertently appended to all DNS queries. This exhibits as described below. (CODE)And / Or: (CODE) Cause This issue can occur in either of these two scenarios. EITHER 1. A Primary DNS S…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now