Link to home
Start Free TrialLog in
Avatar of NtHawk101
NtHawk101

asked on

Etherchannel trunking

I'm trying to trunk two ports from one 3550 switch to another 3550 and can't seem to get it to come up.

Here's the config and test results:


SWITCH A
interface FastEthernet0/13
 description ***port channel 1 member***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport trunk allowed vlan 10,20,30,35,40,100,102,120
 switchport mode trunk
 shutdown
 channel-group 1 mode passive
!
interface FastEthernet0/14
 description ***port channel 1 member***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport trunk allowed vlan 10,20,30,35,40,100,102,120
 switchport mode trunk
 channel-group 1 mode passive

SWITCH B
interface FastEthernet0/13
 description ***port channel 1 member***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport trunk allowed vlan 10,20,30,35,40,100,102,120
 switchport mode trunk
 channel-group 1 mode active
!
interface FastEthernet0/14
 description ***port channel 1 member***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport trunk allowed vlan 10,20,30,35,40,100,102,120
 switchport mode trunk
 channel-group 1 mode active

Sh eth summary:
Switch A

Corp3550#sh eth summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1


Sh eth summary
Switch B

Tvue3550#sh eth summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)         LACP      Fa0/13(D)   Fa0/14(D)

Speed on the interfaces is set at Auto

sh port-security on the interfaces:
Corp3550#sh port-security int f0/13
Port Security              : Disabled
Port Status                : Secure-down
Violation Mode             : Shutdown
Aging Time                 : 0 mins
Aging Type                 : Absolute
SecureStatic Address Aging : Disabled
Maximum MAC Addresses      : 1
Total MAC Addresses        : 0
Configured MAC Addresses   : 0
Sticky MAC Addresses       : 0
Last Source Address:Vlan   : 0000.0000.0000:0
Security Violation Count   : 0

Any help much appreciated.
One other thing, not all of the allowed vlans are on both sides yet. Would that matter at this point?

Thanks!
Avatar of Predrag Jovic
Predrag Jovic
Flag of Poland image

SWITCH A
interface FastEthernet0/13
  shutdown
 channel-group 1 mode passive
!
interface FastEthernet0/14
  channel-group 1 mode passive

SWITCH B
interface FastEthernet0/13
 channel-group 1 mode active
!
interface FastEthernet0/14
  channel-group 1 mode active
Looks like, at least on switch A, you did not create interface port-channel 1. Also FastEthernet0/13 is shutdown.

SWITCH A
interface FastEthernet0/13
 no shut
interface Po1
description ***port channel 1 member***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport trunk allowed vlan 10,20,30,35,40,100,102,120
 switchport mode trunk

Open in new window


SWITCH B
interface Po1
description ***port channel 1 member***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport trunk allowed vlan 10,20,30,35,40,100,102,120
 switchport mode trunk

Open in new window

Avatar of NtHawk101
NtHawk101

ASKER

I caught the shutdown after I posted and fixed that but still no change.
The port channel is created on SW-A so I'm curious why you think it's not.

Thanks!
The reason is that there is nothing under:
Corp3550#sh eth summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1
:)
Can you paste configuration of both devices and result from # show interface status.
If Port channels are configured on both devices it should work if devices are not err-disabled, or that you have different configuration on Po interfaces and physical interfaces.
SW-A:

interface Port-channel1
 description ***3550 to 3550***
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,20,35,40,120
 switchport mode trunk
!

!
interface FastEthernet0/13
 description ***port channel 1 member***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport trunk allowed vlan 10,20,35,40,120
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet0/14
 description ***port channel 1 member***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport trunk allowed vlan 10,20,35,40,120
 switchport mode trunk
 channel-group 1 mode on
!
!
interface GigabitEthernet0/1
 switchport mode dynamic desirable
!
interface GigabitEthernet0/2
 switchport mode dynamic desirable
!
interface Vlan1
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan3
 ip address 192.168.3.1 255.255.255.0
!
interface Vlan10
 description Vuepc Server Network
 ip address 192.168.100.1 255.255.255.0
 ip helper-address 192.168.100.30
!
interface Vlan15
 description Citrix Network
 ip address 192.168.101.1 255.255.255.0
 ip helper-address 192.168.100.30
!
interface Vlan20
 description Desktops
 ip address 192.168.20.1 255.255.255.0
 ip helper-address 192.168.100.30
!
interface Vlan25
 description Transit Network
 ip address 172.16.100.254 255.255.255.0
!
interface Vlan35
 description Management Network
 ip address 192.168.102.1 255.255.255.0
!
interface Vlan40
 ip address 192.168.40.1 255.255.255.0
!
interface Vlan99
 description DMZ-Web
 ip address 172.16.1.1 255.255.255.0
!
interface Vlan110
 ip address 192.168.110.1 255.255.255.0
 ip helper-address 192.168.100.30
!
interface Vlan220
 ip address 192.168.220.10 255.255.255.0
!
!
router eigrp 90
 network 172.16.100.0 0.0.0.255
 network 192.168.1.0
 network 192.168.20.0
 network 192.168.100.0
 network 192.168.101.0
 network 192.168.102.0
 eigrp stub connected summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.100.1
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
snmp-server community vpcsnmp RO
!
control-plane
!
!
!
ntp clock-period 17180247
ntp server 192.168.100.30
end


SW-B config with irrelevant parts removed:

hostname Tvue3550
!
!
!
!
no aaa new-model
clock timezone EST -5
clock summer-time EDT recurring
mls qos
ip routing
no ip domain-lookup

!
!
!
!

spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,20,35,40,120
 switchport mode trunk
!

!
interface FastEthernet0/13
 description ***port channel 1 member***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport trunk allowed vlan 10,20,35,40,120
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet0/14
 description ***port channel 1 member***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport trunk allowed vlan 10,20,35,40,120
 switchport mode trunk
 channel-group 1 mode on
!
!
interface GigabitEthernet0/1
 switchport mode dynamic desirable
!
interface GigabitEthernet0/2
 switchport mode dynamic desirable
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 192.168.100.1 255.255.255.0
!
interface Vlan20
 description ***Desktops***
 ip address 192.168.20.1 255.255.255.0
!
interface Vlan25
 description ***transit***
 ip address 172.16.22.254 255.255.255.0
!
interface Vlan35
 ip address 192.168.102.1 255.255.255.0
!
interface Vlan40
 ip address 192.168.40.1 255.255.255.0
!
interface Vlan101
 ip address 192.168.101.1 255.255.255.0
!
interface Vlan120
 ip address 192.168.120.1 255.255.255.0
!
!
router eigrp 90
 network 172.16.22.0 0.0.0.255
 network 192.168.0.0 0.0.255.255
 network 192.168.10.0
 network 192.168.30.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.22.1
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
control-plane
!
!
!
end
SW-A sh int status

Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/1     ***Edge Port to Co connected    25         a-full  a-100 10/100BaseTX
Fa0/2     ***Uplink to VuePC notconnect   1            auto   auto 10/100BaseTX
Fa0/3                        connected    20         a-full  a-100 10/100BaseTX
Fa0/4                        notconnect   20           auto   auto 10/100BaseTX
Fa0/5     ***DMZ***          connected    99         a-full  a-100 10/100BaseTX
Fa0/6                        notconnect   1            auto   auto 10/100BaseTX
Fa0/7                        notconnect   35           auto   auto 10/100BaseTX
Fa0/8                        notconnect   1            auto   auto 10/100BaseTX
Fa0/9     ***Vueesx04 Consol connected    35         a-full  a-100 10/100BaseTX
Fa0/10    ***Vueesx04-VMs*** connected    trunk      a-full  a-100 10/100BaseTX
Fa0/11    ***Vueesx03 VMs*** connected    trunk      a-full  a-100 10/100BaseTX
Fa0/12    ***Vueesx03 Consol connected    35         a-full  a-100 10/100BaseTX
Fa0/13    ***port channel 1  notconnect   1            auto   auto 10/100BaseTX
Fa0/14    ***port channel 1  notconnect   1            auto   auto 10/100BaseTX
Fa0/15                       connected    20         a-full   a-10 10/100BaseTX
Fa0/16    ***Vueesx01-white  connected    35         a-full  a-100 10/100BaseTX
Fa0/17    ***TV***           connected    20         a-full  a-100 10/100BaseTX
Fa0/18    ***Vueesx01-white  connected    trunk      a-full  a-100 10/100BaseTX
Fa0/19                       notconnect   1            auto   auto 10/100BaseTX
Fa0/20    ***Synology 2bay** connected    35         a-full  a-100 10/100BaseTX
Fa0/21                       connected    20         a-full  a-100 10/100BaseTX
Fa0/22    ***Synology 2bay-# connected    35         a-full  a-100 10/100BaseTX
Fa0/23    ***Openfiler***    notconnect   10           auto   auto 10/100BaseTX
Fa0/24    ***Synology-5bay-L connected    35         a-full  a-100 10/100BaseTX
Gi0/1                        notconnect   1            auto   auto unknown
Gi0/2                        notconnect   1            auto   auto unknown
Po1       ***3550 to 3550*** notconnect   unassigned   auto   auto


SW-B sh int status:

Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/1     ***Edge port to 28 connected    25         a-full  a-100 10/100BaseTX
Fa0/2     ***desktop***      notconnect   120          auto   auto 10/100BaseTX
Fa0/3                        notconnect   1            auto   auto 10/100BaseTX
Fa0/4                        notconnect   120          auto   auto 10/100BaseTX
Fa0/5                        notconnect   1            auto   auto 10/100BaseTX
Fa0/6                        notconnect   1            auto   auto 10/100BaseTX
Fa0/7                        notconnect   1            auto   auto 10/100BaseTX
Fa0/8                        notconnect   1            auto   auto 10/100BaseTX
Fa0/9                        notconnect   1            auto   auto 10/100BaseTX
Fa0/10                       notconnect   1            auto   auto 10/100BaseTX
Fa0/11                       notconnect   1            auto   auto 10/100BaseTX
Fa0/12                       notconnect   1            auto   auto 10/100BaseTX
Fa0/13    ***port channel 1  notconnect   1            auto   auto 10/100BaseTX
Fa0/14    ***port channel 1  notconnect   1            auto   auto 10/100BaseTX
Fa0/15                       notconnect   1            auto   auto 10/100BaseTX
Fa0/16                       notconnect   1            auto   auto 10/100BaseTX
Fa0/17                       notconnect   1            auto   auto 10/100BaseTX
Fa0/18                       notconnect   1            auto   auto 10/100BaseTX
Fa0/19                       notconnect   1            auto   auto 10/100BaseTX
Fa0/20                       connected    trunk      a-full  a-100 10/100BaseTX
Fa0/21    ***Tvueesx01-VMs** connected    trunk      a-full  a-100 10/100BaseTX
Fa0/22    ***tvueesx01 conso connected    120        a-full  a-100 10/100BaseTX
Fa0/23    ***Openfiler***    connected    120        a-full  a-100 10/100BaseTX
Fa0/24    ***Uplink to Tvue* connected    120        a-full  a-100 10/100BaseTX
Gi0/1                        notconnect   1            auto   auto unknown
Gi0/2                        notconnect   1            auto   auto unknown
Po1                          notconnect   unassigned   auto   auto
Also, it must have been cut off or missed but the channel is there:

Corp3550#sh eth summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)          -        Fa0/13(D)   Fa0/14(D)
ASKER CERTIFIED SOLUTION
Avatar of Predrag Jovic
Predrag Jovic
Flag of Poland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
You have problems with VLANs, a lot of duplicated IP addresses, So I guess this is not production device.

SW B:

interface Vlan10
 ip address 192.168.100.1 255.255.255.0
!
interface Vlan20
 description ***Desktops***
 ip address 192.168.20.1 255.255.255.0
!
interface Vlan25
 description ***transit***
 ip address 172.16.22.254 255.255.255.0
!
interface Vlan35
 ip address 192.168.102.1 255.255.255.0
!
interface Vlan40
 ip address 192.168.40.1 255.255.255.0
!
interface Vlan101
 ip address 192.168.101.1 255.255.255.0
!
interface Vlan120
 ip address 192.168.120.1 255.255.255.0

SW A:

interface Vlan1
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan3
 ip address 192.168.3.1 255.255.255.0
!
interface Vlan10
 description Vuepc Server Network
 ip address 192.168.100.1 255.255.255.0
 ip helper-address 192.168.100.30
!
interface Vlan20
 description Desktops
 ip address 192.168.20.1 255.255.255.0
 ip helper-address 192.168.100.30
!
interface Vlan25
 description Transit Network
 ip address 172.16.100.254 255.255.2
!
interface Vlan35
 description Management Network
 ip address 192.168.102.1 255.255.255.0
!
interface Vlan40
 ip address 192.168.40.1 255.255.255.0
!
interface Vlan99
 description DMZ-Web
 ip address 172.16.1.1 255.255.255.0
!
interface Vlan110
 ip address 192.168.110.1 255.255.255.0
 ip helper-address 192.168.100.30
!
interface Vlan220
 ip address 192.168.220.10 255.255.255.0
Not production, just added vlans on the other side as part of my troubleshooting to see if it mattered
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Predrag's comments regarding mdix led me to the solution. Mdix is not supported on the 3550 so I switched to using a crossover and the trunks came up. However, Don's comments are also correct and so gets an assist :)