firefox 50 saying your connection is not secure to every website

SteveDico
SteveDico used Ask the Experts™
on
windows 7... Firefox 50 says, "your connection is not secure",  to every website.  The browser works okay in safe mode with networking.  Chrome is un-flustered and works fine. How do I find out what is loading to mess up the magic?

Steve
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Distinguished Expert 2018

Commented:
Have you checked your OS? Are the time zone, date, and time settings correct?
*** Hopeleonie ***IT Manager

Commented:
So you have version 50.1.0?

Commented:
Does this happen on any site you connect to (HTTP & HTTPS)?
Even on sites that do present a valid security certificate?
Expert Spotlight: Joe Anderson (DatabaseMX)

We’ve posted a new Expert Spotlight!  Joe Anderson (DatabaseMX) has been on Experts Exchange since 2006. Learn more about this database architect, guitar aficionado, and Microsoft MVP.

Author

Commented:
Have you checked your OS? Yes.. time zone, date, and time correct. Having no issues booting safe with networking? I have version 50.1.0    Q: Does this happen on any site you connect to (HTTP & HTTPS)? Yes. If it runs in Win 7 safe mode, something must be loading to put this thing sour. How do I load things one at a time to troubleshoot?

Steve

Author

Commented:
new flag gotten: An error occurred during a connection to www.dog.com. Peer’s certificate has an invalid signature. Error code: SEC_ERROR_BAD_SIGNATURE
Commented:
Which security software (firewall, anti-virus) do you have?

Some security software intercept secure connections and send their own certificate.

Some examples are ESET and Bitdefender.

ESET setup -> advanced setup -> extend web and email tree -> SSL
SSL protocol: Do not scan SSL protocol
BitDefender -> Privacy settings -> disable Scan SSL
You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

Click the link at the bottom of the error page: "I Understand the Risks"
Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

Click the "View..." button and inspect the certificate and check who is the issuer.
You can see more Details like intermediate certificates that are used in the Details pane.
*** Hopeleonie ***IT Manager

Commented:
If you do a clean boot in Windows will Firefox work?
How to:
https://support.microsoft.com/en-us/kb/929135

Did you try to reset Firefox?
How to:
https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings
dbruntonQuid, Me Anxius Sum?  Illegitimi non carborundum.

Commented:
Check your plugins and extensions.  You may have added something which is causing this.  Try disabling any that seem suspicious.  Close Firefox and restart and see if the problem goes away.
Try refreshing Firefox.
    Click the menu button and then click help .
    From the Help menu choose Troubleshooting Information. ...
    Click the Refresh Firefox button in the upper-right corner of the Troubleshooting Information page.
    To continue, click Refresh Firefox in the confirmation window that opens.
    Firefox will close to refresh itself.
JoeSystems Administrator

Commented:
Does it do the same thing in internet explorer? If not then i would reinstall firefox and see what happens. Once you uninstall then go to your c:\users\%username%\appdata (You will need to show hidden folders in folder options) folder and delete any folders with firefox. Then do the reinstall.

To be extra safe i would scan with malwarebytes in safe mode as well.

Author

Commented:
iSSUE MAY BE SOLVED, WILL RESPOND TO CONSULTANTS

Author

Commented:
Tried all things suggested. Changing Eset SSL protocol  seemed to work, but loading the original profile and INSERTING that profile into the profile.ini  seemed to close the deal.  When refreshing or reinstalling, the damn install utility hunts for the old profile and dumps it. I had to move it to another drive and rename it to hide it from the FFGremlins.  Seem to see all sites now. Hope it stays fixed.  You folks are just heavenly...thanks for all solutions!

Steve

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial