Exchange 2010/Outlook 2016 Calendar permissions greyed out

Baris Toprak
Baris Toprak used Ask the Experts™
on
Hi,

First: Sorry for my english :)

We have a problem with the permissions in Outlook 2016. The Server is a Exchange 2010 14.03.0319.002.
The User cant change or add new permissions for sharing. the buttons are greyed out.  (like in the picture)
Any idea where i can configure that?

Thx
baris
greyed-out.png
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Alexei KuznetsovMicrosoft Outlook MVP

Commented:
Does that User have Full Access permissions for that mailbox containing the Calendar in question?
Edwin HofferTechnical Expert
Top Expert 2014

Commented:
Dear user
You can download the Microsoft Exchange Server Public Folder DAV-based Administration Tool. With the help of this, you can perform various management tasks of the calendar and mailboxes.
I have also found a solved query on Expert Exchange & Microsoft TechNet suggesting some more solution on the same issue, by referring the following link:
https://www.experts-exchange.com/questions/27019284/My-Outlook-2010-Calendar-Permissions-is-greyed-out.html

https://social.technet.microsoft.com/Forums/exchange/en-US/f646bb87-9c13-4a0c-b26e-0d82d922a2b9/calendar-properties-permissions-are-greyed-out-unable-to-add-permissions-back?forum=exchangesvradminlegacy

By doing some more digging on Google I found some more suggestion like,
1. You can run the following command to check the issue.
Set-Mailbox -Identity "Mailbox Name" -ApplyMandatoryProperties

2. Delete the existing account and then recreate a new account under Exchange Server.
http://www.msoutlookware.com/basic-tips/introduction-of-outlook-profile.html

3. I have also researched that the "Sharing Calendar" and "Calendar Permissions" are available only for Exchange Server account types and you are connected with Exchange as you have mentioned. So to confirm that you are using an Exchange account, go to Outlook, click File > Info > Account Settings > Account Settings and check the Type column under E-mail tab.

To know more about sharing Outlook calendar with other people you can refer the Microsoft link as follows:
https://support.office.com/en-us/article/Share-an-Outlook-calendar-with-other-people-353ed2c1-3ec5-449d-8c73-6931a0adab88?CorrelationId=8d0c0068-01f2-485b-b79b-56d469112525&ui=en-US&rs=en-US&ad=US&ocmsassetID=HA010354420

Note: All the links provided in the given solution is for better understanding and the brief explanation of the solution. It is provided only with the motive of better understanding and resolution of the error.

Thanks & Regards
Edwin Hoffer
Baris ToprakICT System Engineer

Author

Commented:
@Alexei Kuznetsov
Its the Mailbox from the User itself. All Users have the same Problem.
We have a Sharing Policy in our Exchange configured, so everyone can see the calendar from everyone. We need now for one User more rights, so they can create meetings in other users calendar. And here is the Problem, the permissions are greyed out and i can't create additional permissions.

@Edwin Hoffer
I will check the points and write you back as soon as possible.

Thanks a lot
Microsoft Outlook MVP
Commented:
Then I believe you have a Group Policy applied that prevents users to modify Outlook folder permissions. Can you change permissions for other folders, say, of Contacts or Mail type?
Baris ToprakICT System Engineer

Author

Commented:
Thank you Alexei, i found the Group Policy setting... my predecessor did that and didn't documented that.

BR Baris

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial