Link to home
Start Free TrialLog in
Avatar of Jim Schilling
Jim SchillingFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Tagged Vlan traffic does not seem to reach DHCP server (and/or possibly back again)

Hi All,

So we are trying to tag traffic on one specific Vlan (vlan 10) in our network. However when we do this, the traffic does not seem to reach another vlan (vlan 70) that has the DHCP server on it. Below is a rough layout of the network, with snippets of what I think are the relevant parts of config:

Wireless AP (Meraki MR42 - this is what is actually tagging the traffic to vlan 10).
AP plugged into Cisco 2960X Layer 2 stacked:
interface GigabitEthernet1/0/20
 switchport access vlan 10
 switchport trunk native vlan 10
 switchport trunk allowed vlan 10
 switchport mode trunk
!

Open in new window

Which is sent via this:
interface Port-channel4
 description ALS_STACK->DLS1
 switchport mode trunk
 switchport nonegotiate
!

interface GigabitEthernet1/0/47
 switchport mode trunk
 switchport nonegotiate
 channel-group 4 mode active
!

Open in new window

to a Cisco 3650 Layer 3 in a redundant setup
interface Port-channel4
 description DLS1->ALS_STACK
 switchport mode trunk
 switchport nonegotiate
!

interface GigabitEthernet1/0/5
 switchport mode trunk
 switchport nonegotiate
 channel-group 4 mode active
!

interface Vlan10
 ip address 10.0.10.252 255.255.255.0
 ip helper-address 192.168.0.48
 standby 10 ip 10.0.10.254
 standby 10 priority 120
 standby 10 preempt
!
interface Vlan70
 ip address 192.168.0.252 255.255.255.0
 ip helper-address 192.168.0.48
 standby 70 ip 192.168.0.248
!

Open in new window

This is then sent to a top of rack switch
interface Port-channel2
 description Trunk->R2GSW1
 switchport mode trunk
!

interface GigabitEthernet1/0/13
 switchport mode trunk
 channel-group 2 mode active
!

Open in new window

To which the DHCP server is plugged.
interface GigabitEthernet0/2
 description DHCP
 switchport access vlan 70
 switchport mode access
!
interface Port-channel2
 switchport mode trunk
!

Open in new window


If Vlan tagging is disabled, everything works perfect. But as soon as vlan tagging is enabled it no workie.

I'm not really sure what I need to do next. Any assistance would be greatly appreciated.

Please bear in mind I do not configure Cisco's on a daily basis and am barely up to CCNA level.

Thanks!
ASKER CERTIFIED SOLUTION
Avatar of Harold Bowlin
Harold Bowlin
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Jim Schilling

ASKER

Indeed! This implementation has solved my issues. Many thanks, I was stumped on this for hours...