Link to home
Start Free TrialLog in
Avatar of Keith Bui
Keith Bui

asked on

Cisco 800 router unable to connect through TPG network

I have a cisco router trying to connect through a TPG network but having problems with configuration.

I can ping outside from router but unable to ping from PC connected to router.

from PC i can ping to the router internal WAN interface but that is it.

please find config below

interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 switchport access vlan 10
 no ip address
!
interface FastEthernet4
 description INTERNET
 ip address 210.9.149.58 255.255.255.252
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
!
interface Vlan10
 description DATA
 ip address 10.2.0.1 255.255.0.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 102 interface FastEthernet3 overload
ip route 0.0.0.0 0.0.0.0 210.9.149.57
!
!
access-list 102 permit ip 10.12.0.0 0.0.255.255 any
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!


Any help would be much appreciated.

cheers
Avatar of Predrag Jovic
Predrag Jovic
Flag of Poland image

You have typo in ACL102
access-list 102 permit ip 10.12 .0.00.0.255.255 any

interface Vlan10
 description DATA
 ip address 10.2.0.1 255.255.0.0

Traffic is not natted, so ISP drops traffic.
Avatar of Keith Bui
Keith Bui

ASKER

Thanks, i have updated as follows,


interface FastEthernet3
 switchport mode trunk
 no ip address
!
interface FastEthernet4
 description INTERNET
 ip address 210.9.149.58 255.255.255.252
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
!
interface Vlan10
 description DATA
 ip address 10.2.0.1 255.255.0.0
 ip nat inside
 ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 102 interface FastEthernet4 overload
ip route 0.0.0.0 0.0.0.0 210.9.149.57
ip route 10.0.0.0 255.0.0.0 Null0
ip route 172.16.0.0 255.240.0.0 Null0
ip route 192.168.0.0 255.255.0.0 Null0
!
!
access-list 102 permit ip 10.2.0.0 0.0.255.255 any


I also changed the " ip nat inside source list 102 interface FastEthernet4 overload"

now i am unable to get a connection from cisco 800 router to the HP 1920 switch, it show an amber light .
It should not be related to change of NAT statement.

You changed

interface FastEthernet3
 switchport access vlan 10
 no ip address

to

interface FastEthernet3
 switchport mode trunk
 no ip address

Could be that port is error disabled, or could not negotiate speed.
Check status of your interfaces.
Interface shows that it is up:

FastEthernet3 is up, line protocol is up
  Hardware is Fast Ethernet, address is 2c0b.e9f7.8815 (bia 2c0b.e9f7.8815)
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:11, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 1000 bits/sec, 3 packets/sec
     34366 packets input, 4694385 bytes, 0 no buffer
     Received 6757 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     35069 packets output, 2621731 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     462 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     24 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out
sh ip int brief:

Interface                  IP-Address      OK? Method Status                Prot   ocol
FastEthernet0              unassigned      YES unset  up                    down  
FastEthernet1              unassigned      YES unset  up                    down  
FastEthernet2              unassigned      YES unset  down                  down  
FastEthernet3              unassigned      YES unset  up                    up    
FastEthernet4              210.9.149.58    YES manual up                    up    
NVI0                       unassigned      NO  unset  up                    up    
Vlan1                      unassigned      YES manual up                    up    
Vlan10                     10.2.0.1        YES manual up                    up
Where HP switch is connected?
You have 2 ports in up down state
FastEthernet0              unassigned      YES unset  up                    down
FastEthernet1              unassigned      YES unset  up                    down  
FastEthernet3              unassigned      YES unset  up                    up  


I thinks its the HP vlan settings that is the problem, not sure how to setup tagging ans assigning on HP web interface. Can anyone help
This is the setup on HP vlans:

VLAN Summary
ID      Description                            Untagged Membership                                                                        Tagged Membership
1      VLAN 0001                                        GE1/0/33                                                                                            GE1/0/1
10      Data                            GE1/0/1-GE1/0/32, GE1/0/34-GE1/0/52
The switch is connected through GE1/0/1  into   fastethernet3 on cisco 800
ASKER CERTIFIED SOLUTION
Avatar of Predrag Jovic
Predrag Jovic
Flag of Poland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Thankyou heaps...   that worked.   :)
You're welcome. :)