Solved

CRM 2016 Organization service not working

Posted on 2017-02-27
7
111 Views
Last Modified: 2017-03-03
I am trying to access an online CRM 2016 organization to create a report using Visual Studio 2012.  The format I used in CRM 2015 (https://apolloconsulting.api.crm.dynamics.com/XRMServices/2011/Organization.svc) apparently has changed:

I found a post that discusses this but I am still not able to access to the organization.  

I need someone to make me smarter on how to access an CRM 2016 using the organization service.

Thanks
0
Comment
Question by:apollo7
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
7 Comments
 
LVL 19

Assisted Solution

by:Rikin Shah
Rikin Shah earned 250 total points
ID: 42025743
Hi,

Have you tried removing ".api" from the url?
0
 
LVL 27

Accepted Solution

by:
Chinmay Patel earned 250 total points
ID: 42025746
Hi apollo7,

Good to see you :)


Especially the URL format is changed now:
https://msdn.microsoft.com/en-in/library/gg309401.aspx


For getting better using Organization Service, I suggest having a look at : https://msdn.microsoft.com/en-in/library/gg309449.aspx


Also, Please start looking at WebAPI as I do not see for how long Organization Service will stay relevant.

Regards,
Chinmay.
0
 
LVL 1

Author Comment

by:apollo7
ID: 42025765
Thanks to both of you for the responses.  

I will review the links and suggestion and let you know other questions I may have.
0
Threat Trends for MSPs to Watch

See the findings.
Despite its humble beginnings, phishing has come a long way since those first crudely constructed emails. Today, phishing sites can appear and disappear in the length of a coffee break, and it takes more than a little know-how to keep your clients secure.

 
LVL 1

Author Comment

by:apollo7
ID: 42028938
Both posts have helped me gain access to the organization service in CRM 2016.  

I still don't fully understand, however, where I get an 'org' string to put after "svc" in https://apolloconsulting.api.crm.dynamics.com/XRMServices/2011/Organization.svc
0
 
LVL 27

Expert Comment

by:Chinmay Patel
ID: 42029383
I am not getting what you are trying to say, can you please explain a bit more please?
0
 
LVL 1

Author Comment

by:apollo7
ID: 42031556
When looking at posts, I found the following.  Wanted to know how you get the arguments shown after the org service

There is an extra parameter needs to be added to the end of the current format, which is the SDK version:
http://Name_Of_Crm_Tenant/XRMServices/2011/Organization.svc?singleWSDL&sdkversion=8.0

This is the URL of the post:
https://joonsarena.wordpress.com/2016/04/06/ms-crm-2016-organization-service-not-working/
0
 
LVL 1

Author Closing Comment

by:apollo7
ID: 42032419
I am splitting the points because both posts suggested steps that allowed me to solve my problem.

Thanks very much.
0

Featured Post

Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

These instructions are based on installing Owncloud on your new raspberry pi connected with a usb HDD. What do you need Part A? A Raspberry Pi, model B. A boot SD card for the Raspberry Pi. A usb HDD An Ethernet cable to connect to the lo…
For cloud, the “train has left the station” and in the Microsoft ERP & CRM world, that means the next generation of enterprise software from Microsoft is here: Dynamics 365 is Microsoft’s new integrated business solution that unifies CRM and ERP fun…
The purpose of this video is to demonstrate how to set up the WordPress backend so that each page automatically generates a Mailchimp signup form in the sidebar. This will be demonstrated using a Windows 8 PC. Tools Used are Photoshop, Awesome…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

695 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question