when apply search old messages are not showing up in office 365

Dear Experts

We recently migrated to office 365 premium edition and I have downloaded the office 2016 configured my account in ms outlook and in offline settings have enabled the use cached Exchange Mode and Mail to keep offline is set for 12 months but when apply search it shows only to last few days where as I have mails from several months and this does not show up.

2. ms outlook search is not that great when we apply email in the search or any content phrase it does not filter exactly instead it shows relevant and non relevant and the list of messages is too many to locate what we exactly looking for, is there any best practice to apply search please suggest.  

request to please support on above 2 issues , thanks in advance
D_wathiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Edward PamiasTeam Lead RRS DeskCommented:
Why are you using cached exchange mode? We only use it for mobile users with laptops.
0
Mason DrewIT AdministratorCommented:
Did you delete the previous mail profiles out of the laptop, or remove them? If you did not, there could be a conflict of .OST or .PST file types.  We had this issue at my company as well. My users had to delete their .PST files and any other .OST files associated with Outlook. Once we did that, we had to rebuild the Outlook profile, but things started working right.
0
akbCommented:
You may need to rebuild the indexes. I had exactly the same problem with a client recently after importing mail from Windows Live Mail to their new O365 Outlook.
Go into Outlook, Options, Search, Indexing Options, Advanced and click on Rebuild.
It may take many hours to complete depending on how many emails there are.
To see how the indexing is going, click in the Search field in Outlook. On the ribbon bar click the Search tab. Then click Search Tools, Indexing Status.
When the reindex has finished try searching again.
Outlook search seems to only search for text or numbers, not symbols. To search for a phrase, put the phrase in double quotation marks. This may help narrow down your search.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
D_wathiAuthor Commented:
thanks one and all, have noted all these points and will proceed accordingly.  I am using the cached exchanged mode for all the end users who are using laptop/desktop  for the period of 12 months for the reason if they go offline due to internet down they should still be able to access the messages during last 12 months -- please suggest is this recommended

2. also can you please suggest how and where the offline cached mode can be set for iphone default mail App, and also for andriod devices please
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Office 365

From novice to tech pro — start learning today.