Applications stopped communicating with SQL 2005

Error:
A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
Verified that all services were started.
Named pipes were enabled.
TCPIP were allowed.
ozoneparkAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lcohanDatabase AnalystCommented:
This may be due to some DNS (or firewall) issue - did you tried connecting to it via the IP instead?
0
ozoneparkAuthor Commented:
All of our apps connect to the SQL database via IP.
0
lcohanDatabase AnalystCommented:
OK, so can you try a telnet from the app server where you get this error to see if the SQL server can be reached?

like in cmd prompt run:

telnet 111.222.333.000 1433

without any : and use the actual port if is not running on default TCP port 1433 - obviously replace 111.222.333.000 with the actual SQL IP

you can also run a command like below by that SQL IP to see where is your network broken link:

tracert 111.222.333.000
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

ozoneparkAuthor Commented:
This was the first thing we did to rule out the issue.  Port 1433 is open.
0
lcohanDatabase AnalystCommented:
OK so if the telnet is working fine to IP port 1433 and SQL is running on it so there's no reason why the app cannot connect to that same IP/port number right? Was there any deployment, or windows update in between the time when this was working and current state?
0
ozoneparkAuthor Commented:
No updates or deployment.  They just stopped working yesterday afternoon.
0
lcohanDatabase AnalystCommented:
I mean you could try create a ODBC on that app server and "test connection" but that will just proof the SQL is not the issue in this case and I think you need to check app config files and maybe try an IISRESET
0
ozoneparkAuthor Commented:
Modified the app to bypass checking SQL.  The app worked so this showed me that the issue is a connection to SQL.  Checked all of the config files and recycled the app pool as well as rebooted both servers.  (I have a second server with the same apps and I am getting the same error message)
0
lcohanDatabase AnalystCommented:
Could you try create a ODBC on that app server using exact same IP/port/credentials and "test connection"?
Also, on the SQL Side  - is there anything error/warning related in the SQL Log files by any chance
0
Jason clarkDBA FreelancerCommented:
you may also try to
Restart your MSSQLSERVER service. sometimes it works. Also, check Instance name(.and /)
have a look here: http://www.sqlserverlogexplorer.com/fix-error-message-40/

hope this will help you.
0
Daniel JonesData Research AnalystCommented:
  • Enable Named Pipes SQL Config Manager
  • Restart the server SQL Config Manager
  • Use proper server and instance names
0
ozoneparkAuthor Commented:
Apparently under Windows Server 2008 R2 it is not followed to the letter adding more websites (IP addresses) to the Server which resulted in the primary address no longer being used. There is a known bug that causes this. Only the primary IP is allowed to communicated with the SQL server or other servers in which we allow.  This server is in the DMZ.  It in fact assigned one of the other IPs that have been added that this server starting to use as a primary server IP and only the primary IP is allowed communication.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2005

From novice to tech pro — start learning today.