Avatar of Server Guy
Server Guy
Flag for United Kingdom of Great Britain and Northern Ireland asked on

No NDR to Distribution Group in Exchange 2013

Hi all,

We've recently noticed that our distribution groups are not receiving NDR's.
We've tracked the NDR message through our mail filtering solution and mail server but members of the distribution group do not receive the NDR's. We are using Exchange 2013 and my initial investigation displayed a number of articles which advises that this is not supported.

Does anyone know for sure if it's supported or not, if no can someone suggest a slick workaround.
Exchange

Avatar of undefined
Last Comment
Mahesh

8/22/2022 - Mon
Tom Cieslik

Run this command in your Shell
Get-DistributionGroup distributiongroup@yourserver.com | FL *report*
ReportToManagerEnabled : False
ReportToOriginatorEnabled : False

If you'll get 2x False then you need to modify one to True

Note Only one of these Active Directory attributes should be set to True. Setting both attributes to True produces unexpected results.

To make this setting, set one of these attributes to True on the on-premises object (depending on the desired behavior), and allow for MMSSPP replication to the Microsoft Exchange Online environment.

You can also fallow this article
http://msexchangeguru.com/2015/07/08/delivery-status-notification-distribution-groups/
Mahesh

what do you mean by DL is not getting NDR?

DL do not have any mailbox to receive NDR and to further distribute it with users

I am not sure what you are exactly asking?
Server Guy

ASKER
Thanks Tom, I'll give this a go.

Sorry if I was not clear in my explanation Mahesh, what I mean is that the members of the DL are not receiving NDRs.
Your help has saved me hundreds of hours of internet surfing.
fblack61
Server Guy

ASKER
Hi Tom,

I tried setting the below but unfortunately this hasn't resolved our issue.

ReportToManagerEnabled : False
ReportToOriginatorEnabled : True

We can track the NDR coming in but it doesn't arrive in any of the members mailboxes.
ASKER CERTIFIED SOLUTION
Mahesh

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Server Guy

ASKER
Hi Tom,

Interestingly I've noticed that I don't have the manager attribute but an owner attributes which maybe just a naming change down to exchange version.
We're using exchange 2013.

I've made the below changes and added a manager to the manager field on the distribution list which seems to have resolved the issue.

ReportToOwnerEnabled : True
ReportToOriginatorEnabled : False

I will be carrying out further testing, thanks for your help.
Server Guy

ASKER
We are still trying to tweak this for our environment but we've managed to get this working by assigning a manager to the distribution group and setting the ReportToOwnerEnabled attribute to True.

Thanks
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Mahesh

@Author,

Point should be divided between both
Tom has provided you base Idea and I have taken it further