Autodiscover working but outlook not connecting

timb551
timb551 used Ask the Experts™
on
Hi

I have an exchange 2016 server which has stopped accepting outlook 2016 connections.

I have tested the autodiscover which is fine but if i set an account up it autodiscovers and then says it cannot connect to the folders.

I have checked the internal and external urls and all seems fine.

I can connect using my iphone with out an issue if i manually put server name and domain etc in.

Please help

thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Tom CieslikIT Engineer
Distinguished Expert 2017

Commented:
I think you're talking about local outlook connection from same LAN
iPhone is using probably outside connection so autodiscover is pointing to your External MX with your External IP

Try create additional forward lookup zone in your internal DNS and name it like your server

email.yourdomain.com

inside put A record pointing to your local Exchange IP

(same as parent folder)     A     192.168.1.10    {for example}

Create second Forwart lookup zone

autodiscover.yourdomain.com

Inside point A record to your local Exchange IP:
(same as parent folder)     A     192.168.1.10    {for example}

Refresh DNS on workstation and start setup outlook again
Pavel NagaevLead email system administrator

Commented:
try to test connection setting using MS site https://testconnectivity.microsoft.com
You will see all errors :-)
IT Manager
Commented:
Ended up being a Trend Antirus server plugin that had caused the web.config to go a miss.

Link that helped

https://www.experts-exchange.com/questions/28948686/Outlook-clients-cannot-connect-to-exchange-Mobile-devices-connect-without-problems.html
timb551IT Manager

Author

Commented:
I sorted with the help of another EE post.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial