USB KEYBOARD AND MOUSE FAILS AFTER WIN-XP LOADS

One of our computers began having BSOD.  Running chkdsk /r at the Recovery Console brought the machine back to a full boot however now the USB keyboard and mouse are dead.   The keyboard works fine during boot into BIOS.

Looking for solution to get keyboard and mouse working again.
LVL 1
Lance McGrewRETIREDAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dr. KlahnPrincipal Software EngineerCommented:
You've almost certainly eliminated a hardware problem since the USB KB/mouse work during boot.  It's unfortunate that it's the Human Interface Devices that are failing, as that's the only way to talk to the system other than remoting into it.

I'd image the disk and then restore the system from the last full backup done before the problem occurred, and then restore changed files from the imaged disk.  But, if this is not practical or not desirable, it might be possible to investigate the problem further.

If the motherboard has PS/2 connectors, plug a PS/2 keyboard and mouse in, bring the system up, and

a) see if the USB controllers are recognized in Device Manager.  If they're not present or not recognized, perhaps reloading the chipset drivers will deal with the problem.

b) If the USB controllers are online, check to see if the HID Input Service is running (services.msc).  If the HID service has failed,  neither keyboard nor mouse will work.

Side note:  It would be prudent to take the system's hard drive to another computer, attach it, and check the SMART status on the drive.  If the drive is failing there's no point in repairing the software, at least not while it's on that drive.
0
Lance McGrewRETIREDAuthor Commented:
Machine has been tucked away in a remote closet, used exclusively for HVAC control.  We are in process of digging through archives to find original vendor.   Many different department personnel over last several years and records were poorly kept.  

No PS/2 ports, no remote access preconfigured.   Wondering if [link removed] might give us keyboard access and allow navigation to the Device Manager?
0
Dr. KlahnPrincipal Software EngineerCommented:
(Unfortunately, we are forbidden to discuss that particular software here on EE.)

Can you get the machine up in Safe Mode?
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

nobusCommented:
did you test with another keyboard and mouse - and on all different usb ports?
you can  also test if the problem exists in safe mode
0
RaminTechnical AdvisorCommented:
If bad sector occured  on HDD then Windows probably has lost some important data.
Install new Windows XP from scratch, and check if it solve the problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Sudeep SharmaTechnical DesignerCommented:
Have you tried changing the USB ports of Keyboard and Mouse? Put mouse cable on Keyboard USB port and Keyboard in mouse USB port and see if that works.

Thanks,
Sudeep
0
Lance McGrewRETIREDAuthor Commented:
Have tried other keyboards in all available USB ports.  USB ports become inactive beyond Post.

Current plan is to move HD to working machine and configure as slave.  Then try injecting USB chip drivers back on.
0
Sudeep SharmaTechnical DesignerCommented:
Is the machine accessible from network?

If it is, could you check if you can connect to the system using regedit and the option "Connect Network Registry".

there are certain registry entries I would like to check.

Some AV like Kaspersky, when installed and when uninstalled do some registry changes which cause the Keyboard and mouse not to work.

Thanks,
Sudeep
0
nobusCommented:
post the minidump - when the disk is slaved to another pc
find it in windows \minidumps
0
Lance McGrewRETIREDAuthor Commented:
Attached copy of most recent mini dump.  We now have visibility to the drive.  What next please?
Mini010917-01.dmp
0
nobusCommented:
it tells me you have a problem with your disk hardware
best run the manufacturers diagnostic on it - i use the UBCD for this :
Hardware diagnostic CD    UBCD
---------------------------------------------------
go to the download page, scroll down to the mirror section, and  click on a mirror to start the download
Download the UBCD and make the cd   <<==on a WORKING PC, and boot the problem PC from it
Here 2 links, one to the general site, and a direct link to the download

since the downloaded file is an ISO file, eg ubcd527.iso - so you need to use an ISO burning tool
if you don't have that software, install cdburnerXP : http://cdburnerxp.se/

If you want also the Ram tested - run memtest86+ at least 1 full pass,  - you should have NO errors!
 
For disk Diagnostics run the disk diag for your disk brand (eg seagate diag for seagate drive)  from the HDD section -  long or advanced diag !  (runs at least for30 minutes)

http://www.ultimatebootcd.com/      

**  you can make a bootable cd - or bootable usb stick
*** note *** for SSD drives  use the tool from the manufacturer, like intel 's toolbox :
https://downloadcenter.intel.com/download/18455/Intel-Solid-State-Drive-Toolbox

for completeness -here's how i handle disk problems : http://www.experts-exchange.com/Storage/Hard_Drives/A_3000-The-bad-hard-disk-problem.html

==>>****in order to be able to  boot from CD or usb - you may have to disable secure boot in the bios
0
RaminTechnical AdvisorCommented:
it shows no specific driver problem,
reinstalling Windows is the easiest way to find out if this is a hardware problem or a software problem. some Windows files became corrupted when bad sector happened and it is not easy to determine which files.
0
Lance McGrewRETIREDAuthor Commented:
Using FOG server, we pulled an image from the troubled computer and pushed onto a similar computer, a Dell 745.  Boot up is fine however same problem with non-responsive keyboard mouse after post.  The fact we can use the keyboard/mouse during post and both work fine booting from a Paragon Linux disk utility CD confirm hardware is working.

Twice we ran GRC Spinrite with no errors reported on the cloned drive.

Next we booted from a factory Windows XP disk which recognized the existing Windows XP install.
We attempted to run Repair.  We see the screen that indicates 39 minutes remain and a few more minutes, the install halts with screen messages attached.  Launchingthe repair from either Windows XP disk indicated an "upgrade" was being attempted after selecting the R for repair option ( not the first R for Recovery )  We used the second R for Repair.

Only other option we can think of now is to try finding an original Dell 745 Windows OEM disk to boot from and try the Repair.
IMG_1983.JPG
IMG_1982.JPG
0
nobusCommented:
the igxpmp32 error relates to  Intel Graphics Accelerator  - try uninstalling it for a test - or install the latest version
0
Lance McGrewRETIREDAuthor Commented:
We were unable to resolve the original issue with any of the other suggestions.
0
RaminTechnical AdvisorCommented:
I am glad you got it working, and Thanks.
0
Lance McGrewRETIREDAuthor Commented:
Ramin, we had to resort to calling in the HVAC OEM.  Not being able to resolve the non-responsive keyboard/mouse in a timely fashion called for more extreme measures.  If someone else stumbles onto this thread in the future, your suggestion to reinstall OS will likely be their answer. I still think there should have been a registry hack or driver reinstall that would have fixed our original issue.
1
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
USB

From novice to tech pro — start learning today.