We help IT Professionals succeed at work.

DNS server picking up wrong IP address of server

369 Views
Last Modified: 2017-03-14
Hi all,

Have an odd one. Just built a 2016 server (VM) and done the usually changed the DHCP address to a static as configured on the NIC. However rather than updating the DNS record it keeps adding the wrong address in teh DNS entry.

I have checked the DHCP server and deleted the original lease.

I have deleted the DNS entry and and run an registerdns command from server.

I have gone into registry of server and cleaned out any old NIC entries.

Not sure what where to go next....
Comment
Watch Question

Delete the NIC from VMware and add a new one.

Author

Commented:
Already done that.
Try

netsh interface ip set dns name="NIC NAME" static x.x.x.x
Top Expert 2015

Commented:
configure static DNS reservation with MAC+IP, so that dhcp does not issue IP to others.
Senior System Administrator
CERTIFIED EXPERT
Commented:
This problem has been solved!
(Unlock this solution with a 7-day Free Trial)
UNLOCK SOLUTION

Author

Commented:
Ran teh command and it accepted the it without error.
Satish AutiSenior System Administrator
CERTIFIED EXPERT

Commented:
Whats the result. if not accepted then run the command twice... with error or without...
I have run into an odd issue in the past where a IP of a VM was still reachable after the VM was powered down and deleted. After working with VMware support the issue was with the host and was cleared with a reboot of the ESXi host.  As a test have you tried to vMotion the VM to another host to see if the issue persist?
Not sure how changing the ip address with netsh updated the dns record.

Author

Commented:
Not sure but that was the last thing I did and it worked.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions