Netgear modem router default firmware

http://downloadcenter.netgear.com/en/product/DGN3500#searchResults
is the link to download my firmware. Problem is - it's saying "North America only". What gives? I'm in the UK
LVL 87
CEHJAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

John TsioumprisSoftware & Systems EngineerCommented:
If you go to the above just a bit up and to the left you should see a combobox for Country
Just select "other" and you should get the complete list of available firmwares.
Probably it will redirect you to the beginning so remember to select as Country -->Other
The download link for all countries except North America is link
Before you update your firmware  do check your current version...maybe its unnecessary to do the update
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CEHJAuthor Commented:
Thanks. I'm actually replacing OpenWrt
0
John TsioumprisSoftware & Systems EngineerCommented:
Good luck with this...OpenWRT ruined mine.....keep your fingers crossed..
0
Redefine Your Security with AI & Machine Learning

The implications of AI and machine learning in cyber security are massive and constantly growing, creating both efficiencies and new challenges across the board. Check out our on-demand webinar to learn more about how AI can help your organization!

JohnBusiness Consultant (Owner)Commented:
Where did you get the router? I cannot see anything except North America only. Is there a security issue?

When I click on the link for firmware, it makes me register with the serial number of the router. Have you tried that?  

Here is the Amazon UK site for like routers

https://www.amazon.co.uk/Netgear-DGN3500-RangeMax-Wireless-N-Gigabit/dp/B003462RXU
0
CEHJAuthor Commented:
Yes, i put the serial number in. I got a firmware - unfortunately not with the highest version number but maybe that's not sigificant
0
CEHJAuthor Commented:
Good luck with this...OpenWRT ruined mine.....keep your fingers crossed..

Oooh. Did you try to reinstate the stock firmware and if so how?
0
JohnBusiness Consultant (Owner)Commented:
You may not need the very latest firmware. Can you try what you did download?
0
JohnBusiness Consultant (Owner)Commented:
Did you try to reinstate the stock firmware and if so how?

You can try a factory reset of the router.
0
John TsioumprisSoftware & Systems EngineerCommented:
I am afraid it was ruined beyond repair...the firmware  messed up with the partition tables and bye bye...but i tried to do it via web...with the serial it should work...
0
CEHJAuthor Commented:
Thanks.
0
Natty GregIn Theory (IT)Commented:
Never flash your router for the first time via web console, It said so with red letters, always cable in and the 30/30/30 rule will always get you back from a brick situation to where you can reload the firmware. Just need patience.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.