Link to home
Create AccountLog in
Avatar of Fordraiders
FordraidersFlag for United States of America

asked on

database opened as read only

Access 2010.

I have a problem that just creeped up.
Everytime I open a database  the database opens as ready only.

I have tried the suggestion from "stackflow" open the database as "read-only" close it and reopen while not closing access.
But does not help.
I checked my admin log in ...I'm logged in as admin ?

Thanks
fordraiders
ASKER CERTIFIED SOLUTION
Avatar of PatHartman
PatHartman
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of crystal (strive4peace) - Microsoft MVP, Access
crystal (strive4peace) - Microsoft MVP, Access

if the database is on a network drive, then copy and paste to your local drive.  If all is good then it may be a permissions issue on the network -- if not, we can explore further

[editing]
I see Pat has given you some good information too ~
right click on the db app you are working on
select Properties > see if the Read only attribute was selected
Avatar of Fordraiders

ASKER

looking into this issue  "Therefore, if you do not have create permissions on the folder holding the database, Access cannot create the lock file and will open it read only.  Same for update permissions."
Check your antivirus....lately i have locking issues due to antivirus....disable it or better un install it...report back...
You can see the lock file be created when you open the database.  For an .mdb it will be samename.ldb and for an .accdb, it will be samename.laccdb

If the lock file doesn't appear, your permissions are incorrect.
adding on ...

> "Everytime I open a database  the database opens as ready only"

as others have suggested, you can test the file permissions of what you are opening -- and if you have to change them ... where did the database come from?

if from a CD or other read-only media, it may have got the RO (read-only) flag set).

if from an internet resource -- sometime the file is BLOCKED. If this is the case:
1.      right-click on filename in My Computer or File Explorer
2.      choose Properties
3.      check the Unblock checkbox near the bottom
4.      click OK

... or perhaps you are opening the file from email or a ZIP?

in this case, save the file to a local drive and open what you save.
<ot>
hi crystal, good morning!!!
</ot>
Read-only attribute of the file may be set. This occurs automatically if you use a compact disc-recordableor a compact disc-rewritable to move the file.
Have a look here: https://support.microsoft.com/en-us/help/324666/you-receive-a-you-are-trying-to-open-a-read-only-database-error-message-when-you-open-a-database-that-was-created-in-an-earlier-version-of-access-in-access-2002,-access-2003-or-access-2007

or You may also check this: http://stackoverflow.com/questions/5954982/access-database-opens-as-read-only

Hope it works for you.
Thanks, It all was down to folder permissions.
I have no idea how they were reset.
but reset them and works fine now.

Let me in the right direction.

Thanks
Pat