We help IT Professionals succeed at work.

error when migrating from ASP NET MVC 5, net fw 4.6  to ASP NET CORE fw NetCoreApp 1.1.

170 Views
Last Modified: 2017-11-28
Hello expert,
I am doing migrate from ASP NET MVC 5, net fw 4.6  to ASP NET CORE fw NetCoreApp 1.1.

The type 'Enum' is defined in an assembly that is not referenced. You must add a reference to assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'

The type 'DateTime' is defined in an assembly that is not referenced. You must add a reference to assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'
...

I guess all kind of this error derived from assembly incompatible, anybody know how to fix this issue?
I did add nuget Microsoft.NETCore.Portable.Compatibility but no help.

Thanks.
Comment
Watch Question

Systems Engineer
CERTIFIED EXPERT
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Dao NguyenApplication Developer
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.