Cannot uninstall program: Error opening the installtion log file.

I am trying to uninstall VIPRE anti-virus from a Windows 7 workstation. I get the message "Error opening the installation log file. Verify that the specific log file location exists and is writable." Of course, the message doesn't actually tell you what the location and file name is that it's having trouble opening.

All searches I've come across refer to MS Knowledge Base article  http://support.microsoft.com/kb/2564571, which basically gives the steps:

1. Stop the explorer.exe process from Task Manager

2. Open Task Task manager and start a new Explorer.exe task.

CTRL+ALT+DEL | Task Manager | Applications | New Task...

3. Retry the uninstallation again from "Program and Features". It should now allow you to successfully uninstall the affected software.

I've done this multiple times. It doesn't work for me. I continue to get the error message. How can I fix this?
LVL 1
MarkAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Shaun VermaakTechnical Specialist IVCommented:
Download MSIZap https://msdn.microsoft.com/en-us/library/windows/desktop/aa370523(v=vs.85).aspx and run after locating GUID in Registry
guid.png
0
MarkAuthor Commented:
Thanks, I'll try downloading that now, but what do you mean about the GUI in the registry? What is your image showing me?

more info .. The link you listed says, "This tool is only available in the Windows SDK Components for Windows Installer Developers"
0
Shaun VermaakTechnical Specialist IVCommented:
Thanks, I'll try downloading that now, but what do you mean about the GUI in the registry? What is your image showing me?
Installation each have a GUID. Use this path in registry to find GUID
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

Open in new window


more info .. The link you listed says, "This tool is only available in the Windows SDK Components for Windows Installer Developers"
Yes, part of download
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

BlayneyCommented:
Try uninstalling in safe mode. This often works for me.
But you will have to start the uninstaller service once you are in there. Follow this guide.

https://www.sevenforums.com/tutorials/117840-uninstall-remove-software-safe-mode.html
0
dbruntonQuid, Me Anxius Sum?  Illegitimi non carborundum.Commented:
Or try a reinstall over the present installation.

Then try the uninstall.
0
MarkAuthor Commented:
Blayney: I tried that guide. It did not work for me. I got "Windows could not start the Windows Installer service on local computer", and at the command prompt I got "The service name is invalid." I double checked to make sure I typed the registry entries exactly as described. I tried booting safe mode with and without networking.

Shaun Vermaak: I did download the winskd_web.exe Microsoft Windows SDK for Windows 7 and .NET Framework 3.5 SP1, but VIPRE is not listed in the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall collection. I supposed that means I cannot use the MSIZap tool without a GUID?
0
MarkAuthor Commented:
dbrunton: Tried installing, VIPRE outsmarts me. It says, "You are trying to install a product in the VIPRE family that has fewer features than  your currently installed version. To perform this migration, you will need to uninstall your current VIPRE product."
0
MarkAuthor Commented:
I've tried every suggestion I can find on the web including renaming the TEMP folder, deleting the VIPREInstaller.log and VIPREPRemiumInstaller.log, running the vipre installer from the command line, etc. Nothing is working. I need a way to get this program off this computer! Other ideas?
0
MarkAuthor Commented:
I got it uninstalled. I used a 3rd party program, Revo Uninstaller http://downloads.techradar.com/downloads/revo-uninstaller-free. That did it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dbruntonQuid, Me Anxius Sum?  Illegitimi non carborundum.Commented:
Have a look at this thread  https://support.threattracksecurity.com/support/solutions/articles/1000070667-how-to-manually-remove-a-vipre-business-agent

It is possible you have a Premium or Endpoint Security version installed but the instructions there seem to cover all versions.
0
MarkAuthor Commented:
I found a solution.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.