The specified domain either does not exist or could not be contacted

Hi all, from out of the blue all RDP users are getting this error when attempting to log in to the terminal server which is part of the domain. I can log in to the terminal server locally but any RDP users trying to log in get the error. Not sure where to start. It's odd that when specifying the domain locally is seems to see it and log me in.
Any help appreciated.
Thanks
Paul MontgomeryBusiness IT ProfessionalAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Joshua HopkinsPresidentCommented:
First thing would be to check the eventlogs on the server and see if there is an error for RPD services.  Make sure that they are running on the server and not hung.

I would also check to make sure that the DNS resolves to the correct IP.  If that has changed then users would see this issue.  Also check to make sure that an update did not adjust the local firewall settings and block users.
0
infedonetworkCommented:
Verify the DNS.
Do an Ipconfig /all to and make sure the DNS listed is the one that server the domain. Some time you may have a router that also assign IP and assign the wrong the dns. If that's the case disable the DHCP on the router and make sure the DHCP assign the proper DNS. If you have a DHCP server you can configure this on the scope options
0
Paul MontgomeryBusiness IT ProfessionalAuthor Commented:
Joshua: I don't see anything unusual related to RDP in the Event Viewer. The DNS resolves correctly back to the external IP here . Firewall is off.
infedonetwork: The router (Cisco ASA 5505) has dhcp disabled.

I doubt this is relavent but the DC is a VM running in Hyper-V. I also rebooted everything (host and all VM's)
0
Challenges in Government Cyber Security

Has cyber security been a challenge in your government organization? Are you looking to improve your government's network security? Learn more about how to improve your government organization's security by viewing our on-demand webinar!

Joshua HopkinsPresidentCommented:
VM should not make a difference.  Can you RPD to the terminal server via IP?
0
Paul MontgomeryBusiness IT ProfessionalAuthor Commented:
I definitely can hit the server. The problem is when trying to log in to the server it throws that message.
0
infedonetworkCommented:
You can try this but I have the feeling your problem is on the DNS: https://support.microsoft.com/en-us/help/947022/the-netlogon-share-is-not-present-after-you-install-active-directory-domain-services-on-a-new-full-or-read-only-windows-server-2008-based-domain-controller
Each time I had to deal with the same problem as you have now it was eider the wrong DNS or wrong entry on the DNS
Do a nslookup and type the DC name and see if it resolve to the proper IP
0
infedonetworkCommented:
Try this on the Domain Controller, Terminal server and the client PC
Reset DNS from CMD ipconfig /flushdns
Then try again
0
Joshua HopkinsPresidentCommented:
It sounds like it is not able to use DNS to authenticate against the DC.  Make sure on the Terminal Server that the DNS in on the network connection is statically set to the DC.  There could be other issues in your network such as AD replication causing authentication issues.  If the network connection is statically set then try to disable the connection and then re-enable it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Paul MontgomeryBusiness IT ProfessionalAuthor Commented:
Flushed the DNS, didn't help.
I did see that there was no static IP set in dns on the TS to point to the DC so I corrected that. There were static IP's set but they were to outside IP to the ISP. The preferred  DNS IP now points to the IP of the DC. I tried to connect to the TS from the outside and got the same message.
I don't have any AD replication going as far as I know. This literally happened overnight.
0
Paul MontgomeryBusiness IT ProfessionalAuthor Commented:
Spoke too soon. It must have taken a little while to propagate. Setting the Primary DNS IP to point to the DC fixed it. Odd that this even has worked for all this time.
Thanks for all the help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
RDP

From novice to tech pro — start learning today.