Avatar of Albert Widjaja
Albert Widjaja
Flag for Australia asked on

Troubleshooting AD GPO not applied tips and suggestion ?

People,

Can anyone please suggest me what else the steps and things to consider when troubleshooting Active Directory Group Policy not applying to my Windows client ?

For example logon script running .VBS applied but not working for one Windows 10 client, but applied successfully for the laptop in same OU.

I've tried:

1. Look in local workstation Eventvwr
2. GPUpdate /Force and restart multiple times
3. GPResult /R and compare it with my laptop that is working, but all seems to be same.

I'm running out of idea.

Thanks in advance,
Windows 10Microsoft OfficeMicrosoft Server OSActive DirectoryIT Administration

Avatar of undefined
Last Comment
Albert Widjaja

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Tom Cieslik

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Albert Widjaja

ASKER
Thanks Tom,

I appreciate your tips for the above, I think I have used your tips before resolving the problem few months back. :-)
What I'm looking for is the other ways or methods that I may have missed for troubleshooting GPO in general.
yo_bee

What is the VBS code? You can add some error checking.
https://technet.microsoft.com/en-us/library/ee692852.aspx

Were you able to successfully run the script manually on a Windows 10 machine?

For example logon script running .VBS applied but not working for one Windows 10 client, but applied successfully for the laptop in same OU.
I will assume that the Laptops in the same OU are Windows 7 machines.
Albert Widjaja

ASKER
The VBS code is just basically configuring the email signature template.

When I run it manually on the Windows 10 laptop using cmd prompt, it doesn't do any prompt or error, then nothing changed in Outlook.

Even after rebooting and running the script again while the Outlook is closed.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Albert Widjaja

ASKER
So how and where to see if Group Policy is not working for a client OS ?
is it from the windows server side event log or the client ?
Tom Cieslik

Run CMD as Administrator on some computer you want to test

GPRESULT /R /user   xxxxxx

xxxxx is your domain user name log on on this computer

Or if you want to check remotely

GPRESULT /S  sytemname /R /user   xxxxxx

systemname replace by computer name you want to test and xxxxx by user who is using this computer
(RPC service) must be ON on this machine


You'll get all informations
Albert Widjaja

ASKER
@Tom: if I follow your first step to map the network drive GPO with WMI filter, does it going to break the existing Windows 7 drive mapping ? Because at the moment the Windows 7 workstation works fine, but only 1 or 2 Windows 10 got this issue of not mapping.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Tom Cieslik

As long as there is no duplicates, then no.
But if your user has let say X:\ drive mapped to  \\server\share and you'll create X:\ drive to different location on the server in GPO then GPO will overwrite user settings.
Albert Widjaja

ASKER
Tom, somehow the mapped network drive in those two users is not mapped to anything at all.
I assume yes, the GPO should overwrite anything mapped with the same drive letter.
Albert Widjaja

ASKER
See this one GPO that is not working:

Drive GPO
Somehow it is not working for that one particular person, it is the most important thing to resolve.
Your help has saved me hundreds of hours of internet surfing.
fblack61
Tom Cieslik

what is the result when your run from his computer ?

GPRESULT /R /user   xxxxxx
Albert Widjaja

ASKER
Thanks !