Link to home
Start Free TrialLog in
Avatar of johnyu1997
johnyu1997

asked on

Window 10 cannot access internet with static ip

I recently switched to the new computer and our company all uses static ip to connect to internet.   The new computer seems like it only works for dhcp but not static ip.   My old computer uses window 10 also and had the same problem before.   The problem goes away after some kind of window update.  I try to run window update but it says it has some kind of issues and try to rerun later "does not show any error code".  I reset window update many times but it still won't finish the update.   It is for the update of version 1607.   My window 10 is the professional one and the build is 10240.  The static ip works ok because I tried it on the other computer.
Avatar of Ramin
Ramin

Go to below link, open/save  the Windows Update Troubleshooter, and follow the steps in the wizard to find and fix the problem.

https://support.microsoft.com/en-us/help/10164/fix-windows-update-errors
have you tried leaving it on dhcp to run windows updates.. and confirmed that the static ip is not confl
My window 10 is the professional one and the build is 10240

That is very old. Update to 14393.953 (current) and see if this fixes the issue. There were networking fixes to 10240.
Separately, if you wish for a bit of a normal life, use DHCP. It just works better. Static IP for workstations basically died some years back.
And you remember to set a dns server in the static settings, too, right?
Avatar of johnyu1997

ASKER

Window update troubleshooter cannot solve this problem.  I do have dns server set in there.
What's the update on this problem?
I cannot download specific update anymore from microsoft, right?  It has to go through window update.
You must use Windows Updates - yes.
It just says it has minor problem and will try later, but no error code.
try 8.8.8.8 for DNS and retest.
Not related to dns.  It cannot even ping the internal gateway. It can when using dhcp.
Try 8.8.8.8 does not work.
Please try this:

First remove WIFI drivers in the Device Manager. Then log out from Microsoft account ( if you are logged in with it ) and log in to local account. Then reboot.  install wifi driver, set static ip address and try to connect to the internet.
First DHCP is better and you should use it.

But, did you try updating to a year newer than what you have?  

If need be do a Windows 10 repair. No need to lose anything.


Go to the Media Creation Link

https://www.microsoft.com/en-us/software-download/windows10

Click on Upgrade to Windows 10 (even if Windows 10 is running), click on the Download button, select Open (Run) but NOT Save. It is possible you may need to go to the download location and run the program - it depends on exactly what MCL does (it changes from time to time). Allow the program to run. Allow drivers to update. Then select Keep Everything.
Did you set up ip address and subnet mask and default gateway on your adapter?
What is the configuration when on DHCP?
What is the configuration when you set it to static?
ASKER CERTIFIED SOLUTION
Avatar of johnyu1997
johnyu1997

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Because it works