RAID 1 volatile subkey Windows 7 64 bit

I use Ultrabac software for back up and restore, and bare metal restores. It works very well. I highly recommend it. Recently, I found a problem with restoring Win 7 64 bit machines to hardware with a two drive, RAID 1 array. This has never been a problem with Windows 10 64 bit Pro restores, regardless of the target hardware. The current target is an HP Z 420. I can put any Win 10 on there from any source without issues.

The main problem is once the Win 7 image is restored to different hardware, upon first boot, the Intel RAID 1 Volume IS there, the machine boots normally and starts installing all the drivers as expected. It also creates a RAID device that is missing a driver listed with other uninstalled devices. If I leave that RAID device as is, BSOD on reboot. If I uninstall it, I can reboot without incident, and this mystery RAID device comes back as it was before, seeking a driver. This does this against any and all Win 7 images NOT generated on the same kind of hardware profile.

The RAID device does NOT have a disable option in the contextual menu, just Update driver or Uninstall. I tried to install the RAID driver used in the boot disk that is used to run the restore jobs, Intel Rapid Storage RAID driver. Restore disks are built machine specific with RAID and Ethernet drivers injected into the restore disks as needed. When I try to install those drivers against that RAID device, it takes the drivers, then fails with an error "Cannot create a stable subkey under a volatile parent key." At that point, the RAID device becomes an unknown device, and at reboot, BSOD that I can't recover from.

The vendor has only seen this once before, and thinks there is a registry setting that causes the creation of this, what appears to be, an "extra" RAID device. Everywhere else one can check, the RAID is installed and working as single disk. The RAID works. If it didn't work, I would not get a boot cycle at all. This needs to be addressed via a registry setting, but we aren't sure how or where to address this "ghost" RAID driver that won't install, nor will go away.

Any ideas? Thank you.
afrendAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Gerald ConnollyCommented:
Isnt that a FakeRAID setup?

if so you will find going to a software RAID-1 setup will be more reliable (and faster)
0
Davis McCarnOwnerCommented:
The Windows 7 default drivers for the Intel RST are known to have numerous issues that are usually fixed with newer drivers; but, a question:
Are you using a BIOS driven RAID1 or disk management?
0
afrendAuthor Commented:
The RAID is assembled in the BIOS and shows up in Disk Management as a single drive.

Forgive my ignorance, can you explain to me the RST drivers you are speaking of? As mentioned, when using the Intel RAID driver against the uninstalled RAID device, that's when I ran across the whole volatile key error. Is that the same as the RST drivers, or is that different?

Thank you.
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Davis McCarnOwnerCommented:
Intel RST (Rapid Storage Technology) is software to manage Intel's hard disk controllers.
http://www.intel.com/content/www/us/en/architecture-and-technology/rapid-storage-technology.html

If; however, you are using a BIOS based RAID, you might think about disabling the controller until after the PC is working.
As a general rule, it is better to use disk management to manage a RAID 1 and to not use the BIOS.
0
afrendAuthor Commented:
Thank you.
If I leave the two disks as non RAID in the BIOS, then how do I create the RAID in disk management in the absence of an operating system?
I can "break" the RAID at the BIOS level, no problem, then lay the image down on one of the drives.
How then, do I make a true mirror in Disk Management?
In other words, in the BIOS, I can create Disk 0 as a Raid 1. In the O/S, I would need to use both Disk 0 and Disk 1, correct?
I'm not arguing the point, but confessing my ignorance. I've been doing server based RAID arrays at the BIOS level for many years going back to before SCSI Ultrawide. Only the last few years have I been doing two disk RAIDs at the workstation level. I have never used an O/S to manage a RAID, so please inform me. I always assumed the functionality and stability at the firmware level was a better way to manage RAIDs rather that at the O/S level.
Wrong?
0
Davis McCarnOwnerCommented:
1) The second drive must have no partitions on it (I would zero out the beginning of the drive and reboot. I might even disconnect the drive until Windows works the way I want it to.)
2) Here is how:
https://www.howtogeek.com/howto/36504/how-to-create-a-software-raid-array-in-windows-7/
(You want a mirrored volume)
0
afrendAuthor Commented:
Funny you should mention that! That's my next move, to physically disconnect the second drive.
Well, this just got even MORE interesting...
Before I pull down a working machine to run this test, I just broke up the RAID 1 in the BIOS. (Intel RST)
I installed the image to one of the disks, and it stills boots and runs...
AND...
STILL tosses that RAID driver in there, and replicates that driver on reboot.
Now, take a look at these captures. Note that even though I "broke" the RAID, the second disk still mirrors the first, but now appears Offline.
I guess I now HAVE to find a completely different machine without a BIOS based RAID controller, and/or just physically unplug one of the drives and do it all over again. I'll try it again with one physical disk attached and see what happens first as I really haven't anything "laying around" with the disk size I need. (230 GB)

My thinking is, this RAID thing just isn't going to work with Win 7 unless it is going back on the same hardware, in this case, a Z 420. I did take an image from a non RAID 420 and had no problems moving it to the RAID 1 420, but when I move to an image from a different hardware profile, the problem persists.
devicedevice2
0
Davis McCarnOwnerCommented:
Did you create the image on a PC that was in a RAID1 setup?
That will cause you untold grief in part; because, Windows ties the array to the serial numbers of the drives and the controller.
0
afrendAuthor Commented:
I really haven't had that issue with Ultrabac at all, but no, the image came from a single drive machine.
All I've ever had to do is reactivate Windows with the COA on the fresh hardware.
Ultrabac for Win 10 works GREAT, RAID, non RAID, 32 bit, 64 bit, it doesn't care at all.
That's why it surprised me this was such an issue with Win 7.
0
Davis McCarnOwnerCommented:
Unplug the second drive, reimage the first, get it setup, and I'll bet the problem goes away.
0
afrendAuthor Commented:
Confirmed.
Even with the second drive physically disconnected, the restoration still seeks a RAID driver.
There must be something in the driver, and I NEED to inject a storage driver to mount ANY drive:

iaStorA.sys is the one that allows that.
After the image is on the drive and rebooted, there should not be a RAID issue.

The source machine is NOT a RAID machine.
Next week, we try this with a non RAID machine.
0
Gerald ConnollyCommented:
I think you need to disable the RAID in the BIOS
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
afrendAuthor Commented:
I'm think that I need to find a SATA interface NOT governed by the RAID BIOS, for starters.
This RAID BIOS is actually disk management, even with the option used, "Reset disks to non RAID."

I think you are right that something feeds it from the BIOS level causing the O/S to seek out a RAID that just is not there.

Thank you.
0
afrendAuthor Commented:
How soon we forget, and how easily spoiled...
On the Windows 10 machines, moving a single drive image to a RAID is no problem.
I never have to touch anything in the RAID BIOS.
Apparently, Win 7 is a different animal.
I went into the main BIOS under Storage Options, and changed the setting from RAID+AHCI to IDE SATA.
Problem solved.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
RAID

From novice to tech pro — start learning today.