Avatar of Sean
Sean
 asked on

"The SMTP address has no mailbox associated with it" error when you access a user's mailbox by using EWS application

We are trying to Connect Dynamics 365 (on-premises) to Exchange Server (on-premises) to do server side sync. I have done these steps https://technet.microsoft.com/en-us/library/mt622062.aspx 

Using CRM 0216.

Every time i "Test and Enable mailboxes" none go out and the alerts shows: "The SMTP address has no mailbox associated with it" error when you access a user's mailbox by using EWS application" (See picture)

I have set up and added the application impersonation as well.

I have verified user credentials are good, and ports are accurate, the machine is updated to Cumulative Update 9 for Exchange Server 2013, I have rebooted, restarted services etc, i tried different users and credentials.
Capture.PNG
Capture2.PNG
* Dynamics CRMExchange

Avatar of undefined
Last Comment
Sean

8/22/2022 - Mon
Satish Auti

Are you trying to configure it with mail-enabled user or it's mailbox. because mail enabled user does not have the mailbox attributes.
Mohammed Hamada

I guess it might be SPN issues with user's AD Object. or it could be the EWS is not configured properly the Autodiscover for Exchange might not function as expected.

Try testing impersonation using https://testconnectivity.microsoft.com/
Go to Service Account Access (Developers) under Exchange Server

There make sure you select "Use Exchange Impersonation" and type the user you're impersonating and the user that has impersonation ... you can see the issue there.
Sean

ASKER
connected successfully (snap shot of results). i did not see any options for impersonations on that site.
Capture.PNG
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
Satish Auti

Good to here that
Mohammed Hamada

When you go to the MS test site make sure you Pick this test "Service Account Access (Developers)" not EWS
Under this connectivity you can test the Impersonation.. I guess there might be a problem with impersonation .. I have done for an online app and it worked pretty well for me but I needed to configure new Role for Impersonation not adding it under an existing one.

The command that would assign impersonation to the User which you're using is this
New-ManagementRoleAssignment –Name:"Impersonating" – Role:ApplicationImpersonation –User:"CRM admin User"

You could show us the result of the current user that's assigned impersonation
Get-ManagementRoleAssignment -RoleAssignee "CRM admin" -Role ApplicationImpersonation -RoleAssigneeType user
Sean

ASKER
my apologies Mohammed Hamada i dont see the option for Service Account Access (Developers) not EWS see attached.
Capture.PNG
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
ASKER CERTIFIED SOLUTION
Sean

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Mohammed Hamada

Great to hear that :) , You can close the question by selecting your own post as the answer.
Sean

ASKER
figured out the problem.