We help IT Professionals succeed at work.

Internet browsers time-out but can ping and connect remotely

1,427 Views
Last Modified: 2017-04-20
I had this question after viewing Internet browsers not working but can ping and connect remotely.

A Windows Server 2012, not the domain controller, on the network has this problem. All the computers do not have it. This Windows Server can ping all sorts of websites but times out trying to load webpages. It can load Google.com, open the links on the Google homepage (About, Privacy, Terms...) not the Google search results pages.

After each of the attempted fixes, we get the message:
The connection has timed out.
The server at XXX is taking too long to respond.
... check your computer's network connection ...

Open in new window


Things we have tried:
  1. Tried with Microsoft Internet Explorer
  2. Tried with Firefox
  3. Reset Firefox settings
  4. Cleared the Firefox cache
  5. Tried with Windows Firewall disabled
  6. Scanned for viruses and found none with Webroot
  7. Uninstalled Webroot
  8. Checked for proxy settings and tried with and without
  9. netsh winsock reset all - then restarted the server
  10. netsh int ip reset all  - then restarted the server
  11. Reset the Comcast modem/router
  12. Tried different receptacles on the network switch

Any ideas? Thank you in advance!
Comment
Watch Question

IT Engineer
CERTIFIED EXPERT
Distinguished Expert 2017
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
RaminTechnical Advisor
CERTIFIED EXPERT

Commented:
Install the latest network adapter Driver and check if it helps.
CERTIFIED EXPERT

Commented:
check your IP and your gateway/proxy ip (if any).
Maybe it can't get the correct ip.
CERTIFIED EXPERT

Author

Commented:
I will be able to test these helpful suggestions later today. Thanks!
What is so puzzling is that the problems occurs on just one machine with the firewall on that machine disabled. Other machines surf the Web just fine. And this one can pull up Google's pages but not search results and no other websites!
CERTIFIED EXPERT

Author

Commented:
Here is the traceroute to www.yahoo.com:
Tracing route to fd-fp3.wg1.b.yahoo.com [2001:4998:58:c02::a9]
over a maximum of 30 hops:
  1     3 ms     3 ms     7 ms  2603:XXxxxxxxxx:b900:fc91:14ff:fe44:cdff 
  2    22 ms    11 ms    19 ms  2001:558:4003:46::1 
  3    28 ms    16 ms    16 ms  te-0-2-0-5-sur01.sims.mn.minn.comcast.net [2001:XXXXXX:31::1] 
  4    15 ms    17 ms    14 ms  2001:XXXXXXXXX::2 
  5    11 ms     *       25 ms  be-29-ar01.roseville.mn.minn.comcast.net [2001:XXXXXXXXX::1] 
  6     *        *        *     Request timed out.
  7    25 ms    29 ms    29 ms  hu-0-11-0-0-pe04.350ecermak.il.ibone.comcast.net [2001:558:0:f8ce::2] 
  8    46 ms    49 ms    70 ms  2001:559::dba 
  9    31 ms    28 ms    29 ms  as10310.chicago.megaport.com [2606:a980:0:1::d] 
 10    58 ms    51 ms    47 ms  v6.ae8.pat1.bfz.yahoo.com [2001:4998:f00d:7::1] 
 11    71 ms    59 ms    59 ms  2001:4998:f01c:a::1 
 12    49 ms    58 ms    51 ms  2001:4998:58:fc1f::1 
 13    56 ms    53 ms    53 ms  2001:4998:58:fa00::15 
 14    48 ms   105 ms    68 ms  2001:4998:58:ce07::1 
 15    45 ms    55 ms    53 ms  ir1.fp.vip.bf1.yahoo.com [2001:4998:58:c02::a9] 
Trace complete.

Open in new window

I've inserted some X's for anonymity.
I ran a second traceroute and there was no timeout in the listing. The total time was 48 ms.
@Tom Cieslik - Do you see anything helpful from a troubleshooting standpoint? Thanks again!
Tom CieslikIT Engineer
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
Are you have IPv6 implemented in your network ?
If not it looks like your machine is preferring IPv6 over IPv4.
This can cause your problem, but fix is simple.

You can set your machine to prefer IPv4 over IPv6

https://support.microsoft.com/en-us/help/929852/how-to-disable-ipv6-or-its-components-in-windows
CERTIFIED EXPERT

Author

Commented:
I disable IPv6 in the Registry. No success. Here is the traceroute:
Tracing route to fd-fp3.wg1.b.yahoo.com [2001:4998:58:c02::a9]
over a maximum of 30 hops:
  1     7 ms     4 ms     1 ms  2603:3016:2103:b900:fc91:14ff:fe44:cdff 
  2     *       20 ms    20 ms  2001:558:4003:46::1 
  3    11 ms    14 ms    13 ms  te-0-2-0-5-sur01.sims.mn.minn.comcast.net [2001:558:32:31::1] 
  4    27 ms    20 ms    21 ms  2001:558:30:129::2 
  5    25 ms    29 ms    30 ms  be-29-ar01.roseville.mn.minn.comcast.net [2001:558:30:a9::1] 
  6    24 ms    23 ms    24 ms  be-13367-cr02.350ecermak.il.ibone.comcast.net [2001:558:0:f794::1] 
  7    21 ms    39 ms    39 ms  hu-0-11-0-0-pe04.350ecermak.il.ibone.comcast.net [2001:558:0:f8ce::2] 
  8    29 ms    28 ms    30 ms  2001:559::dba 
  9    27 ms    20 ms    26 ms  as10310.chicago.megaport.com [2606:a980:0:1::d] 
 10    43 ms    50 ms    49 ms  v6.ae8.pat1.bfz.yahoo.com [2001:4998:f00d:7::1] 
 11    53 ms    59 ms    51 ms  2001:4998:f01c:a::1 
 12    59 ms    58 ms    59 ms  2001:4998:58:fc1f::1 
 13    49 ms    44 ms    57 ms  2001:4998:58:fa00::15 
 14    54 ms    78 ms    46 ms  2001:4998:58:ce07::1 
 15    44 ms    60 ms    58 ms  ir1.fp.vip.bf1.yahoo.com [2001:4998:58:c02::a9] 
Trace complete.

Open in new window

Tom CieslikIT Engineer
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
This is IPv6 so I think is still bad

2001:558:32:31::1

Look on my tracerout without IPv6

Tracing route to fd-fp3.wg1.b.yahoo.com [98.139.183.24]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  50-246-185-126-static.hfc.comcastbusiness.net [50.246.185.126]
  2     8 ms     8 ms     7 ms  96.120.77.133
  3     8 ms     7 ms    11 ms  xe-8-2-0-sur01.levittown.pa.panjde.comcast.net [68.86.159.237]
  4     9 ms    11 ms    16 ms  be-24-ar03.ivyland.pa.panjde.comcast.net [69.139.192.57]
  5    10 ms     9 ms    10 ms  xe-4-0-0.edge1.toronto.level3.net [4.68.71.13]
  6     *        *        *     Request timed out.
  7    20 ms    37 ms    26 ms  yahoo-inc.ear3.newyork1.level3.net [4.15.212.174]
  8     *        *        *     Request timed out.
  9    24 ms    20 ms    28 ms  et-19-1-0.msr2.bf2.yahoo.com [74.6.227.151]
 10    20 ms    20 ms    24 ms  unknown-74-6-122-x.yahoo.com [74.6.122.91]
 11    31 ms    23 ms    33 ms  po8.fab4-1-gdc.bf1.yahoo.com [72.30.22.39]
 12    20 ms    20 ms    21 ms  po-12.bas2-7-prd.bf1.yahoo.com [98.139.129.195]
 13    21 ms    21 ms    21 ms  ir2.fp.vip.bf1.yahoo.com [98.139.183.24]

Trace complete.


Like You can see I have IPv4 on the end of each hops, you have IPv6

Can you post your ipconfig /all
Tom CieslikIT Engineer
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
Did you restarted server after this registry changes ?
CERTIFIED EXPERT

Author

Commented:
Oh, sorry, no - I did not restart the server. We will try that after hours (CDT here).
CERTIFIED EXPERT

Author

Commented:
Ouch. Disabling IPv6 did not help. We still couldn't open websites. I suspect we are barking down the wrong trail.

After disabling it, the server lost its IPv4 address. Yikes! We were able to reset the static IPv4 address and now at least the server is accessible.

We followed this instruction:
Type 0xff to disable all IPv6 components except the IPv6 loopback interface. This value also configures Windows to prefer using IPv4 over IPv6 by changing entries in the prefix policy table.
from thisthis page. And also tried 0x 11, rebooting after each try. No joy.
Tom CieslikIT Engineer
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
Can you set google dns on NIC for test ?

8.8.8.8
CERTIFIED EXPERT

Author

Commented:
Has anyone else seen a problem like this? Only one computer on this local network has trouble opening web pages. But that computer can ping any website without any trouble.
Tom CieslikIT Engineer
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
Check search engine on server and if it's possible change (install) google search if you have Bing as default search engine.
Also disable all add-ons in web browser.
CERTIFIED EXPERT

Author

Commented:
I think we need more eyes on this issue. Tom, thanks for all the help.
As for web browsers, in the OP:
Things we have tried:
1. Tried with Microsoft Internet Explorer
2. Tried with Firefox
3. Reset Firefox settings
4. Cleared the Firefox cache
Tom CieslikIT Engineer
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
Did you try set google DNS I a suggested before ?
CERTIFIED EXPERT

Author

Commented:
The problem has not been solved, but I've chosen this one as Best Solution because the contributor tried very hard to solve the problem with this one and many other posts. I appreciate the effort.

If anyone else happens across this question and has any other ideas, please message me directly. At this point, it looks like a "nuke and pave" - reformat and Windows Server reinstall - would be the way to go.
Tom CieslikIT Engineer
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
Thank You Wells Anderson
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.