IIS 7 and executing pages using localhost

I am revising classic ASP pages and have installed IIS 7. I am using Windows 10 and developing locally i.e. localhost. It is bind to port 80 and there are no conflicts with other software that I am aware of. I created a new website, testsite, made sure ASP was included. I created the virtual directory and Stop/started my web site. When I clicked on the "test connection" - it states "Authorization can not verify access to path c:\Inetpub\testsite"

When I click on the website, I can see my folder but not my pages.
When is use the url - http://localhost/testsite/test.asp - to test my page - it gives a 404 error.
I have also tried http://localhost:80/testsite/test.asp  - same results.
What is wrong and how do I fix it???
OverthereAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ryan ChongBusiness Systems Analyst , ex-Senior Application EngineerCommented:
is your ASP module installed for your IIS?

check this out, it should be similar for Windows 10.

Classic ASP Not Installed by Default on IIS 7.0 and above
https://www.iis.net/learn/application-frameworks/running-classic-asp-applications-on-iis-7-and-iis-8/classic-asp-not-installed-by-default-on-iis
0
OverthereAuthor Commented:
Yes, the ASP module was added. I am thought that would fix it but nooooo.
0
Ryan ChongBusiness Systems Analyst , ex-Senior Application EngineerCommented:
check this article out as well:

Warning: Authorization – Cannot verify access to path (C:\inetpub\wwwroot\)
http://blogs.msmvps.com/bernard/2009/11/04/warning-authorization-cannot-verify-access-to-path-c-inetpub-wwwroot/

btw, I assume if you're using local IP address instead of localhost, will that work for you?
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

OverthereAuthor Commented:
No the local IP address will not work either. I am a stumped chump.
0
Ryan ChongBusiness Systems Analyst , ex-Senior Application EngineerCommented:
you may want to verify and see through this checklist?

Localhost connection issues list
http://iislogs.com/steveschofield/2007/03/17/localhost-connection-issues-list/
0
OverthereAuthor Commented:
I will look into that. I did think of something that might be a solution. IIS creates a default web site that binds to port 80. I stopped that web site and my test site is bind to 80 also. I can not use port 81 because my Apache server is bind to 81. And I do not want to change Apache port - it works very well - I flip from IIS and Apache depending on what language.  So I was wondering that maybe I need to change the port my site is bind to - what other  ports can I bind to other 80 and 81? MY IP address is not static.
0
OverthereAuthor Commented:
I did some experimenting. I moved my pages to the default web site and the html pages will work. But the asp pages will not.
When I view MIME types, I see htm and html but nothing for asp and I have installed the asp.
I can type in http://localhost and receive the welcoming page. I can execute htm/html pages but now receive a 500 error.
0
Ryan ChongBusiness Systems Analyst , ex-Senior Application EngineerCommented:
This expert suggested creating a Gigs project.
what other  ports can I bind to other 80 and 81
any other ports will do.. but we need to configure this in your web server.

I moved my pages to the default web site and the html pages will work. But the asp pages will not.
try look for the first link I posted for resolution, to enable your IIS to run asp.

Classic ASP Not Installed by Default on IIS 7.0 and above
https://www.iis.net/learn/application-frameworks/running-classic-asp-applications-on-iis-7-and-iis-8/classic-asp-not-installed-by-default-on-iis

or you may need someone to troubleshoot the issue for you, if yes, you may try the Gigs or Live services in EE.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
OverthereAuthor Commented:
Thank you for responding and trying to help. I now have IIS 7 working. Here's what I did:
Created a restore point
 I uninstalled everything that had to do with ASP.Net .
That just left asp module.
I double- checked the IIS options (per the link https://www.iis.net/learn/application-frameworks/running-classic-asp-applications-on-iis-7-and-iis-8/classic-asp-not-installed-by-default-on-iis) to make sure I had checked only what it showed.
Did a hard reboot of my computer.
Recopied the file folders and pages back into the www default web site.
The conclusion I have is there is something with that particular page that is causing an error.
It is probably a coding error or I have left out a directive. The original pages were developed with Visual Studio 6.
The page that phews is encoded by <% %> tags which should be acceptable and should work. SO my thought is that there is something in the coding that is causing the 500 error. I have script debugging options turned on in IE 11. But it does not show me any errors etc.
I would think it would display the error(s). I know I used to debug in that manner. But don't remember now how .
Your thoughts....
0
Ryan ChongBusiness Systems Analyst , ex-Senior Application EngineerCommented:
SO my thought is that there is something in the coding that is causing the 500 error. I have script debugging options turned on in IE 11. But it does not show me any errors etc.
so, 2 points...

1. is that mean you able to run a simple asp script?

can you have a simple page just to response out the today's date time? like:

test.asp
<%
response.write "Now = " & Now()
%>

Open in new window


2. if there's a particular error in your script, what browser are you running your page? do you see something from the Windows' Event Log ?
0
OverthereAuthor Commented:
I was trying to post the below comment while you were posting! And yes the simple asp page displaying the datetime works.  - still have something not working - not showing what my errors is w/o using developer tools - it used to show the errors on the page. along with the http error page.
Thank you for responding and trying to help. I now have IIS 7 working. Here's what I did:
Created a restore point
 I uninstalled everything that had to do with ASP.Net . My computer executes faster now too - LOL.
That just left asp module.
I double- checked the IIS options (per the link https://www.iis.net/learn/application-frameworks/running-classic-asp-applications-on-iis-7-and-iis-8/classic-asp-not-installed-by-default-on-iis) to make sure I had checked only what it showed.
Did a hard reboot of my computer.
Recopied the file folders and pages back into the www default web site.
The conclusion I have is there is something with that particular page that is causing an error.
It is probably a coding error or I have left out a directive. The original pages were developed with Visual Studio 6.
The page that phews is encoded by <% %> tags which should be acceptable and should work. SO my thought is that there is something in the coding that is causing the 500 error. I have script debugging options turned on in IE 11. But it does not show me any errors etc.
I would think it would display the error(s). I know I used to debug in that manner. But don't remember now how .
It used to show me the error like 500 etc. but would also show what the script was too. Doesn't now. I would like to fix that too. Any clues?
I know I can use developer tools but the other way was much nicer.
Your thoughts....
0
OverthereAuthor Commented:
I think I may have that working now too - WHEW - what a mess, huh?!!
Again, I thank you. Always learning something new...
0
OverthereAuthor Commented:
Happy Happy! Thank you - this is why I love EE.
0
OverthereAuthor Commented:
I now receive detail errors with the error pages. I had to go into IIS and edit the feature settings to detail error messages. Here is the link that shows how to do it.
And I have included a snapshot.

http://stackoverflow.com/questions/2640526/detailed-500-error-message-asp-iis-7-5

:}
Edit-Details-Settings.JPG
1
Ryan ChongBusiness Systems Analyst , ex-Senior Application EngineerCommented:
Coool, tks for the sharing!
0
OverthereAuthor Commented:
Sharing is always good, and you never know - am sure others have had this problem etc.  :}
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP

From novice to tech pro — start learning today.