Link to home
Start Free TrialLog in
Avatar of Darius
DariusFlag for Lithuania

asked on

I'm using XML(xslt) - How to fix the BOM issue

Hi Guys,

I am using xslt(mapping) to create output xml file.
Issue: target system compline about added BOM character.

These outputs configurations does not fix an issue
<xsl:output method="xml" version="1.0" encoding="utf-8" omit-xml-declaration="no" indent="yes"/>
 <xsl:output method="xml" version="1.0" encoding="ASCII" omit-xml-declaration="no" indent="yes"/>

Open in new window


I'm using online validator to test output xml file
http://validator.w3.org/i18n-checker/#validate-by-upload+

results
User generated image
Any advice?

Thank you!
SOLUTION
Avatar of Gertone (Geert Bormans)
Gertone (Geert Bormans)
Flag of Belgium image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Darius

ASKER

We created an internal transformer service in C# that uses the class XslTransformer.
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Some of this information might be helpful, too.  I found that some common text editors will add a BOM, whether you want it or not.

See BOM is Decidedly Not Da Bomb in this article:
https://www.experts-exchange.com/articles/11880/Unicode-and-Character-Collisions.html
Thanks for the article reference Ray. Have just scanned through it but it definitely deserves some in detail reading later.