Link to home
Start Free TrialLog in
Avatar of Diane Burns
Diane BurnsFlag for United Kingdom of Great Britain and Northern Ireland

asked on

How to Stop Windows Security Warning when opening files on the Intranet

Hi,

I have an annoying problem I can't seem to find a solution to.  

We have hosted lots of files, mainly PDF's and TIF's on our Intranet within an iFrame.  When users open these files they are presented with this Windows Security warning:

"Do you want to allow files from this website to run on your computer?  you should only run files that come from websites that you trust."

When they click OK the file opens, but I need to prevent the pop-up all together.

I have tried many Group Policies, but none of them seem to work.  The policies include:

Do not preserve zone information in file attachments - enabled
Inclusion list for low file types - enabled - PDF; TIF
Trust logic for file attachments - enabled - preferring the file type
Turn on Enhanced Protected Mode - disabled
Intranet zone template - enabled
Site to zone assignment list - \\fileservername  1   \\domain.local  1  (same for all file servers)
Access data sources across domains - enabled
Allow active content over restricted protocols to access my computer - enabled
Allow file downloads - enabled
Launching applications and files in an iFrame - enabled
Use pop-up blocker - enabled - disable
Intranet sites: include all network paths (UNC's) - enabled
Turn on automatic detection of intranet

There are other policies applied as well, but these are the ones I think are potentially related to the issue.  I have checked that the policies apply to both the users and computers OU's

What am I missing?
WindowsSecurityPopup.JPG
Avatar of David Johnson, CD
David Johnson, CD
Flag of Canada image

add your site to the intranet zone
Avatar of Diane Burns

ASKER

Hi David,

Thanks for getting back to me.  

I've just checked all policies because I thought that this was already set, but it might have been removed because we still want users to be able to add sites to Trusted Sites zone from time to time.

I have read that you can set it in the registry instead which gives you this flexibility, then use GPP instead of policies.  Do you know the exact registry entry for this please? I've just gone to check my IE settings and Local Intranet is set to this User generated image
Many thanks
Update:

I have just manually added the key to my registry:

Computer\HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains\Intranet
New DWORD: http - 1

User generated image
Theoretically I can now add this as a GPP to my group policy for all users, but when I tested opening the files on my computer I am still getting the same security pop-up.

Any ideas?
Sorry to keep posting, but in case it helps, the URL for the hosted files is http://intranet/docs....

but the location where the files are stored within the iFrame and the file path that the security warning is complaining about is \\server\share\docs\...

I have also added this to my Intranet zone as servername  file  1

User generated image
But again this has not stopped the security warning
ASKER CERTIFIED SOLUTION
Avatar of Diane Burns
Diane Burns
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
this solution worked for our site