Issues in Apache upgrade while running make install on Aix

Hi All,

I'm trying to upgrade the Apache from 2.0.10 to 2.0.16 on Aix servers. I'm using the source and trying to compile it, but getting lot of issues with the make install script. I have compiled the apr and apr-utils and they seem to be working, but the apache scripts are giving issues.

Can anyone suggest me on how to create a installp fileset using the source or any other procedure to upgrade. Thanks.

krishna chAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dr. KlahnPrincipal Software EngineerCommented:
Did you run ./configure first?
What is the purpose in upgrading 11 years old version to 10.5 years old one?
IBM provides own apache build:
krishna chAuthor Commented:

Sorry for coming back late.

Yes I have ran ./configure before going for make script. Still the make and make install fails with errors relates to directories.

The Apache version given by IBM is not supported by them and moreover there are dependencies for this version like openldap and DB. I have tried installing the rpm which got installed in different location not like the original Apache version.

May I know if anyone of you tried to create a installp package from the Apache source code. Thanks.

Dr. KlahnPrincipal Software EngineerCommented:
Over the long term, you are probably better off installing the Apache kit from the Apache web site, rather than the AIX kit.  Difficult though it may be, and though ./configure may whine, it's a better option.

Here's my reasoning.  Apache is designed to run in the environment of the standard build, and while it can be shuffled around into other directories, it means customizing both the build options and the run options.  If you stick with a build that is as much standard as possible, the chances of a problem are reduced.   The chances are good that the next time an Apache upgrade is done, it will be someone else doing it and they won't know what you do now.

Since Apache has ongoing security updates (and this is an issue with a version as old as 2.0, when current is 2.2 or 2.4), running an old version (a) exposes your site to known vulnerabilities, (b) prevents your site from working with new versions of Secure HTTP, and (c) makes it harder to maintain for both site management and web designers, who will demand the latest-and-greatest features.

In this situation I'd pass the above along to your management and tell them that you really need to get to at least version 2.2 (legacy), and preferably 2.4 which is the active line of development.  If you put it into terms of "There's ten years of vulnerabilities unfixed in 2.0" you should get the necessary support.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Dr. KlahnPrincipal Software EngineerCommented:
Question is stale.  Comments were apposite; points divided among the contributors.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.