Issues in Apache upgrade while running make install on Aix

krishna ch
krishna ch used Ask the Experts™
on
Hi All,

I'm trying to upgrade the Apache from 2.0.10 to 2.0.16 on Aix servers. I'm using the source and trying to compile it, but getting lot of issues with the make install script. I have compiled the apr and apr-utils and they seem to be working, but the apache scripts are giving issues.

Can anyone suggest me on how to create a installp fileset using the source or any other procedure to upgrade. Thanks.

Regards,
Krishna
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Dr. KlahnPrincipal Software Engineer

Commented:
Did you run ./configure first?
Top Expert 2015
Commented:
What is the purpose in upgrading 11 years old version to 10.5 years old one?
IBM provides own apache build:
http://www-03.ibm.com/software/products/en/http-servers

Author

Commented:
Hi,

Sorry for coming back late.

Yes I have ran ./configure before going for make script. Still the make and make install fails with errors relates to directories.

The Apache version given by IBM is not supported by them and moreover there are dependencies for this version like openldap and DB. I have tried installing the rpm which got installed in different location not like the original Apache version.

May I know if anyone of you tried to create a installp package from the Apache source code. Thanks.

Regards,
Krishna
Principal Software Engineer
Commented:
Over the long term, you are probably better off installing the Apache kit from the Apache web site, rather than the AIX kit.  Difficult though it may be, and though ./configure may whine, it's a better option.

Here's my reasoning.  Apache is designed to run in the environment of the standard build, and while it can be shuffled around into other directories, it means customizing both the build options and the run options.  If you stick with a build that is as much standard as possible, the chances of a problem are reduced.   The chances are good that the next time an Apache upgrade is done, it will be someone else doing it and they won't know what you do now.

Since Apache has ongoing security updates (and this is an issue with a version as old as 2.0, when current is 2.2 or 2.4), running an old version (a) exposes your site to known vulnerabilities, (b) prevents your site from working with new versions of Secure HTTP, and (c) makes it harder to maintain for both site management and web designers, who will demand the latest-and-greatest features.

In this situation I'd pass the above along to your management and tell them that you really need to get to at least version 2.2 (legacy), and preferably 2.4 which is the active line of development.  If you put it into terms of "There's ten years of vulnerabilities unfixed in 2.0" you should get the necessary support.
Dr. KlahnPrincipal Software Engineer

Commented:
Question is stale.  Comments were apposite; points divided among the contributors.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial