We help IT Professionals succeed at work.

Weird Audio Problem Headset Windows 7

848 Views
Last Modified: 2017-05-24
I have a problem that is driving me nuts.

I work for a company one day a week.
This company has installed a new VOIP-telephone system (NEC s9100) a couple of months ago.
This VOIP-system comes with a softphone application (NEC UC SUITE).

Normally we should use the softphone with a plantronics usb-headset. But we were unable to make this work, thanks to encryption software that prohibits outgoing datastreams on the usb ports (HIBUN AE).
So we need to use the internal soundcard for this.
The laptops they are using are Lenovo Thinkpad T450's, with realtek soundcards that have only one jack (multistream) and all the laptops are installed with windows 7 64bit.

I have tried various multi-stream headsets (HP, Lenovo, ...) on these laptops, but most of these laptops have the problem that the mic doesn't seem to work in the softphone.
There is only one laptop, were both mic and earphone of the headset are working simultaneously. All headsets work on this laptop, so the problem is not coming from the headsets.
On all the other laptops only the earphone of any headset is working, but the mic doesn't seem to work in the softphone.

The headphones and mic are both selected as default playback device and default communications device.
I've tried to update the BIOS, update all drivers, adjust the audio to multi-stream mode in Realtek Control Panel, .... but the problem always persists. I can hear the other party in my headset, but the mic doesn't record anything.
Here is the weird part. When I try to record something with windows soundrecorder, i can record without any problem.
When i playback the recorde file i can hear myself in perfect quality.
Also when i go to Audio in control panel and i go to Recording Devices, when i talk into the microphone, i see the green bars moving next to the Headset-Mic icon. But in the softphone-app i can't get the mic to work on most laptops.

But there is one T450 were everything works just fine.
I've already made an image of this laptop and when i ghost any T450 laptop with this image. The softphone client works perfect on that laptop.
So I'm pretty sure it has to be a configuration/windows/settings problem that I just can't seem to find.
On the long run, i know that if i reinstall every computer with this working image, i can get past this problem.
But then i won't know the reason why this is happening and such a reinstall will take so much time (40 laptops).

Anyone that recognizes this problem and perhaps knows a solution?

One thing i was thinking about is to export all registry settings regarding audio and soundriver on the working machine, since all machines are identical regarding hardware. But for this part I don't know which keys i need to export, so any help on this one is also welcome.

This I really don't know what to do anymore.
Comment
Watch Question

CERTIFIED EXPERT

Commented:
At a guess it kind of reminds me of the old days when a laptop shared the audio device between the mic and the speakers from the motherboard,.
 Because it was a laptop everything had to be very small so connections were limited to one way only.
It refers to the transmission of data in two directions simultaneously.
For example, a telephone is a full-duplex device because both parties can talk at once. In contrast, a walkie-talkie is a half-duplex device because only one party can transmit at a time.
This was referred to as half duplex.
An example of a half-duplex system is a two-party system such as a walkie-talkie, wherein one must use "over" or another previously designated keyword to indicate the end of transmission, and ensure that only one party transmits at a time, because both parties transmit and receive on the same frequency.
Desktop and laptop computers once came with a half duplex sound card.
With audio streaming and Internet phone services gaining in popularity each year, newer computer models are coming equipped with a full duplex sound card as a standard component.
Even if someone has an older model, he/she can easily upgrade to the full duplex sound card and enjoy the benefits of full duplex sound.
I used to offer this virtual sound card so that owner the laptop  so they could use the steremix to record  what you hear in the speakers\
http://www.virtualaudiorecorder.com/
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Try to uninstall the softphone app, restart computer, install revo uninstaller, install the softphone app and remove the app using revo uninstaller. Restart computer.

Remove all devices on audio, restart computer and let windows reinstall the devices and install the softphone app again to test.
bdg 009Network Administrator

Author

Commented:
@Merete It's a realtek HD Audio soundcard. It has only one jack but it has multi-stream audio capability. More or less the same way your smartphone audio connector works. We also tried these headsets on an iphone and a huawei smartphone. All the headsets work without any problem, the mic also.

@Jackie Man: Thanks for your answer, but that i've already tried a couple of times. Doesn't help.

One thing, i've noticed. On the affected laptops (the ones where the mic doesn't work in the softphone app), it also occurs in skype.
One of the guys of NEC-support told me to try that, wheter to figure out if the problem is laptop related or software related.
The strange thing is that in skype the behaviour is exactly the same, i can hear through the headset, but the mic doesn't record anything.
When we try to record something with windows audio recorder, the mic seems to work well.
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Have you tried to do a clean boot?
bdg 009Network Administrator

Author

Commented:
Yes of course, that would be the very first thing i tried.

I'm breaking my head over this for about two months now, my customer is getting very annoyed that only one of his users can use the softphone-client like it supposed to be.
The softphone company (NEXTEL) says they can't support us, because we don't use the headsets that were supplied by them. (Their USB-headsets never worked, because of the encryption software, but now they don't want to troubleshoot our problem because they didn't provide these headsets)

I'm looking for an explanation of why this is happening, maybe then i can find a solution.
Or if anyone knows how to export all audio related settings from the registry, i might give that a try.

As last resort i can always reinstall these laptops with the working image, but i like to keep this as a last resort effort.
If i do it that way, i still don't know why it works on one laptop and why it doesn't work on all the other (identical) laptops.
If the problem reoccurs in the future, i want to have a quick way of repairing this issue, not reverting to a saved old image of these laptops.
David Johnson, CDSimple Geek from the '70s
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
<Type-based Device Control>
Prohibit the unauthorized transfer of data via various types of devices by prohibiting the use of devices.The supportable devices are Bluetooth, Infrared ports, Wi-Fi, Serial/Parallel ports, Data linkage cables, PDAs, Smartphones and etc.

<Device-specific Control>
Restrict users to copy data only to company authorized USB memory.Administrator can check the logs for the device information of the USB memory.


Has everything USB based been disabled i.e. keyboard/mouse? It sounds like the 'Security' Software' configuration needs to be tweaked.

This Security Suite's limitations seem a bit sketchy

When using Windows is 64-bit Edition, you can install HIBUN server software only in WoW64*1 mode.
CERTIFIED EXPERT

Commented:
bdg 009Network Administrator

Author

Commented:
@David Johnson:
I also suspect it has something to do with the security suite. USB transfer has been limited in the outgoing direction for sure, like you described above. Incoming usb data is not prohibited. Mouse/keyboard/usb hubs... all function as normal. Usb printers and usb headsets i've tried in the past and will not work due to HIBUN restrictions.
As for this reason we are obliged to work with headsets with a single audio jack (Multi-Stream).
I also suspect there is something blocking from within HIBUN, but when we contact their support they say that they don't block the use of the internal sound card and also the one Laptop where the software DOES work,  has been installed with HIBUN.

@Joinaunion: Thanks for your input, but i think these methods do not apply to my situation. I'm prohibited to install any other software on the softphone-server (3d party server, waranty limitations) and we don't use any usb-softphones in this company.
SteveArchitect/Designer
CERTIFIED EXPERT

Commented:
may be a long shot, but try disabling a 'feature' of Windows that is meant to make voice calls easier...

Control panel > Sounds > Communications

Try setting this to 'Do Nothing' and see if it helps.
bdg 009Network Administrator

Author

Commented:
@Steve
Tomorrow i'm onsite, will try your suggestion and keep you guys posted.
Thanks for your input already
CERTIFIED EXPERT

Commented:
Could you check, that the windows Audio and Windows Audio endpoint Service is start?
From what I have read  the WiDi software> Intel WiDi USB section should be uninstalled when having problems with the audio devices connecting to software with voip.
There is a service that runs in the background..
This maybe the restrictions you're referring to the>encryption software that prohibits outgoing datastreams on the usb ports (HIBUN AE).
 Apparently uninstalling the Intel Widi device from device manager, called something like  "wiusb"
 It is in its own group in device manager,
What is Intel WiDi?
http://www.shouldiremoveit.com/Intel-WiDi-9076-program.aspx
I also found these guides for you to help with troubleshooting
SoftphoneCompatibility.pdf
https://www.plantronics.com/au/media/downloads/SoftphoneCompatibility.pdf

ANSWER SOFTPHONE WITH USB HEADSET<< this may or may not apply to you as they are using ShoreTel 12.3 in an all softphone environment
ANSWER SOFTPHONE WITH USB HEADSET
https://forums.shoretel.com/viewthread.php?id=906C0000000H2RVIA0
If you are using a Plantronics headset, you might want to try the Spokes software: http://www.plantronics.com/us/support/software-downloads/
bdg 009Network Administrator

Author

Commented:
Ok i'm onsite now and already tried a couple of things:
 
1. Uninstalled WiDI --> no result, still can't get the mic working after removal of widi. (Laptop where the headset is working, has also WiDi installed)

2. Control panel > Sounds > Communications > Try setting this to 'Do Nothing --> doesn't change a thing.

3. In the meantime, I've reloaded another T450 laptop (where the headset wasn't working) with the system image that i've created from the laptop on which the headsets do work.
Now the headset works flawlessly on this laptop too. So i'm now 110% sure this isn't a hardware problem.
CERTIFIED EXPERT

Commented:
I agree, no 2 laptops are the same, even though it's the same manufacturer model year etc, when they are manufactured it's handed over to the brand name who then install the OS OEM, each brand has it's own OEM stamp in simple language.
So at the time you system imaged your T450 laptop it may have been in a different state from these others.
The image may not have included some of the preinstalled Apps such as these.
Lenovo® DOit Apps      
SHAREit
SECUREit
SYNCit
SNAPit
SEEit
http://shop.lenovo.com/us/en/laptops/thinkpad/t-series/t450/
bdg 009Network Administrator

Author

Commented:
Thing is, back in 2015 i created a clean system-image of a t450 with all company software preinstalled (except hibun AE and antivirus)  and all lenovo and other useless apps removed. (So none of these apps that you stated above are on any laptop in our network.)
This image i've been using to preload all the T450 laptops here (until the softphone problem started). Some of these i've just preloaded 2 months ago, and even on these i can't get the headsets working.
That's what i don't get at all. They all share the same father-system-image, but strangly the softphone was only working on one of these laptops.
Now that i've created a working softphone system image (from that one laptop) and i'm reloading as much of these laptops with this image. It's a very time-intensive solution, but it's the only trick i have left in my sleeve for now.
I do keep one of these faulty machines in their original state, so i can troubleshoot this problem some more.
I still keep on the lookout for a more easier solution and the source of this problem.
I don't want to reload every laptop again in the future, might this problem reoccur again.
So guys, your input in this topic remains highly appreciated.
CERTIFIED EXPERT

Commented:
ok, the first thought that comes to mind is the softphone software for one user? or a version that allows multiple installed?.

refs to>This company has installed a new VOIP-telephone system (NEC s9100) a couple of months ago.
This VOIP-system comes with a softphone application (NEC UC SUITE).
NEC drivers seem to be for Vista?
http://www.necdriver.com/NEC-Notebook-Driver/S-Series/Versa-S9100/
I'll do a little research for the licences permits per user for this software
If the software registers the chipset for that PC. And cannot be installed ??
https://www.necam.com/Unified_Communications/doc.cfm?t=UCSuite
All I found so far
As an integral part of the UC application suite, UC Desktop Client can be used as a standalone application, via an Internet browser or integrated with Microsoft® Office Outlook®.
https://www.necam.com/Unified_Communications/doc.cfm?t=UCEDesktopClient
CERTIFIED EXPERT

Commented:
Well I dont see anything about corporate licenses.
UC Suite for NEC SV9100 - Overview
http://au.nec.com/en_AU/solutions/unified-communications/messaging-and-presence/uc-desktop-suite-for-nec-sv8100-overview.html
With any software if it is not used as recommended could cause the problems.
Refs to>Normally we should use the softphone with a plantronics usb-headset.
But we were unable to make this work, thanks to encryption software that prohibits outgoing data streams on the usb ports (HIBUN AE).
So we need to use the internal soundcard for this.
Is the software outdated? 2002?
Solve One Way Audio-Step by Step
http://www.voipmechanic.com/voip-one-way-audio.htm

NEC SV8100 Telephone System User Guide
(for SV8100 12-button and 24-button phones with CAP/PARK keys)
https://www.alternativetechs.com/wp-content/documents/USER.SV8100_with_SV8100_12-and_24-button_phones.CAP-PARK.pdf
bdg 009Network Administrator

Author

Commented:
@Merete

1. We've got the installer of the software suite from NEXTEL.
They've supplied me the software (UC suite) and they assured me i can install it on every laptop/pc in our network.
We didn't get a limited number of installations/licenses and we don't need to activate the software after installation.
We only need to fill in a couple of parameters when we run it for the first time: the VOIP-server ip, the softphone username and password.
I've also thought about possible limitations per user account, but now 've already got a couple of systems working (based on the image of that one laptop) and it seems there are no limitations per user account. On the working systems i can login as any user and use the softphone without limitations.

2. I concur with your statement that if software is not used as recommended, it could cause the problems.
The problems with this installation are going back to the prerequisites.
Somebody had to test stuff like that before they started the installation.
I never knew anything about prerequisites or anything, I only work there one day a week.
A couple of months ago, i arrived there in the morning and i heard they were going to switch to a new telephone system that day.
So that day, they found out that the usb-headsets would never work, but at that point NEXTEL wouldn't/couldn't continue with the installation unless one of the managers signed a disclosure that the installation was not conform to prerequisites.
That was the beginning of this whole mess. Whenever i call Nextel support, most of the time, they inform me about this disclosure and that they can't support us in that part of the installation, sometimes when i'm lucky i can find a good soul overthere who wants to help me a little. Anyway, lots of mistakes have been made prior to the installation of this system, but now everyone is looking at me to clean up this mess and make this damned softphone working. I've already have one bypass solution (reload all the laptops), but that's solving it without knowing what's causing this. I'm still on the lookout for a quick solution, so i can solve future cases without reloading an entire laptop.

3. The software looks quite outdated (it is also very slow in loading time and definitely not user-friendly) . I'm not onsite right now, but I will have a look next time. The installer is for vista indeed, but Nextel assured me that it shouldn't be a problem to run on windows 7 ( as the architecture of both OS'es is nearly identical)

anyway thanks already for your time invested in this
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Can you list out all software installed for a working and non-working notebook?
bdg 009Network Administrator

Author

Commented:
@jackie

Next time i'm onsite, I will check it.
But I suspect the installed software will be identical on all notebooks,  since they all origine from the same grandfather-image and the users are prohibited to install any software, only admins can install software.
CERTIFIED EXPERT

Commented:
A couple of things you may want to check. I know this applies to vista but may work in your situation.

Changing Audio Settings in Vista
Successful operation of the softphone within Vista requires that the audio properties be set to a
supported format. The default settings for the audio device must be set within the range of values shown
in the following table.
Sampling frequency (Hz): 8000 / 16000 / 32000 / 48000
Quantization bit: 16 bit
Channel: all values supported

To change the audio properties for the Playback device:
1. On the Windows Control Panel, select the Sound option.
2. On the Playback tab, select the device to be changed and press the Properties button.
Untitled.png
3. Select the Advanced tab and set the default format to a supported setting.
 Untitled2.png
4. Select OK to save the settings.

To change the audio properties for the Recording device:
1. On the Windows Control Panel, select the Sound option.
2. On the Recording tab, select the device to be changed and press the Properties button.
Record1.png3. Select the Advanced tab and set the default format to a supported setting.
Record2.png4. Select OK to save the settings.
CERTIFIED EXPERT

Commented:
Wow. Sorry about the spaces in my post. Not sure what happened there. Sorry.
bdg 009Network Administrator

Author

Commented:
@joinaunion

The sampling frequencies are in the right format. i've already tried to change them. If they are set to unsupported formats, the softphone will notice you to change these values and the softphone application will not boot up, until you changed them back to the supported formats.
CERTIFIED EXPERT

Commented:
Well I dare say they will eventually come around to the idea that it won't work.
Basically what you're doing is a clean install of windows 7 ( imaged) without any possible driver changes or updates. As the image is from one period.
These non working systems may have new updates that changed how hardware work.
MS has been very busy rewriting the structure of windows by adding newer and newer features so that the average public will stop using windows 7 and upgrade to windows 10.
Only to find that a lot of stuff doesn't from our older windows 7 wont work in the w10 environment other than the basics..
Especially in the line of multimedia and communications.
Windows 10 is the final OS and from then MS hopes that we all give away  windows installed desktops and laptops and go as an App.
Microsoft Discusses a Very Limited Future for Windows 10 Mobile

USB headsets/mic can be finicky with laptops and the inbuilt mic./ versus the speakers also inbuilt and playback devices. in windows 7
Can you disable the mic since you want to use the mic on the head sets?
Have you run a test for the mic?
I have several headsets with mic, 1 Logitech and one connectland both are usb and often times in order to get them work right with PC desktop audio devices have to manually make my headset the default  playback.device.
When I remove them I then have to reset the speakers as default.
For some unknown reason my sound card ( Realtek HD ) won't immediately release the USB back to windows .

With the software you are getting an incoming call then pickup the call and speak .
But the mic doesnt work.
Do they have any budget?
Which particular brand is these headsets
plantronics usb-headset. is the brand but which model?
Blackwire? number??
Entera USb
is this included?
DA40 USB AUDIO PROCESSOR
Corded USB-to-headset adapter brings superior call clarity for PC calling.
Expand the connectivity options of your current Plantronics H-Series headsets with the DA40 USB adapter. With this corded USB-to-headset adapter and H-Series headset (traditionally used with a desk phone) you can now manage PC communications with superior call clarity.
Plug-and-play USB connectivity for fast, simple setup
Quick Disconnect capability allows the headset to detach without losing the call
PC Wideband delivers heightened speech clarity, providing the best possible PC audio quality (headset must support wideband audio)
Two year limited warranty
http://www.plantronics.com/au/product/da40

I believe that your only solution is to start the imaging install on all systems.
Hopefully not too many.
Since the software is getting old, possibly the headsets as well, you're tasked with an uphill battle.
With very little support, I commend you for your efforts so far endeavouring to try and fix it.
Know when to to say enough.
Regards and all the best.
 Merete
CERTIFIED EXPERT

Commented:
Was there a previous version installed before SV9100 and was it uninstalled prior to installing SV9100?

I assume your using a UC Server. Can you confirm if command 20-59-14 UC Server Settings – UC - License Level is set to 0?
0= Softphone.
Also command 20-59-14 UC Server Settings – UC - Login Mode should be set to 0 also. This defines user to use softphone.

Can you confirm ip has been assigned?
When the user logs in can you confirm they, Check the Login as Softphone check box. (unless you are using Plug and Play then this step won't apply)

Within the Uc suite can you select Tools then Preferences  select the audio tab. Can you confirm the correct audio device has been selected. In your case the realtek. Also confirm that  Enable Core Audio Option to use high quality audio  has been checked.
bdg 009Network Administrator

Author

Commented:
Today i was onsite again. Well the problem just got worse. Today i saw the same thing happening on a laptop that was just reloaded with the image that worked fine on 5 laptops till now.

Same thing all over again, headset works fine as for general windows functionallity. I can record just fine with default soundrecorder.exe, i can even voice control the OS with the headset. But in the softphone the microphone stays mute, regardless all the suggestions above.

I can confirm that there were no previous installations of SV9100. I can confirm all the other parameters you stated above. The UC Suite client connects well to the server,even over the vpn, all users have access to the softphone. I can make calls, only the microphone doesn't work.
USB headsets won't work due to the encryption/security suite HIBUN AE.
All laptops are Lenovo T450 laptops equipped with a realtek HD multi-stream audio internal soundcard (only 1 external jack), os: win 7 professional 64 bit sp1.
Headsets are all multi-stream audio headsets (1 jack). I've tried with headsets from hp, from lenovo, ... On the working laptops, they all work, on the other laptops, the mic never works in the nec uc desktop suite.
On some i got it working based on the image of another laptop where it worked, today i got a first laptop that showed the odd behaviour after a fresh reload.

One thing i know more since today, is that the current problem has likely nothing to do with hibun ae. The laptop today didn't have hibun ae installed yet.
Logically, I'm thinking towards an incompabilty between the UC Desktop Suite client and windows 7 sp1.
The Nec UC Suite is originally intended for windows vista, which shares overall the same architecture as Windows 7, but there was no multi-stream audio by that time.
But on the other hand that doesn't explain the five machines on which it does work, all sharing the same preload image.


For the moment i'm out of options.
CERTIFIED EXPERT

Commented:
Before we dig even further into this odd issue, can you run virus and malware scan on the pc's in question.

You can use malwarebytes and run free scan, https://www.malwarebytes.com//

In either case if issues are found quarantine or delete the problems found and reboot then try mic again.

Please post back results.

Oh. Do you have CTI installed? Do you use TAPI client?
bdg 009Network Administrator

Author

Commented:
I'm pretty sure it's not malware related. Yesterday it happened on a fresh reloaded laptop (on which i didn't even connect to the internet yet).
When I frist saw this behaviour, i scanned that laptop with adwcleander, mbam, zemana and superantispyware, with no result.

Anyway the behaviour looks a lot like this (seems always have something to do with the realtek Hd soundcard.
(tried these steps, but my problem persists and i'm unable to use usb headsets)

https://community.skype.com/t5/Windows-desktop-client/Mic-not-working-with-Skype-fine-with-other-apps/td-p/564471/page/1
CERTIFIED EXPERT

Commented:
Do you have the latest High Definition Audio Codecs installed?
You can go here click accept then click next, http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=24&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false

You can check your versions by opening windows media player. Once windows media player is open hit alt on keyboard then select help then about windows media player then click the technical support information link.
bdg 009Network Administrator

Author

Commented:
Well,

I install the drivers for ealtek from the lenovo website or the sound driver i get through lenovo system update (TVSU)
I tried once to install the general HD driver from realtek on one of the faulty machines.
It installs, but in the end it starts removing the current driver and when it wants to install the new driver, it fails and the computer needs to reboot.
After the reboot the souncard appears as 'High Definition Audio Device' in device manager.

The other thing (media player) i will try next time i'm onsite
CERTIFIED EXPERT

Commented:
We got somewhere...lol

If you can try installing the driver through device manager. Right click the device then select update driver software. Now select browse my computer for driver software. Then select let me pick from a list  of device drivers on my computer.

When the new window pops up click on Have Disk then select the download from my previous post.
bdg 009Network Administrator

Author

Commented:
@joinaunion

That way, i've tried it already and i could install it that way.
It doesn't make a difference and when i install it that way, i don't get a link to the realtek hd audio manager in the control panel.
CERTIFIED EXPERT

Commented:
Do you have control panel icons set to view by Large Icons?

Are you able to run it by going here, C:\Program Files\Realtek\Audio\HDA\RtkNGUI64.exe?
CERTIFIED EXPERT

Commented:
Hi guys
rehashing
I work for a company one day a week.
This company has installed a new VOIP-telephone system (NEC s9100) a couple of months ago.
This VOIP-system comes with a softphone application (NEC UC SUITE).

Normally we should use the softphone with a plantronics usb-headset. But we were unable to make this work, thanks to encryption software that prohibits outgoing datastreams on the usb ports (HIBUN AE).
So we need to use the internal soundcard for this.
The laptops  are Lenovo Thinkpad T450's, with realtek soundcards that have only one jack (multistream) and all the laptops are installed with windows 7 64bit

It seems to me that the problem is a sequence of things.
The Laptops didn't have the headset functioning prior to the installation of>(VOIP-system  with a softphone application (NEC UC SUITE).)
If the headsets with mic had run the mic setup firsthand got the mic tested and functioning possibly the (VOIP-system softphone application) may then have detected the headsets/mic and did it's thing then all should have been good.
It seems to be that a clean install works and that then makes sense with the sequence of things and the fact the image when installed is like a clean install and then the headset mic works.
So to me the problem is the Voip software was installed in the wrong sequence and has broken the mic port inside the plantonics usb headsets, as it is USB somehow windows cannot detect the mic from the headphones.
Run the windows mic setup.
Click the Start button , and type MMSYS.CPL in the Start Search box, and then press the ENTER key. ...
Select the Recording tab.
Select the Microphone/headset you want to configure.
Click the Configure button. ...
Click on the Set Up Microphone and follow the step-by-step instructions to test your microphone.

I believe you wont be able to do that since the mic port on the laptop is not able to utilize that audio port for mic as the mic is built into the Plantonics headset.
There in lies the conflict.
As the VoIP has been installed that has messed with the mic.
bdg 009Network Administrator

Author

Commented:
@merete
The headsets do work in windows. We tried the plantronics usb-headset on only 3 laptops, but couldn't get that to work on either of the 3, due to hibun ae.
The usb-headsets were only installed after nec uc desktop suite was installed, and this was all done by a technician from NEXTEL.

If the mic doesn't work in the softphone, it shows the same behaviour in Skype. In all other applications that i have tested, the mic works just fine. Like stated before, i can record sounds with any other programs (soundrecorder.exe, audacity), i can even configure Windows 7 to voice control the computer with this headset. Only NEC UC suite and Skype make the  mic useless (in these programs  i can't even record through the built in microphone (without headset)).
It's like they describe in that link from the Skype website. most of these users can bypass this problem by using a usb headset, but that's no option for us.
I have troed all the suggestions in this topic and in that topic on the Skype website, but none of these provided a fix for my problem...

@Joinaunion: Yes if i list al icons, it's also not there (it's that part of the installation that fails). I can go to the link in program files and i can open the control panel from there. But installing the soundcard this way doesn't solve the problem.

Yesterday, I did a last reload. I've reloaded a laptop from a user who desperately needed the softphone (very bad mobile reception at his residence).
The softphone worked right after reload and it continued to work without any problem for the first 30 minutes. Then, all of the sudden, after closing and restarting the NEC UC Desktop suite (not rebooting the pc, just closing and restarting the app), the mic became mute again and nothing i could do that could bring it online again.
After that, i got so fed up with this shit and i've organized a mini-meeting with two managers and told them that this is a lane with no end. I have no viable solution for this problem, i'm just wasting a,lot of time over it..., if they want it to work and if they want to benefit from the support from the installer company (NEXTEL), well then they have to find a way to make the usb headsets work with the hibun ae software.
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
VoIP is different from normal multimedia applications as it depends on a server (gateway) to process the IP traffic connecting to different endpoints.

In order to make operation scalable, the server does not require encryption. From my experience, most VoIP applications have a very low system requirements and you can use a obsolete computer to run the VoIP applications if you only need the voice to pass through.

Do you have access to console of the VoIP server so that you can change its settings like the one mentioned below?

http://www.urtech.ca/2016/11/solved-plantronics-mic-not-working-mitel-micollab-client/

Finally, if a sound device is connected via 3.5 audio port, encryption can only be made on a endpoint to endpoint basis, not via a server.

Correct me if I am wrong as the above are only my educated guess using my helpdesk support experience.
CERTIFIED EXPERT

Commented:
Just curious. Can you go to control panel then sound. Please post pic if you can of playback tab or list what devices show there. Thanks.

Also which jack is the user plugging the headphones into?
bdg 009Network Administrator

Author

Commented:
ok i will make screenshots next tuesdays.

On the 3.5 jack, there is no encryption or blocking by hibun ae. Even if i uninstall hibun ae, this weird mic behaviour persists on the affected machines.

On the voip server console, i can add some parameters for each user like assign softbuttons to an action or number. There seems no option on the server console where you can specify client audio devices.
CERTIFIED EXPERT

Commented:
Did you get those screenshots?
bdg 009Network Administrator

Author

Commented:
Not yet.

Will try to do tomorrow
Network Administrator
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
CERTIFIED EXPERT

Commented:
So your all good now?
bdg 009Network Administrator

Author

Commented:
for the moment,
I will try it next week on some more affected laptops, but for now this seems to solve the problem.
bdg 009Network Administrator

Author

Commented:
It is the best solution for this matter

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.