IIS rewrite URL from .htaccess: match all files and folders starting with . and deny access

VP DD
VP DD used Ask the Experts™
on
On  IIS and trying to translate into it the following Apache rule:

# prevent httpd from serving dotfiles (.htaccess, .svn, .git, etc.) 
# - except let's encrypt challenge
RedirectMatch 403 ^/?\.(?!/well-known/acme-challenge/[\w-]{43}$)

RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::\2$
RewriteRule ^(.*) - [E=BASE:%1]

Open in new window


The idea of the rule is prevent IIS from serving:

    Any file than starts with “.”, or

    Any folder that starts with “.” but the folder “./well-known/acme-challenge”

Thanks in advance ;)
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Dan McFaddenSystems Engineer

Commented:
First, I'd like to see the how you would create a URL path with a "dot" as the first character.  To me, the uri-stem "./well-known/acme-challenge/*" seems to indicate that somewhere there is a directory named "." which is not allowed.

Or is there an application that utilizes URL routing rules (something like an MVC structure) that handles URL routing/mapping?

Not everything doable in Apache is doable in IIS and visa-versa.

Typically you can import the .htaccess rules using the URL Rewrite feature (if it is installed on the IIS Server).  The issue with the Apache rewrite rule is that is uses a flag that URL Rewrite does not support, that being the "[E=BASE:%1] statement on the rewrite.  Which is trying to dynamically update the CGI environment variable named BASE.

You can setup static CGI environment variables in IIS, but the URL Rewrite feature does not support an interface for setting/updating environment variables (for CGI or FastCGI).

So, unfortunately, this rule is not compatible with the URL Rewrite feature in IIS.

Dan

Author

Commented:
Hi Dan,

Easily CMD and  md .demo

In the case of ./well-known/acme-challenge is created by a certifcate intaller (Certify).

Well, there is no way to deny files or folder staring with "." on IIS?

Thanks!
Dan McFaddenSystems Engineer

Commented:
OK, something re-learned today.  Wasn't thinking of command line create.

Either way, the issue in the rule is not the dot in the path, it is the environment variable assignment in the htaccess rule.  There is no facility for IIS (no API available for IIS) to modify  the user environment variables.  Essentially making this rewrite rule incompatible with IIS URL Rewrite feature.

If you remove the line "RewriteRule ^(.*) - [E=BASE:%1]" you can import the htaccess file into the URL Rewrite feature directly.

Dan
Introduction to R

R is considered the predominant language for data scientist and statisticians. Learn how to use R for your own data science projects.

Author

Commented:
Maybe  [E=BASE:%1] cannot be translated to IIS

the 1st part
# prevent httpd from serving dotfiles (.htaccess, .svn, .git, etc.) 
# - except let's encrypt challenge
RedirectMatch 403 ^/?\.(?!/well-known/acme-challenge/[\w-]{43}$)

Open in new window


this will translated onto web.config as

<rule name="Deny files and folderd starting with . but allow folder .well-known" patternSyntax="ECMAScript" stopProcessing="true">
   <match url="(^\.|\/\.(?!well-known))" ignoreCase="true" negate="false" />
   <conditions logicalGrouping="MatchAll">
   </conditions>
   <action type="AbortRequest" />
</rule>

Open in new window

Dan McFaddenSystems Engineer

Commented:
Which is what I had mentioned in my previous post.

Dan

Author

Commented:
Sorry did not see it, where did you mention it?

If you are referring to the rule that is generated by importing the .htaccess into IIS is not even close to it.
If you import the above .htaccess to IIS you get this:
.htaccess to IIS y
Dan McFaddenSystems Engineer

Commented:
I mentionedI mentioned it here.

If you remove the line "RewriteRule ^(.*) - [E=BASE:%1]" you can import the htaccess file into the URL Rewrite feature directly.

Dan

Author

Commented:
Yes, it can be imported but it does not work.

The rule is what you see on above image without the red dots lines.

So, it does not work as the .htaccess it does not “match all files and folders starting with . and deny access” as asked.
Systems Engineer
Commented:
Which is what i mentioned early on in my first post.


Typically you can import the .htaccess rules using the URL Rewrite feature (if it is installed on the IIS Server).  The issue with the Apache rewrite rule is that is uses a flag that URL Rewrite does not support, that being the "[E=BASE:%1] statement on the rewrite.  Which is trying to dynamically update the CGI environment variable named BASE.

You can setup static CGI environment variables in IIS, but the URL Rewrite feature does not support an interface for setting/updating environment variables (for CGI or FastCGI).

So, unfortunately, this rule is not compatible with the URL Rewrite feature in IIS.

There was no working solution given because the mod_rewrite rule is not compatible with IIS; URL Rewrite feature.  I thought I was being quite clear about the issue.

Dan

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial