SSIS Package Configuration Warning: Failure importing configuration file

I am seeing a strange behavior in my SSIS package when using a network UNC for my package configuration.  I’ve created a package configuration that looks to a network path for its configuration file.  When I try to run this package from the designer I receive the warning that the configuration file cannot be found and failure importing configuration file.  I’m using SQL Server 2012/ Sql Server Data Tools (aka BIDS).

When I store the configuration file on my local hard drive I get no warning.  When I map the network path to a drive letter and set my path to the drive letter I get no warning.  It’s only when I specify the path as a UNC.  
As a further test, I created a simple package with a package configuration pointing to the UNC.  I added a script task with some code that reads up the contents of that same config file specified as a UNC into a string variable.  When I run the package from the designer, I still get the warnings that it can’t find the config file –but- the script task can read the contents of that config file without a problem.
This is a new one for me.  Has anyone seen this behavior before?
Mike DwyerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zephyr_hex (Megan)DeveloperCommented:
Does your path have any spaces in it?  Or is it particularly long?
Also, did you verify the permissions on the share?
Mike DwyerAuthor Commented:
No spaces in the path and not particularly long (55 chars).  But I just noticed some unusual about the security for my account.  
The UNC has several subfolders along the path, some of which I don't have access to list the contents of.
So if my UNC was \\myserver\FolderA\FolderB\FolderC\FolderD\myconfigfile.dtsconfig and I don't have rights to list folder contents on folder B,
I can't use explorer to navigate down to my config file from the top level folder.  I get stopped at FolderB.  I'm not the network admin and can't change this but I'll bet this has something/everything to do with this.  Microsoft may be trying to traverse the path to find my folder or something like that.  That would explain why specifying just a mapped drive letter works (nothing to traverse).

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
zephyr_hex (Megan)DeveloperCommented:
Yes.  If you can't access the network path, it's not going to work when you run the SSIS job.  Also note that if you schedule the SSIS job, the account that runs the scheduled job also needs access to the path.
5 Ways Acronis Skyrockets Your Data Protection

Risks to data security are risks to business continuity. Businesses need to know what these risks look like – and where they can turn for help.
Check our newest E-Book and learn how you can differentiate your data protection business with advanced cloud solutions Acronis delivers

Mike DwyerAuthor Commented:
Well, it can access the file using the full path.  
I put a script task in the package that reads the config file contents just to prove that.  
And when I was in the designer, it was able to read/write to that file when I set up the configuration in the first place.  

However, I am guessing the methodology used by SSIS to load the file at runtime is doing something different and gets tripped up when trying to traverse the path, subfolder by subfolder.  My guess, anyway.  There's nothing on google about this.
zephyr_hex (Megan)DeveloperCommented:
So you could read/write using the UNC path in designer?
What account runs the job when you're not in designer, and does that account have access to the UNC path?
Mike DwyerAuthor Commented:
Yes, there's no problem accessing a file in that folder at all....Except when SSIS tries to load the configuration.

Ok, problem solved!  It was the fact that for one of the subfolders in my UNC I did not have rights to list the contents of that folder.  Once I had their network folks give me rights to list contents, everything worked great.  That's a strange one.
Mike DwyerAuthor Commented:
This post names the specific problem that was corrected to fix the problem.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.