EXCH and MAPI over HTTP

Hi Experts,

I have EXCH2013 running with 3 nodes in a DAG.
For some users I have changed over to MAPI over HTTP.
But when I check the connection status, I have still some connections with RPC/HTTP
Is it normal or not ?
Eprs_AdminSystem ArchitectAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dinesh BabuMessaging EngineerCommented:
Hello,

when running Get-CASMailbox cmdlet for the mailbox which were enabled for MAPI/Http should show MapiHttpEnabled as "True".
If you configured some additional mailboxes that weren't enabled for MAPI, then those connections still be in rpc/http, may be thats the reason still you are seeing RPC/HTTP.
Which version of Outlook you are using ? you should use Outlook 2013 +

Thanks,
Dinesh
0
Eprs_AdminSystem ArchitectAuthor Commented:
My outlook version is 2010.
The RPC/HTTP connections are from the public Folder DB.
The user is enabled for MAPIoverHTTP
0
Dinesh BabuMessaging EngineerCommented:
If still connection status shows "RPC/HTTP", then please change the below registry keys.
Locate HKEYCURRENTUSERSoftwareMicrosoftExchange,  create a new DWORD “MapiHttpDisabled” with value 0.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Dinesh BabuMessaging EngineerCommented:
My outlook version is 2010.
The RPC/HTTP connections are from the public Folder DB.
The user is enabled for MAPIoverHTTP

oh ok, if your public folders are in legacy versions of Exchange, then you cant access it through latest clients like outlook 2013+.
Before you should move PF to Exchange 2013 environment.
0
Eprs_AdminSystem ArchitectAuthor Commented:
not all is RPC/HTTP
I have 4 connections with HTTP and the rest is RPC/HTTP
I just want to know wether its ok or not ?
0
Dinesh BabuMessaging EngineerCommented:
Microsoft recommendations is to use latest version of Outlook (Outlook 2013 SP1 +) for MAPI/Http

Thanks,
Dinesh
1
Eprs_AdminSystem ArchitectAuthor Commented:
my public folder are not in legacy mode.
0
Dinesh BabuMessaging EngineerCommented:
I just want to know wether its ok or not ?
Yes its normal , since all the public folder connections are RPC/Http
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Eprs_AdminSystem ArchitectAuthor Commented:
Thanks a lot.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.