Link to home
Create AccountLog in
Avatar of Stephen Kairys
Stephen KairysFlag for United States of America

asked on

Outlook 2016: Search for messages not working - comes up empty

Outlook 2016/Win10:

Starting about a week ago, when I search any folder (e.g. search on "vendor"), nothing comes up at all.

Could there be some setting I may have inadvertently changed that has imposed some hidden criteria that is preventing items from coming up?

Is there a known Microsoft bug that surfaced in a recent update?

Any other suggestions to troubleshoot this problem?

I'm referring to Outlook itself, not OWA.

Thanks,
Steve
Avatar of Nick Rhode
Nick Rhode
Flag of United States of America image

This can sometimes be a corruption (key word "sometimes") in which a repairing your pst would help (unless you are using exchange)

However you could try rebuilding the index.  In outlook go to FileOptions > SearchIndex Options button > Advanced.  Click rebuild and it will re-index your emails.  Depending on your mailbox size, this could take a while

If this is exchange, you can verify if its just the local .ost or the actual mailbox by trying to search in OWA.  OWA is a direct connect to the mailbox in exchange.
Avatar of Stephen Kairys

ASKER

@Nick,
I'm not using Exchange. So, will try the reindex later today. Thanks!
Ran the REBUILD: search still fails. Thanks.
Avatar of Patrick Bogers
Hi

Sounds like there is something wrong with indexing.
Have a quick look on this link to quickly troubleshoot the issue
https://lookeen.com/blog/how-to-fix-outlook-2016-search-problems

Cheers
@Patrick,
Thank you. Just starting workweek...will look in detail later today.
Search is set for Current folder. Current mailbox when searching from the inbox.

Outlook seems to be selected for indexing.  As to INDEXING OPTIONS-->MODIFY, I see the below.
User generated image
Why are all these non-Outlook entities checked? (In fact, when I hover over the first line, the indicator "(Unavailable)" displays at the end.

That's what I have so far...

Thanks!
ASKER CERTIFIED SOLUTION
Avatar of Patrick Bogers
Patrick Bogers
Flag of Netherlands image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
If you are using PST files then you might also like to include "Index Properties and File Contents" in the Indexing Options.

To do this, follow the steps as mentioned below:
Control Panel => Indexing Options => Advanced => File Types.

Scroll down and select .PST.

After selecting PST choose "Index Properties and File Contents" instead of "Index Properties Only".

Thanks,
Sudeep
@Patrick - What's the purpose of waiting five minutes?

@Sudeep - Just curious...Until recently, I had no indexing issues, so what's the purpose of changing to "Index Properties and File Contents"? Are you thinking that setting might have been inadvertently changed?

Will try these steps later....needs to do them outside of my workday.

Thanks.
Well if you didn't have any issues and if you are getting the results as expected then you may not need it, however as the settings says if you don't opt for "Index Properties and File Contents" the only the file properties would be result in the search and if you do you would also get the contents of the file in the search.

By search I mean in Window normal search, not only in Outlook.

Further have you followed and checked the step mentioned in the link below:
https://support.microsoft.com/en-in/help/2769651/outlook-search-returns-no-matches-found

Sudeep
@Sudeep-
Please remind me. Are PST files used for old, archived emails? If so, I don't think they apply here as my Outlook goes back only to the beginning of 2016, and the messages I'm not seeing are very recent (e.g. this week, and even today).

Also, which step in the link you provided did you have in mind?
Thanks!
@Patrick, Per your comment:

>>I would deselect all, close OL, wait 5 minutes, open OL and select outlook only and click to rebuild the index.<<

I did as you suggested. Now, it looks like items come up (although it was SLOW during at least the first search); however, I see the following message:
User generated image
Thoughts on the above? Thanks.
Hey, everyone. Haven't heard back. Any feedback on my previous post? Thanks.
Well, guess what. I just tried searching again, and the error's not occurring.  Still, I'll check the options later. Thanks.
Thank you Patrick! I ended up not rechecking the options as I'm no longer getting the error I mentioned.
Avatar of james snow
james snow

Hello
You can also check out this blog to get rid of all Outlook Search Issue.  The blog has all the possible solutions to solve all search related Issues for all the version of Outlook.
Thank you.