Website not secure message

When users visit a particular internal website they get a message that the site is "Not secure" within Google Chrome (see the screenshot).

What can be done so that the connection to the website will be secure while the users visit this website within Google Chrome?
 
METTEAM08-NOT-SECURE
IT GuyNetwork EngineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dr. KlahnPrincipal Software EngineerCommented:
Well ... when you're selling something direct to purchaser on the site, or dealing in goods of a "personal" nature, HTTPS is certainly mandatory.  On an internal web site that is not accessible from outside the LAN, I don't know that I see the need for HTTPS.  Chrome is issuing a notice not a warning, and that's why it's in black and not red.  Firefox takes the other approach; when a site is secured it shows a lock, and when it's secured with a traceable certificate it shows the site name in green.

But if someone has Decreed that This Issue must be Resolved, then your web server will have to go to Secure HTTP -- "HTTPS" -- with all the attendant configuration headaches that come along with it.  And if you want that green sitename in Firefox you'll need to purchase a traceable security certificate, and renew it every so often.

Side note:   Don't buy a certificate from Comodo.  They are perennially in hot water for security issues and some browsers now specifically downgrade Comodo certificates.

https://threatpost.com/comodo-issues-eight-forbidden-certificates/115311/

http://bravatek.com/comodo-certificate-hack-it-gets-worse/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
aranaCommented:
Open Chrome, type chrome://flags in the address bar, then press “Enter“.
Scroll down to the “Mark non-secure origins as non-secure” setting and change it to “Always mark HTTP as neutral” to turn off the “Not Secure” warnings. Set it to “Default” enable the warnings.
 
BEWARE THAT THIS IS NOT RECOMMENDED, as user will not be warned when visiting an insecure site outside of your internal network
0
Scott Fell, EE MVEDeveloper & EE ModeratorCommented:
You just need to use https AND make sure all assests (images and scripts) are loaded from within the site.  If all files are loaded from within the site, but you have one external file loaded using http, you will get an error.

You will also want to get a certificate or self sign (since it is internal) to avoid certificate warnings or just ignore which is probably ok since it is internal.
0
masnrockCommented:
How do you have the server configured? Where did your SSL certificate come from and is it set up correctly? Use Developer Tools in Chrome to see the information on the SSL certificate.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Google

From novice to tech pro — start learning today.