Cisco 3750 switch throttling and prioritizing traffic

My company has run of 100 Mbps private between two locations. On either end is a 3750 switch. I believe there is finally enough traffic between the locations that I need to do some throttling and prioritizing so critical applications can still talk during the time our backups run.

I realize this would be better served by plugging both ends into routers but I'd like to try and make it work with the switches as I'd need to change my network architecture around.

Below is my code. My two questions are: 1) The policy is applied to the interface connecting to the fiber, yet when I run sh policy-map int gig 4/0/47 I get 0's for everything like nothing's being processed. 2) How do I prioritize Class A traffic?


ip access-list extended priority_list
permit ip host 15.5.5.31 any
permit ip host 15.5.5.39 any
permit ip host 15.5.5.10 any

ip access-list extended non_priority
permit ip any any

class-map Class-A
match access-group name priority_list

class-map Class-B
match access-group name non_priority

policy-map priority-policy
class Class-A
police 95000000 8000 exceed-action drop
*
prioritize this traffic*
class Class-B
police 40000000 8000 exceed-action drop
*
do not prioritize this traffic*

int Gig 4/0/47
service-policy input priority-policy
travisryanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kevinhsiehCommented:
First of all, you need a policy to classify traffic. You have most of it, but not all of it. My classification policies actually mark traffic with DSCP tags. I don't know if what I have will work.

policy-map classify-policy
class Class-A
class Class-B

! on all interfaces where traffic can arrive on, you need to classify the traffic on ingress
interface range g4/0/1-48
service-policy input classify-policy

! on the egress interface where you want to control the traffic, apply your output policy
int g4/0/47
desc fiber connection to mpls
service-policy output priority-policy

Open in new window

0
travisryanAuthor Commented:
Kevin, I'm not sure I follow. I have an access list, a class map, a policy map, then I apply that policy to an interface with these lines:

int gig 4/0/47
service-policy input priority-policy


What else am I missing?
0
Get Cisco Certified in IT Security

There’s a high demand for IT security experts and network administrators who can safeguard the data that individuals, corporations, and governments rely on every day. Pursue your B.S. in Network Operations and Security and gain the credentials you need for this high-growth field.

kevinhsiehCommented:
I think you need two policy maps. At least I do. The first is on ingress traffic to do classification. The second is on egress traffic to give priority bandwidth and shaping.
0
travisryanAuthor Commented:
Kevin, on a switch (at least the 3750) you can't put an egress policy on an interface:

LocationASwitch(config-if)#service-policy output priority-policy
police command is not supported for this interface
Configuration failed!
Warning: Assigning a policy map to the output side of an interface not supported
0
travisryanAuthor Commented:
Let me also add that from some of my bandwidth monitoring it looks like the policy is in effect eventhough when I run "sh policy-map int gig 4/0/47" it's showing "0 packets, 0 bytes""5 minute offered rate 0 bps, drop rate 0 bps" which makes me even more confused.
0
travisryanAuthor Commented:
I applied a policy to the other end of our fiber connection between locations thinking this was a directional problem, but that didn't change anything. Also, running a "sh policy-map" on this interface showed the same "0 packets, 0 bytes" results as the other policy. Below is that configuration. Any help is appreciated.

ip access-list extended LocationB_priority_list
permit ip any host 10.1.1.31
permit ip any host 10.1.1.39
permit ip any host 10.1.1.10

ip access-list extended LocationB_non_priority
permit ip any any

class-map LocationB-Class-A
match access-group name LocationB_priority_list

class-map LocationB-Class-B
match access-group name LocationB_non_priority

policy-map LocationB-priority-policy
class LocationB-Class-A
police 95000000 8000 exceed-action drop

*prioritize this traffic*
class LocationB-Class-B
police 40000000 8000 exceed-action drop

*do not prioritize this traffic*

int Gig 1/0/47
service-policy input LocationB-priority-policy
0
travisryanAuthor Commented:
Since I'm not familiar with any part of the process I'm breaking it down into it's parts. I tried a simple:

ip access-list extended test
permit ip host *computer a* any
deny ip host *computer b* any

conf t
int gig 1/0/40
ip access-group test in


And that works, so I know I've got my ip access list section configured correctly so it has to be something down the line.
0
travisryanAuthor Commented:
After speaking to a consultant that specializes in Cisco it seems like he's stumped for the moment as well. That makes me feel better and worse at the same time.
0
travisryanAuthor Commented:
This ended up being an issue where the prioritizing was assigned to the wrong interfaces, they needed to be assigned to the interfaces on the other end of my communication link.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
travisryanAuthor Commented:
This was the clear solution to the problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.