Avatar of Ian Price
Ian Price
Flag for United Kingdom of Great Britain and Northern Ireland asked on

Word Automatically highlight text in Grey on mouse click

We have one computer running Word 2013.

The problem is hard to explain but basically on a left mouse click Word is selecting chucks of text and highlighting it in grey, when it does this the user can not type into the body of the document.

Its very intermittent you can see an example below

Example
Any advice would be great.

Ian.
* MouseMicrosoft Word

Avatar of undefined
Last Comment
Eric Fletcher

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Ramin

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Rob Henson

I might be making 2+2 = 5 but looking at the screen shot the Mailings tab is selected.

Is this document a Mail Merge document? If so are the areas of text being clicked on Merge Fields?

There is an option with merge fields for them not to highlight grey. I suspect it will be on the right click menu when right clicking a merge field.

Thanks
Rob H
Colleen Kayter

Rob Henson is right.

This is a mail merge document, but more specifically, a mail merge master document displaying one record from the underlying database as an example of what the completed merge would look like.

The user needs to either complete the merge to generate separate documents containing plain text. If the intent is to send a letter to the displayed recipient or just one recipient (to be typed in), then a merge can be done identifying only that record.
Ian Price

ASKER
It isn't a mail merge document at least it shouldn't be - this happens even if it a new document.

I think Ramin might be right in that its the mouse playing up, I'll check.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
Colleen Kayter

ise, the screenshot you show displays the "mailings" tab at the top and the size of the gray areas at the top indicate this really is a mail merge doc. To test this, right click in the gray area, menu options will include update field and toggle code.

If this is happening with new documents, it sounds like there may be an auto new macro running or the normal.dot template was saved with a mail merge doc in it instead of a blank page.
Eric Fletcher

The user's options has likely been changed to display field codes when selected. This is a user-specific option, so all documents on their instance of Word will display the grey shading when the selection is within a field code.

To check (and alter it), use File > Options > Advanced, and scroll down to the "Show document content" section. Within it, change the "Field shading" setting from When selected to either Always (to always show field codes and/or their results with a light grey background), or Never. Click OK to apply the change.

Field codes (such as what are used in Mail Merge) display generated content, so they can't reliably be edited. For situations where field codes are being used a lot, I advise people to turn on the "Always" setting so it is clear when content has been generated and not typed. This will add the grey shading in the screen view, but it won't be printed.

Having the visual cue of grey shading for generated content helps prevent problems where people swear that they edited text within a table of contents or index — only to have all the edits disappear when the field is updated.
Eric Fletcher

The OP's situation is is almost certainly a result of the user's Options being set to show Field code shading when selected. That was my answer, but I'm unsure if I can award myself the points.
Manage field code shading with File > Options > Advanced, Show document content
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Colleen Kayter

Eric, read the OP. The user cannot type in the document. This is not caused by whether or not fields are shaded. What the screen shot shows is a Mail Merge preview.
Eric Fletcher

Thanks Colleen. I did note the comment about typing in the OP, and could see that the content with grey shading is from the preview mode for a mail merge.

However, it wasn't clear whether Ian's user was just unable to type at all — or just that any typing was not being retained. Since the content was from mail merge field codes, I assumed the latter case: if the user typed some content, and then moved to the next merge result, the typed-in content would not be retained because it would be refreshed from the source when that record was previewed again. I've run into this before, and always recommend that people turn on the field code shading to avoid this type of confusion.

Perhaps Ian can clarify whether my assumption is correct.