Avatar of Jeff
Jeff
Flag for United States of America asked on

Cannot import nk2 file in outlook 2016

Does anyone know if it is possible to import an nk2 file more than once?

I installed Office 2016. Setup outlook to get mail from users account (pop3) (used .pst file from old pc office 2003) then imported the nk2 file from old outlook 2003. Everything worked fine including the autocomplete.

However, something happened and I had 5000+ duplicate emails. So, I deleted the profile and pst file  and did everything over again, but this time the importing of the autocomplete nk2 file did not work. After hours of searching and redoing everything multiple times I uninstalled the office 2016 and reinstalled. I am still unable to import the nk2 file.

The profile name is Outlook, the nk2 file name is Outlook. (and yes, I re-copied the nk2 file from the old system each time.

Any ideas on this? Any Registry entries to check?

OS is Windows 10 Home and Office 365 Business.
OutlookPC* nk2

Avatar of undefined
Last Comment
Alexei Kuznetsov

8/22/2022 - Mon
Edward Pamias

Try this...

  1.    Make sure that the .nk2 file is in the following folder: %appdata%\Microsoft\Outlook. Note The .nk2 file must have the same name as your current Outlook 2010 profile. ...
  2.    Click Start, and then click. Run.
  3.    In the Open box, type. outlook.exe /importnk2, and then click.
CompProbSolv

"Does anyone know if it is possible to import an nk2 file more than once?"
Yes, you can.  It may get renamed after the import, though.

Edward's suggestion should work as expected.
Jeff

ASKER
I just downloaded the nk2edit program and found out that the nk2 import is working because nk2edit shows the addresses in the Outlook\RoamCache folder. So the problem is not the import, it appears that the autocomplete is just not working.
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Edward Pamias

On the File menu, click Options.
    Select the Mail tab.
    Scroll approximately halfway down until you see Send messages. Make sure that the Use Auto-Complete List to suggest names when typing in the To, Cc, and Bcc lines box is checked.
ASKER CERTIFIED SOLUTION
Alexei Kuznetsov

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Jeff

ASKER
Yes, that option is checked. I have even toggled it.

Actually I spoke too soon. It appears the autocomplete file in the RoamCache folder is from a previous attempt dated yesterday. So, it appears the import is not working, because I deleted the file and ran the import again and it did not recreate the autocomplete Stream File.
Edward Pamias

When you imported the file did you follow the instructions I posted?
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Jeff

ASKER
Ed Pamias: When you imported the file did you follow the instructions I posted?

To a "T". I've done this multiple times on multiple computers. It definitely has to do with the fact that I setup a profile then deleted it and then tried to setup the profile the second time, Even uninstalling and reinstalling the software did not delete all the residual files from the first install and profile setup.


Alexei Kuznetsov: Try the free Import Auto-Complete List free tool for that.

Worked like a charm!!! Thanks. Where do I send the money?
Edward Pamias

I think I will be trying that tool too! :)
Alexei Kuznetsov

Where do I send the money?
=) You can purchase the advanced version of the tool if you want to.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck