Switch port problems

Hi i have set up the network but cant ping a vlan from the switches. I have a PC on gi1/0/1 on edge switch can get everything fine but not able to ping from other switches to PC.

I have pc ip: set static to 10.194.10.2  ..  gw: 10.194.10.1

From core switch i can ping the PC but not from edge switches


CORE switch sh ip route :
Gateway of last resort is 10.194.2.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 10.194.2.1
      10.0.0.0/8 is variably subnetted, 40 subnets, 3 masks
C        10.194.0.0/24 is directly connected, Vlan990
L        10.194.0.1/32 is directly connected, Vlan990
C        10.194.2.0/29 is directly connected, TenGigabitEthernet5/14
L        10.194.2.5/32 is directly connected, TenGigabitEthernet5/14
C        10.194.6.0/24 is directly connected, Vlan130
L        10.194.6.1/32 is directly connected, Vlan130
C        10.194.10.0/24 is directly connected, Vlan10
L        10.194.10.1/32 is directly connected, Vlan10
C        10.194.11.0/24 is directly connected, Vlan11
L        10.194.11.1/32 is directly connected, Vlan11
C        10.194.12.0/24 is directly connected, Vlan12
L        10.194.12.1/32 is directly connected, Vlan12
C        10.194.13.0/24 is directly connected, Vlan13
L        10.194.13.1/32 is directly connected, Vlan13
C        10.194.14.0/24 is directly connected, Vlan14
L        10.194.14.1/32 is directly connected, Vlan14
C        10.194.15.0/24 is directly connected, Vlan15
L        10.194.15.1/32 is directly connected, Vlan15
C        10.194.16.0/24 is directly connected, Vlan16
L        10.194.16.1/32 is directly connected, Vlan16
C        10.194.17.0/24 is directly connected, Vlan17
L        10.194.17.1/32 is directly connected, Vlan17
C        10.194.18.0/24 is directly connected, Vlan18
L        10.194.18.1/32 is directly connected, Vlan18
C        10.194.70.0/24 is directly connected, Vlan900
L        10.194.70.1/32 is directly connected, Vlan900
C        10.194.90.0/24 is directly connected, Vlan90
L        10.194.90.1/32 is directly connected, Vlan90
C        10.194.91.0/24 is directly connected, Vlan91
L        10.194.91.1/32 is directly connected, Vlan91
C        10.194.92.0/24 is directly connected, Vlan92
L        10.194.92.1/32 is directly connected, Vlan92
C        10.194.100.0/24 is directly connected, Vlan100
L        10.194.100.1/32 is directly connected, Vlan100
C        10.194.110.0/24 is directly connected, Vlan110
L        10.194.110.1/32 is directly connected, Vlan110
C        10.194.120.0/24 is directly connected, Vlan120
L        10.194.120.1/32 is directly connected, Vlan120
C        10.194.121.0/24 is directly connected, Vlan121
L        10.194.121.1/32 is directly connected, Vlan121

Edge switch config:

!
!
!
vlan internal allocation policy ascending
!
vlan 2
 name point_2_point
!
vlan 10
 name ext_bld_serv
!
vlan 11
 name ext_energy_mon
!
vlan 12
 name ext_sec_sys
!
vlan 13
 name ext_cctv_sys
!
vlan 14
 name ext_nurse_call
!
vlan 15
 name ext_messaging_sys
!
vlan 16
 name ext_em_lighting
!
vlan 17
 name ext_iptv_sys
!
vlan 18
 name vmotion
!
vlan 90
 name k2ms_prod
!
vlan 91
 name k2ms_test
!
vlan 92
 name endobase
!
vlan 100
 name asa_dmz
!
vlan 110
 name serv_test
!
vlan 120
 name serv_pres
!
vlan 121
 name serv_terminal
!
vlan 130
 name serv_ilo
!
vlan 900
 name ap_management
!
vlan 990
 name switch_management
!
vlan 992
 name wan_services_net
!
vlan 997
 name wlc_ha_keepalive
!
vlan 999
 name anti-vlan-hop
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
 no ip address
 shutdown
!
interface GigabitEthernet1/0/1
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface GigabitEthernet1/0/29
!
interface GigabitEthernet1/0/30
!
interface GigabitEthernet1/0/31
!
interface GigabitEthernet1/0/32
!
interface GigabitEthernet1/0/33
!
interface GigabitEthernet1/0/34
!
interface GigabitEthernet1/0/35
!
interface GigabitEthernet1/0/36
!
interface GigabitEthernet1/0/37
!
interface GigabitEthernet1/0/38
!
interface GigabitEthernet1/0/39
!
interface GigabitEthernet1/0/40
!
interface GigabitEthernet1/0/41
!
interface GigabitEthernet1/0/42
!
interface GigabitEthernet1/0/43
!
interface GigabitEthernet1/0/44
!
interface GigabitEthernet1/0/45
!
interface GigabitEthernet1/0/46
!
interface GigabitEthernet1/0/47
!
interface GigabitEthernet1/0/48
!
interface GigabitEthernet1/0/49
 description Link to Core bkcswp01
 switchport mode trunk
 switchport nonegotiate
!
interface GigabitEthernet1/0/50
!
interface GigabitEthernet1/0/51
!
interface GigabitEthernet1/0/52
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan900
 description AP Management Ground Floor
 ip address 10.194.73.12 255.255.255.0
!
interface Vlan990
 description Switch Management
 ip address 10.194.0.61 255.255.255.0
!
ip default-gateway 10.194.2.5
ip forward-protocol nd
ip http server
ip http secure-server
Keith BuiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
On core switch what is output from:
sh ip int brief

ANd what is configuration on trunk port between core and edge switch (on both devices).
0
Keith BuiAuthor Commented:
core sh ip int brief:
sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
TenGigabitEthernet1/1  unassigned      YES unset  administratively down down
TenGigabitEthernet1/2  unassigned      YES unset  administratively down down
TenGigabitEthernet1/3  unassigned      YES unset  administratively down down
TenGigabitEthernet1/4  unassigned      YES unset  administratively down down
TenGigabitEthernet1/5  unassigned      YES unset  administratively down down
TenGigabitEthernet1/6  unassigned      YES unset  administratively down down
TenGigabitEthernet1/7  unassigned      YES unset  administratively down down
TenGigabitEthernet1/8  unassigned      YES unset  down                  down
TenGigabitEthernet1/9  unassigned      YES NVRAM  down                  down
TenGigabitEthernet1/10 unassigned      YES NVRAM  down                  down
TenGigabitEthernet1/11 unassigned      YES unset  up                    up
TenGigabitEthernet1/12 unassigned      YES unset  up                    up
TenGigabitEthernet1/13 unassigned      YES unset  up                    up
TenGigabitEthernet1/14 unassigned      YES unset  up                    up
TenGigabitEthernet1/15 unassigned      YES unset  up                    up
TenGigabitEthernet1/16 unassigned      YES unset  up                    up
TenGigabitEthernet2/1  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet2/2  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet2/3  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet2/4  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet2/5  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet2/6  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet2/7  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet2/8  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet2/9  unassigned      YES unset  down                  down
TenGigabitEthernet2/10 unassigned      YES unset  down                  down
TenGigabitEthernet2/11 unassigned      YES NVRAM  administratively down down
TenGigabitEthernet2/12 unassigned      YES NVRAM  administratively down down
TenGigabitEthernet2/13 unassigned      YES NVRAM  administratively down down
TenGigabitEthernet2/14 unassigned      YES NVRAM  administratively down down
TenGigabitEthernet2/15 unassigned      YES NVRAM  administratively down down
TenGigabitEthernet2/16 unassigned      YES NVRAM  administratively down down
TenGigabitEthernet5/1  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet5/2  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet5/3  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet5/4  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet5/5  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet5/6  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet5/7  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet5/8  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet5/9  unassigned      YES NVRAM  administratively down down
TenGigabitEthernet5/10 unassigned      YES NVRAM  administratively down down
TenGigabitEthernet5/11 unassigned      YES NVRAM  administratively down down
TenGigabitEthernet5/12 unassigned      YES NVRAM  administratively down down
TenGigabitEthernet5/13 unassigned      YES NVRAM  administratively down down
TenGigabitEthernet5/14 10.194.2.5      YES manual up                    up
TenGigabitEthernet5/15 unassigned      YES NVRAM  administratively down down
TenGigabitEthernet5/16 unassigned      YES NVRAM  administratively down down
mgmt0                  unassigned      YES unset  down                  down
Vlan1                  unassigned      YES NVRAM  administratively down down
Vlan2                  unassigned      YES unset  administratively down down
Vlan10                 10.194.10.1     YES NVRAM  up                    up
Vlan11                 10.194.11.1     YES NVRAM  up                    up
Vlan12                 10.194.12.1     YES NVRAM  up                    up
Vlan13                 10.194.13.1     YES NVRAM  up                    up
Vlan14                 10.194.14.1     YES NVRAM  up                    up
Vlan15                 10.194.15.1     YES NVRAM  up                    up
Vlan16                 10.194.16.1     YES NVRAM  up                    up
Vlan17                 10.194.17.1     YES NVRAM  up                    up
Vlan18                 10.194.18.1     YES NVRAM  up                    up
Vlan90                 10.194.90.1     YES NVRAM  up                    up
Vlan91                 10.194.91.1     YES NVRAM  up                    up
Vlan92                 10.194.92.1     YES NVRAM  up                    up
Vlan100                10.194.100.1    YES NVRAM  up                    up
Vlan110                10.194.110.1    YES NVRAM  up                    up
Vlan120                10.194.120.1    YES NVRAM  up                    up
Vlan121                10.194.121.1    YES NVRAM  up                    up
Vlan130                10.194.6.1      YES NVRAM  up                    up
Vlan900                10.194.70.1     YES NVRAM  up                    up
Vlan990                10.194.0.1      YES NVRAM  up                    up
BKCSWP01#

__________________________________________________________

Core show Interface :

interface TenGigabitEthernet1/11
 switchport
 switchport mode trunk
 switchport nonegotiate
!
interface TenGigabitEthernet1/12
 switchport
 switchport mode trunk
 switchport nonegotiate
!
interface TenGigabitEthernet1/13
 switchport
 switchport mode trunk
 switchport nonegotiate
!
interface TenGigabitEthernet1/14
 switchport
 switchport mode trunk
 switchport nonegotiate
!
interface TenGigabitEthernet1/15
 switchport
 switchport mode trunk
 switchport nonegotiate
!
interface TenGigabitEthernet1/16
 switchport
 switchport mode trunk
 switchport nonegotiate

_________________________________________________________________________________

Edge switch config, int gi1/0/49 is the trunk to the core.

!
interface GigabitEthernet1/0/49
 description Link to Core bkcswp01
 switchport mode trunk
 switchport nonegotiate
!
interface GigabitEthernet1/0/50
!
interface GigabitEthernet1/0/51
!
interface GigabitEthernet1/0/52
!
interface Vlan1
 no ip address
!
interface Vlan900
 description AP Management Ground Floor
 ip address 10.194.73.11 255.255.255.0
!
interface Vlan990
 description Switch Management
 ip address 10.194.0.60 255.255.255.0
!
ip default-gateway 10.194.2.5
0
JustInCaseCommented:
Output from
show interface trunk
What is interface on core that is connected to edge switch?
sh cdp neigh
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

Keith BuiAuthor Commented:
the PC is pluged into BKLVL3FCR2SW01 on port gi1/0/1

Show CDP nei:

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
BKLVL3FCR2SW01   Ten 1/11          150              S I   WS-C2960X Gig 1/0/49
BKLVL1FCR1SW01   Ten 1/16          139              S I   WS-C2960X Gig 1/0/49
BKLVL2FCR2SW01   Ten 1/13          171              S I   WS-C2960X Gig 1/0/49
BKLVL2FCR1SW01   Ten 1/14          160              S I   WS-C2960X Gig 1/0/49
BKLVL1FCR2SW01   Ten 1/15          144              S I   WS-C2960X Gig 1/0/49
BKLVL3FCR1SW01   Ten 1/12          127              S I   WS-C2960X Gig 1/0/49
bkrtp01          Ten 5/14          163             R S I  ISR4451-X Gig 0/0/1

Total cdp entries displayed : 7
0
Keith BuiAuthor Commented:
Sorry just missed show interface trunk on core:

h int trunk

Port                Mode         Encapsulation  Status        Native vlan
Te1/11              on           802.1q         trunking      1
Te1/12              on           802.1q         trunking      1
Te1/13              on           802.1q         trunking      1
Te1/14              on           802.1q         trunking      1
Te1/15              on           802.1q         trunking      1
Te1/16              on           802.1q         trunking      1

Port                Vlans allowed on trunk
Te1/11              1-4094
Te1/12              1-4094
Te1/13              1-4094
Te1/14              1-4094
Te1/15              1-4094
Te1/16              1-4094

Port                Vlans allowed and active in management domain
Te1/11              1-2,10-18,90-92,100,110,120-121,130,900,990,992,997,999
Te1/12              1-2,10-18,90-92,100,110,120-121,130,900,990,992,997,999
Te1/13              1-2,10-18,90-92,100,110,120-121,130,900,990,992,997,999
Te1/14              1-2,10-18,90-92,100,110,120-121,130,900,990,992,997,999
Te1/15              1-2,10-18,90-92,100,110,120-121,130,900,990,992,997,999

Port                Vlans allowed and active in management domain
Te1/16              1-2,10-18,90-92,100,110,120-121,130,900,990,992,997,999

Port                Vlans in spanning tree forwarding state and not pruned
Te1/11              1-2,10-18,90-92,100,110,120-121,130,900,990,992,997,999
Te1/12              1-2,10-18,90-92,100,110,120-121,130,900,990,992,997,999
Te1/13              1-2,10-18,90-92,100,110,120-121,130,900,990,992,997,999
Te1/14              1-2,10-18,90-92,100,110,120-121,130,900,990,992,997,999
Te1/15              1-2,10-18,90-92,100,110,120-121,130,900,990,992,997,999
Te1/16              1-2,10-18,90-92,100,110,120-121,130,900,990,992,997,999
0
JustInCaseCommented:
On core sh interface trunk looks good.

On edge device the same command?
0
Keith BuiAuthor Commented:
edge switch
BKLVL3FCR2SW01#sh int trunk

Port        Mode             Encapsulation  Status        Native vlan
Gi1/0/49    on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi1/0/49    1-4094

Port        Vlans allowed and active in management domain
Gi1/0/49    1-2,10-18,90-92,100,110,120-121,130,900,990,992,997,999

Port        Vlans in spanning tree forwarding state and not pruned
Gi1/0/49    1-2,10-18,90-92,100,110,120-121,130,900,990,992,997,999
BKLVL3FCR2SW01#
0
JustInCaseCommented:
So trunk is OK.

Did you check default gateways on devices involved in ping?
I guess this is the most likely root cause if ping is working from core, but not from devices in other vlans.

You can try to ping from device in vlan 10  vlan interfaces of other vlans. Most likely it will work. So, next logical assumption would be that default gateway is not properly configured on devices in other vlans (or device in other vlan  is placed in wrong VLAN, check port configuration).
0
Keith BuiAuthor Commented:
I noticed on core switch has a ip route and default-gateway configured, do i only need 1 and which one can i remove?
0
Keith BuiAuthor Commented:
sorry i mean ip route 0.0.0.0 0.0.0.0 10.194.2.1 and ip default-gateway 10.194.2.1
0
JustInCaseCommented:
Default gateway will not be in use as long as routing is enabled. So it does not really matter is it configured or not.
Default route will be used for forwarding traffic.
If there is some problem with routing (no ip routing issued by mistake), default gateway may still give you chance to access device  for router and reconfigured it.
0
Keith BuiAuthor Commented:
Thanks for the info, regarding default routes

No other devices are active in vlans as yet only one port in vlan 10.
0
JustInCaseCommented:
In that case you can only ping interface vlans  of other vlans on core switch from device in VLAN10. If that is OK, everything should be OK.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Keith BuiAuthor Commented:
yes i can ping other vlans from device. Thanks for your help
0
JustInCaseCommented:
You're welcome.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switch

From novice to tech pro — start learning today.