ASA 5506 Port Forward

I have an ASA 5506 x v9.5. I have multiple Public IP's (45.67.166.130 - 45.67.166.158), I have mapped them to internal computers using static NAT (Private IP's 192.168.1.130 - 192.168.1.158).

My mapping is as follows: Public IP 45.67.166.130 NAT's to 192.168.1.130  and 45.67.166.131 NAT's to 192.168.1.131 and so on.

I need to allow tcp traffic on port 6500 in and out on public facing IP 45.67.166.131 and consequently it's translated internal IP of 192.168.1.131

I used this command to create the rule, but still cannot pass TCP traffic on port 6500: access-list outside_access_in extended permit tcp 45.67.166.131 255.255.255.0 host 192.168.1.131 eq 6500

Here is my config, any help is appreciated:

: Hardware:   ASA5506, 4096 MB RAM, CPU Atom C2000 series 1250 MHz, 1 CPU (4 cores)
:
ASA Version 9.5(1)
!
hostname ciscoasa
names
ip local pool VPN 192.168.1.30-192.168.1.60 mask 255.255.255.0
!
interface GigabitEthernet1/1
 nameif outside
 security-level 0
 ip address 96.159.229.212 255.255.255.240
!
interface GigabitEthernet1/2
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet1/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/4
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/5
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/6
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/7
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/8
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management1/1
 management-only
 no nameif
 no security-level
 no ip address
!
ftp mode passive
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network 192.168.1.130
 host 192.168.1.130
object network 192.168.1.131
 host 192.168.1.131
object network 192.168.1.132
 host 192.168.1.132
object network 192.168.1.133
 host 192.168.1.133
object network 192.168.1.134
 host 192.168.1.134
object network 192.168.1.135
 host 192.168.1.135
object network 192.168.1.136
 host 192.168.1.136
object network 192.168.1.137
 host 192.168.1.137
object network 192.168.1.138
 host 192.168.1.138
object network 192.168.1.139
 host 192.168.1.139
object network 192.168.1.140
 host 192.168.1.140
object network 192.168.1.141
 host 192.168.1.141
object network 192.168.1.142
 host 192.168.1.142
object network 192.168.1.143
 host 192.168.1.143
object network 192.168.1.144
 host 192.168.1.144
object network 192.168.1.145
 host 192.168.1.145
object network 192.168.1.146
 host 192.168.1.146
object network 192.168.1.147
 host 192.168.1.147
object network 192.168.1.148
 host 192.168.1.148
object network 192.168.1.149
 host 192.168.1.149
object network 192.168.1.150
 host 192.168.1.150
object network 192.168.1.151
 host 192.168.1.151
object network 192.168.1.152
 host 192.168.1.152
object network 192.168.1.153
 host 192.168.1.153
object network 192.168.1.154
 host 192.168.1.154
object network 192.168.1.155
 host 192.168.1.155
object network 192.168.1.156
 host 192.168.1.156
object network 192.168.1.157
 host 192.168.1.157
object network 192.168.1.158
 host 192.168.1.158
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network obj_any
 nat (any,outside) dynamic interface
object network 192.168.1.130
 nat (inside,outside) static 45.67.166.130
object network 192.168.1.131
 nat (inside,outside) static 45.67.166.131
object network 192.168.1.132
 nat (inside,outside) static 45.67.166.132
object network 192.168.1.133
 nat (inside,outside) static 45.67.166.133
object network 192.168.1.134
 nat (inside,outside) static 45.67.166.134
object network 192.168.1.135
 nat (inside,outside) static 45.67.166.135
object network 192.168.1.136
 nat (inside,outside) static 45.67.166.136
object network 192.168.1.137
 nat (inside,outside) static 45.67.166.137
object network 192.168.1.138
 nat (inside,outside) static 45.67.166.138
object network 192.168.1.139
 nat (inside,outside) static 45.67.166.139
object network 192.168.1.140
 nat (inside,outside) static 45.67.166.140
object network 192.168.1.141
 nat (inside,outside) static 45.67.166.141
object network 192.168.1.142
 nat (inside,outside) static 45.67.166.142
object network 192.168.1.143
 nat (inside,outside) static 45.67.166.143
object network 192.168.1.144
 nat (inside,outside) static 45.67.166.144
object network 192.168.1.145
 nat (inside,outside) static 45.67.166.145
object network 192.168.1.146
 nat (inside,outside) static 45.67.166.146
object network 192.168.1.147
 nat (inside,outside) static 45.67.166.147
object network 192.168.1.148
 nat (inside,outside) static 45.67.166.148
object network 192.168.1.149
 nat (inside,outside) static 45.67.166.149
object network 192.168.1.150
 nat (inside,outside) static 45.67.166.150
object network 192.168.1.151
 nat (inside,outside) static 45.67.166.151
object network 192.168.1.152
 nat (inside,outside) static 45.67.166.152
object network 192.168.1.153
 nat (inside,outside) static 45.67.166.153
object network 192.168.1.154
 nat (inside,outside) static 45.67.166.154
object network 192.168.1.155
 nat (inside,outside) static 45.67.166.155
object network 192.168.1.156
 nat (inside,outside) static 45.67.166.156
object network 192.168.1.157
 nat (inside,outside) static 45.67.166.157
object network 192.168.1.158
 nat (inside,outside) static 45.67.166.158
route outside 0.0.0.0 0.0.0.0 96.159.229.209 1
access-list outside_access in extended permit tcp 45.67.166.135 255.255.255.0 host 192.168.1.135 eq 5900
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
service sw-reset-button
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec security-association pmtu-aging infinite
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto map inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map inside_map interface inside
crypto ca trustpoint _SmartCallHome_ServerCA
 no validation-usage
 crl configure
crypto ca trustpool policy
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
    6c2527b9 deb78458 c61f381e a4c4cb66
  quit
crypto ikev1 enable outside
crypto ikev1 enable inside
crypto ikev1 policy 10
 authentication crack
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
no ssh stricthostkeycheck
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0

dhcpd auto_config outside
!
dhcpd address 192.168.1.130-192.168.1.190 inside
dhcpd dns 8.8.8.8. 69.105.28.16 interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
dynamic-access-policy-record DfltAccessPolicy
username rcanilao password jXtG7YxzBv..nfQL encrypted
username kitc password R7fvLnzeDOdf3PkW encrypted
tunnel-group DefaultRAGroup general-attributes
 address-pool VPN
 dhcp-server 192.168.1.1
tunnel-group DefaultRAGroup ipsec-attributes
 ikev1 pre-shared-key *****
tunnel-group DefaultWEBVPNGroup general-attributes
 address-pool VPN
 dhcp-server 192.168.1.1
tunnel-group DefaultWEBVPNGroup ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
call-home reporting anonymous
Cryptochecksum:a6b930d43a5dc68b6fc0210a595d450a
: end
Robert OsorioAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alexey KomarovChief Project EngineerCommented:
Hi
Try it like this
access-list outside_access_in extended permit tcp any host 45.67.166.131 eq 6500
0
max_the_kingCommented:
Hi,
if you want give access to that server on that port to anyone, you should change your access-list in:

access-list outside_access_in extended permit tcp any host 192.168.1.131 eq 6500

but the main mistake here is that you forgot to apply the access-list on interface outside:

access-group outside_access_in in interface outside.

hope this helps
max
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Robert OsorioAuthor Commented:
Thank you. I will give these a try later today and see what the results are and award points I appreciate your help.
0
Robert OsorioAuthor Commented:
Thank you. All is working.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Static

From novice to tech pro — start learning today.