esxi root user permission

Hi there, root user was changed from Administrator role, to a very privilage role. Is there a way I can rolback this action, because now I can't do any administration task.
Is there a way to change permission from other user, like dcui?
Pochoclo LocoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mcsweenSr. Network AdministratorCommented:
To resolve this issue you have to manually edit the authorization.xml or authentication.xml file depending on the version of product that you  are using. To correct the issue:
Connect to the ESX host's service console via SSH or local console.

Note: ESXi connection to the local console is made using the "unsupported mode"
Open this file in a text editor :
/etc/vmware/hostd/authentication.xml

Note: In ESX4.1 and later the file name is authorization.xml

Change the existing value of the <ACEDataRoleId> </ACEDataRoleID> to -1.
After editing this file, save it and restart the management agents on the host or reboot the host.

From: https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1031192
1
Pochoclo LocoAuthor Commented:
Thank you for the reply. I also saw that I have to change it using nano.
I can't access the ESXi Console:
-I hit Alt+F1
-Type unsupported, hit enter, but nothing ever happend
So I can't access the console.
Can you help me out with that?
0
mcsweenSr. Network AdministratorCommented:
You have to enable the service first.
https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2004746

Enabling ESXi Shell access using the Direct Console User Interface
Use the direct console user interface to enable the ESXi Shell:
  1. From the Direct Console User Interface, press F2 to access the System Customization menu.
  2. Select Troubleshooting Options and press Enter.
  3. From the Troubleshooting Mode Options menu, select Enable ESXi Shell.
  4. Enable ESXi Shell
  5. Enable SSH

Press Enter to enable the service.
1
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Pochoclo LocoAuthor Commented:
Thanks for the follow up, now it ask me login and password. I imagine is Root and its password, right?
0
Pochoclo LocoAuthor Commented:
I can't get past unsupported mode, I enable both services and when I got to the console to try login, I log with root but it says I don't have authorization.
0
mcsweenSr. Network AdministratorCommented:
If you do not have another user setup on the ESXi host you will have to follow the instructions here to boot from a Linux live CD.

https://community.spiceworks.com/how_to/117082-reset-esxi-root-administrator-rights
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Pochoclo LocoAuthor Commented:
Well, now I know you can't mess around with root without having a backup user.
Thanks for your help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.