Sonicwall routing & UniFi Cloud Key

I am setting up a Sonicwall TZ400 and 2 UniFi switches for a client.  Swtich A will be for data and Switch B will be for IP Phones.

X0 is a LAN port setup as / - DATA - Switch A
X1 goes to the WAN (FIOS)
X2 is a LAN port setup as - IP Phones - Switch B

X0 and X2 both have DHCP setup, - 254  (X0)  & - 254 (X2)

I need to make sure all ports are open on the LANS and that traffic from X0 & X2 can talk to each other in both directions.  Also, the networks need to be able to talk to for the UniFi Cloud Key to work.  The UniFi Cloud Key is a Layer 2 device and it is used to remotely administer the switches and wireless access points.

The UniFi Cloud Key is plugged into the switch connected to X0 (Data).

Currently the Cloud Key can see the switch and access points on X0 (Data), but it can't see the switch on X2 (IP Phones).  Also, I believe it uses port 8080 to talk to all UniFi devices.

Do I need to create any routing entries for X0 and X2 to talk to each other?   Is it ok that X0 & X2 have the same subnet?  Should X2 use X0's gateway or inherit it from the sonicwall?

Thanks in advance for your time.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

stewarrh99Author Commented:
Solved: Got this info from the UniFi forms, the L3 option worked for me.

For those devices which are in different broadcast domain (different networks), you have to use one of the L3 adoption method
On the sonicwall, you can use the dhcp-option 43

L3 Option:

Sonicwall dhcp-option 43:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
stewarrh99Author Commented:
Make sure that you issue another set inform command on the UniFi device while it it adopting.  You may have to issue multiple set inform command from SSH for this to work.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.