Lost SonicWall settings from 2 years ago, need to recreate to allow RemoteApp to work correctly

I updated the firmware on my SonicWall TZ-150 this morning and lost all internet connection.  After dealing with the "barely intelligible" support staff, I was only able to regain Internet connectivity by resetting my SonicWall device back to Factory Settings.  In that process, I lost all of the "rules" and "whatever else" I had set up 2 years ago to enable my clients to access my network via RemoteApp under MS Remote Desktop Services (Win Server 2008 R2).  Since the only change I made was to my SonicWall device, I've ruled out all the other setup required to get RemoteApp to work (it's been working fine for the past 2 to 3 years....).  I'm in "no way, shape, or form, any kind of firewall or SonicWall expert (read: novice, at best) and I have no idea what I had set up 3 years ago when I first set up the entire environment.  So, I'm looking for some SonicWall expertise to help me with my SonicWall settings so I can get this remote access capability restored to my system!  I'm attaching two screens from my SonicWall setup software that may be of some help, but, even there, I'm not really sure whether this is the information needed or not.NAT PoliciesFirewall Access Rules
Jim KlocksinOwner, Data ArchitectsAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KnightsmanCommented:
I believe these are the instructions your looking for:
https://support.sonicwall.com/kb/sw4535

These instructions will make sense with your screenshots.  Just take your time, read it along, somethings are not entirely clear, but it should makes sense if you dont rush through itl.

Oh, and make backups this time!
0
Jim KlocksinOwner, Data ArchitectsAuthor Commented:
Actually, I currently have that page open in another tab on my browser, but it's really not helping me all that much.  I feel like I have all the settings the way I need them (I did have a backup from 6/2015 which contained most (if not all) of the settings that I've been using for the past couple of years and I KNOW for a fact that I haven't changed anything in my SonicWall device since that time and, like I said originally, everything's been working well.  It's getting late for me today, so I won't respond to any other comments until tomorrow, but thanks for the feedback and I'm going to keep plugging away at this tomorrow!
0
Jim KlocksinOwner, Data ArchitectsAuthor Commented:
I have followed the abovementioned article and, at this point, probably have more entries in my "rules" settings than I need, but I still can't get my RemoteApp to work.  Again, to reiterate, my RemoteApp has been working perfectly for the past 2 to 3 years and the ONLY change to my system is that I updated the firmware and was forced to reboot using factory defaults.  I did have a backup file from June of 2015 which I was able to import settings from but I'm still not getting the RemoteApp to work.  I'm attaching the error message I get when attempting to access the RemoteApp from within my own network!  This was not the case prior to my upgrading the firmware on my SonicWall.  Anyone who can help or suggest anything else to try would be greatly appreciated.  RemoteApp-Error.jpg
Please keep in mind that the only changes to my system occurred within the SonicWall device, I really don't want to start chasing RemoteApp issues, since nothing was changed on my server and the current setup has worked for a number of years now!  Thank you.
0
The Firewall Audit Checklist

Preparing for a firewall audit today is almost impossible.
AlgoSec, together with some of the largest global organizations and auditors, has created a checklist to follow when preparing for your firewall audit. Simplify risk mitigation while staying compliant all of the time!

Jim KlocksinOwner, Data ArchitectsAuthor Commented:
To summarize:  Yesterday I updated the firmware in my SonicWall TZ105 firewall.  After the update, I lost my RDP capability, both for RemoteApps and for RDP-ing my network server which I should be able to do from anywhere since it has an assigned Public IP address due to the SSL certification I needed to provide my clients with access from their corporate network into my own network.  At this point, I'm not as sure as I was a few hours ago that the problem is totally with my SonicWall device (although that would make sense since that's the only "part of the equation" here that has changed.  Internally, I'm receiving "Remote Gateway server" not available error messages and, while I've imported some older settings (June, 2015) into my "rebooted" SonicWall, I have no idea whether I have that device set up correctly or not!?  Help???
0
masnrockCommented:
What ports do you have open with respect to Remote Gateway and Remote App? And of course, the lesson learned is to make a backup before any firmware update (granted I've never had a scenario where I've needed to restore it on a Sonicwall).
0
Jim KlocksinOwner, Data ArchitectsAuthor Commented:
Actually, my backup from June, 2015, contained most, if not all (as I suspect), of the settings for my Remote Desktop and RemoteApp.  I'm using ports 443 and 4011 (to avoid using 3389).  My installation for my RemoteApp uses a Remote Gateway server as well as a Remote Session Host Server (both are on the same machine but have different public IP addresses since I'm using SSL Certificates for both).  I never changed anything on my network server so I'm at a loss as to why this is not working, since, to the best of my knowledge (which isn't much when it comes to setting up the SonicWall device) I have everything set up correctly.  From my internal network, RemoteApp can't seem to connect with the Remote Gateway Server and from an external network, RemoteApp errors out saying there's a problem with the remote server!?
0
Jim KlocksinOwner, Data ArchitectsAuthor Commented:
Just a follow up....this problem is DEFINITELY a SonicWall problem created when I updated the firmware without a current backup of my SonicWall's settings.  The resultant problem which I desperately need to resolve, is my RDP access which is currently NOT working after having worked with no issues for the past 2 to 3 years.  The first step I'm attempting to resolve is to be able to access my RemoteApp from within my local network (using the RDP RemoteApp process of course...).  The SonicWall is not allowing access to my Remote Gateway computer (which is in actuality my network server) and, again, I'm attaching the error message returned when attempting to run my RemoteApp.  At this point, I'm realizing that I really need someone with substantial SonicWall knowledge (my model is the TZ105 running SonicOS) in order to get this resolved. TIA....RemoteApp-Error.jpg
0
masnrockCommented:
Are those servers in a separate subnet or a defined DMZ? Seems odd that even internally you're having issues.
0
Jim KlocksinOwner, Data ArchitectsAuthor Commented:
Not sure why you think that makes any difference.  Do you have any experience with RDP and RemoteApps?
0
Jim KlocksinOwner, Data ArchitectsAuthor Commented:
This question is going nowhere and, on top of that, my situation has changed slightly after working with Sonicwall support and reviewing a number of YouTube videos about RDP settings for the Sonicwall.  So, I want to close this question and pursue my issue with a subsequent question I posed after this one.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jim KlocksinOwner, Data ArchitectsAuthor Commented:
Situation has changed and my Sonicwall settings are different now from what I posted in this question!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.