Microsoft Small Business Server 2011 Indexing Issues

I've noticed on SBS 2011 when I go to control panel, Indexing Options, every share is selected as well as a few other local folders from the logged in Server user.  This is over 400,00 files.  It is killing the speed of the SBS 2011 and network.  If I go into "Modify" button and uncheck folders then go into "Advanced" button and "Rebuild" it rebuilds with what I have only selected but if I come back to Indexing Options 20 minutes later it automatically adds all the shared folders/files and I'm back up to 400,000 files in an hour or two.

I've already gone to the folder properties in File Explorer, until the "General" tab, "Advanced" button, and unchecked everything - even the "Allow files in this folder to have contents indexed in addition to file properties".  I've been so irritated by this I even this that on the root of the C drive!

On 2012, 2012R2, or 2016 Servers this process I explained above works and I see zero difference in searches and massive performance in everything else but it doesn't work on SBS 2011.

Regards,
Torrey
LVL 2
Torrey BatesPreidentAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hypercat (Deb)Commented:
This sounds like the search settings are being controlled by a group policy.  Find any GPOs that apply to your SBS server and see if there are any settings under the Administrative Templates > Windows Components > Search section.  It could be under either the Computer or the User configuration sections of the GPOs.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Torrey BatesPreidentAuthor Commented:
Ill check this out and get back to you soon!  Thanks.
0
Torrey BatesPreidentAuthor Commented:
I made the changes in Group Policy under Computer Configuration and User Configuration.  Adjusted what is indexed in Control Panel/Indexing and are rebuilding the indexes now .  I will see if it holds up and stops indexing these thousands of folders/files I don't want indexed.  I'll be back with an update soon!

Regards,
Torrey
0
Torrey BatesPreidentAuthor Commented:
Thank you!

Had to reboot the Server for the changes to take event.  After a reboot the indexing did a rebuild all on it's own and it's been fine.

Under Computer Configuration > Administrative Templates > Windows Components > Search enabled and setup:
- Prevent automatically adding shared folders to the index
- Default excluded paths
- Prevent indexing in certain paths

and also under:

Under User Configuration > Administrative Templates > Windows Components > Search enabled and setup:
- Default excluded paths
- Prevent indexing in certain paths
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.