Avatar of xmouser
xmouser
Flag for United States of America asked on

Video card Win 10

So I have a DELL xps 8900, Win 10 with a GeoForce 720 card. When I try and view videos at Amazon they are not HD. If I looking device manager I see the generic Intel video and the Nvidia. I'm connected to the monitor via HDMI. How do I force the system to use the Nvidia card?

Hmm, checking on YouTube I can play videos at 1080p so how do I get the Amazon videos at HD?
Dell* VideosWindows 10

Avatar of undefined
Last Comment
John

8/22/2022 - Mon
John

Connect the monitor in the simplest way possible and reinstall the Nvidia driver.

Do you have two video cards?
xmouser

ASKER
The onboard Intel card and the NVIDIA. I've updated the NVIDIA drivers but still getting SD quality. It may be an Amazon issue. i'm coming from a MAC and it always played at a higher resolution.
ASKER CERTIFIED SOLUTION
John

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
xmouser

ASKER
Thanks for the help. I updated Silverlight - even though I 'updated' Silverlight an hour ago and now I can get 1080. I'm getting 1080 for display under Intel but it's telling me under Nvidia that no compatible device is attached. That's a battle for another day. Thanks.
Your help has saved me hundreds of hours of internet surfing.
fblack61
John

You are very welcome and I was pleased to help you. Best of luck going forward.