Why cannot open any excel files after enable "Ignore other application that use Dyanamic Data Exchange (DDE)"

Hi I cannot open multiple excel(2010) instances at the same time. After enabling "Ignore other application that use Dyanamic Data Exchange (DDE)", I can open multiple instance. However, days ago, I suddently could not open all excel files. After disable "Ignore other application that use Dyanamic Data Exchange (DDE)", I can open excel file, but i cannot open multiple excel files at the same time. Anyone can give some idea for this? Thanks

"Ignore other application that use Dyanamic Data Exchange (DDE)" is located at Option ----> Advanced ----> General
eemoonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
It is not totally clear which problem you try to solve by switching off DDE. DDE is used only for finding and controlling running instances.
You should always be able to start Excel manually in multiple instances.
It should always work to open sheets if done in Excel itself.

So I guess your issue is only with clicking on files in Explorer?
0
eemoonAuthor Commented:
Thank you so much for your reply. My final purpose is to open multiple excel files in multiple instances. we already tried many ways to do that, such as, open anther excel instance first and then open another excel file from the new instance. and also, we can modify registry of PC to resolve the issue etc. but enable  "Ignore other application that use Dyanamic Data Exchange (DDE)" is best way. however, this way only can work for several days in my PC and then i have to disable it because i suddenly cannot open all excel files unless disable  "Ignore other application that use Dyanamic Data Exchange (DDE)"
0
byundtMechanical EngineerCommented:
The checkbox for "Ignore other applications that use Dynamic Data Exchange (DDE)" has long been associated with problems launching Excel by double-clicking a file. In extreme cases, Excel will launch with an empty husk where the file should be. Excel's File...Open dialog should still work, though. These problems first started occurring when Excel 2003 was the latest and greatest spreadsheet wrangler.

Some people reported a registry tweak that permitted the DDE checkbox to co-exist with opening files from emails or by double-clicking them. Windows 7 registry tweak

For my own purposes, I leave the DDE setting unchecked. If I want to view two files at the same time, I do so by opening them in the same instance of Excel and then using the View...Arrange All menu item to show them.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

eemoonAuthor Commented:
Your link discussed a lot on the issue. It seems changing registry is a good way. Some one changed registry for the issue successfully. but later the issue come back again. they explained the issue coming back is due to installation of new software. Do you think so? If so, how can i prevent it from happening again if another software need to install in future? In fact, my pc registry changing many times for this issue, so it caused the issue goes back again again.
0
byundtMechanical EngineerCommented:
Do you think so? If so, how can i prevent it from happening again if another software need to install in future?
I cannot answer either of these questions. Instead, I suggest you conduct an experiment to see if the suggested registry tweak fixes your problem.
0
eemoonAuthor Commented:
Why cannot open any excel files after enable "Ignore other application that use Dyanamic Data Exchange (DDE)"
0
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
Because you need to switch off the usage of DDE in the registry, too!
0
byundtMechanical EngineerCommented:
Apparently, I wasn't clear enough.

1. Uncheck the box for "Ignore other application that use Dyanamic Data Exchange (DDE)". Checking this box has caused problems off and on for Excel users for more than a decade.
2. If you want to view two files at once, do not try to do so in separate instances of Excel. That too has been a source of trouble.
3. The very reliable way of viewing two files at once is to open them in the same instance of Excel, then to use either the View...Arrange All...Vertical menu item. Vertical refers to the "split" line between the two windows.

Also, consider upgrading your version of Excel. Excel 2013 changed to the Single Document Interface model of viewing. This makes it easier to use two screens to view two Excel files in the same Excel instance. Each file has its own set of menus and tools.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
eemoonAuthor Commented:
In Excel2010, current best way is to change registry. I did it, but issue is after updating some software, the registry changed back. So I hope there is a way which can fix the changed registry and keep the registry not changed back.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Excel

From novice to tech pro — start learning today.