Removing Headers from report before exporting to Excel

Is there a way to remove the merging and headers before exporting to excel ? what's happening, is that when exporting, the excel is doing some weird merging with the headers and columns.

All I really want to export is the column names and data. OR maybe i'm doing something wrong with the headers....
LVL 1
Auerelio VasquezETL DeveloperAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Megan BrooksSQL Server ConsultantCommented:
This is an issue that I had to deal with repeatedly over the years, from RS 2005 to RS 2012, and I can't say that I ever found a particularly good solution for it. You can end up with column splits and merges that complicate use of the spreadsheet, and may not even render correctly in some situations.

If you have your own front end UI for the reports then you can launch a "headerless" version of the RDL when exporting to Excel. You could conceivably produce that RDL automatically from the normal version using XSLT or code, as a post-build step, although I never went that far. I even thought about rendering the header as an image. But for the most part we just passed it on to the customer as it was.
0
irudykCommented:
You could try the following:

Add a parameter to the report

General
Name: DisplayHeader
Prompt: Display header
Data type: Boolean
Parameter visibility: Visible

Default Values
Specify values | Add | Value: true

Next click on each text box in the page header section and under Properties | Visibility | Hidden
and set the condition to:

=Parameters!DisplayHeader.Value=false

Then, if you know you want to export the results to Excel, change the Display header option to False before clicking View Report. Otherwise, before you export to Excel, change the Display header option to False, click the View Report button to regenerate the report without the page header.

This may not be the slickest way to accomplish the task, but it's a work-around.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Megan BrooksSQL Server ConsultantCommented:
I don't recall having had that work for us. If it does, go for it.
0
Build an E-Commerce Site with Angular 5

Learn how to build an E-Commerce site with Angular 5, a JavaScript framework used by developers to build web, desktop, and mobile applications.

irudykCommented:
Also, forgot to mention that the text box(s) in the page header should also have the Properties | General | CanShrink set to True
0
Auerelio VasquezETL DeveloperAuthor Commented:
This solution almost works! I got rid of the header, and I know this is nitpicky, but this is what my users complained about. They want the column headings to start at row one, it looks there is a tiny bit of white space, between the tablix and header..... So the column headers start on row 2. Know if there is a way around that ?
0
irudykCommented:
Okay. Say there is one text box within the page header. If that is the case, set the top of the text box = 0 and the height of the text box = the the height of the page header.
0
irudykCommented:
If the height of the text box = the height of the page header, then the gap exists with the page where the tablix is.  In that case, ensure the the top of the tablix = 0
0
Auerelio VasquezETL DeveloperAuthor Commented:
is that under alignment ? padding options ? that's the only places I see the words "Top" or "Bottom"
0
irudykCommented:
For the textbox it would be under Properties | Location | Top
0
irudykCommented:
The height would be under Properties | Size | Height
0
Auerelio VasquezETL DeveloperAuthor Commented:
So, close, i'll award the points, but it still starts on row 2..... Thre is so little white space now, I can't even delete it lol
0
Megan BrooksSQL Server ConsultantCommented:
You might have to disable the header area in the RDL to get rid of that. Still, you fared better than I did (given that my employers didn't want me to spend any time on the problem).
0
Auerelio VasquezETL DeveloperAuthor Commented:
This was a request from the customer, so I have to try and figure it out. But it's much better than before, being that all they have to do is delete one row, and not have to worry about all the merged columns.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SSRS

From novice to tech pro — start learning today.