Office 365 Resource Calendars aka "Rooms"

ITIExperts1
ITIExperts1 used Ask the Experts™
on
Good Morning,
 I have a client that used to be on a local exchange server that recently switched to Office 365. They used to have their conference room and vacation calendars setup as public folders. When they would schedule an appointment they would have to schedule it manually for the user and manually again for the room/vacation.

When we migrated them over to Office 365 they switched the public folders to shared mailboxes. They were still having to double post each appointment. What I did was switch them to "rooms". I was able to use power-shell to convert the shared mailbox to a resource mailbox and that went fine. Now I have a few problems that I need help with.

1) They don't want the resource calendars to show up as mailboxes in Outlook. I try to close them but I get an error saying I can't. (I can get the exact error if needed)
2) There are duplicate calendars showing up in outlook that seem to be a reminiscence of the old shared mailboxes. So I have the "rooms" showing up under Rooms but I also have the conference room and vacation calendars showing up that I can't check off under Shared Calendars.

Is there a way to only have the rooms show up and not auto-open the mailbox in Outlook? I am not sure if something happened with the permissions when I converted them over. I hope I asked the right questions here I am really not sure how to word it. Hoping it strikes a bell with someone that maybe had a similar issue. All users have Office 2016.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Most Valuable Expert 2015
Distinguished Expert 2018
Commented:
1) You most likely have them added via Automapping, i.e. the user have Full access permissions on them. This is not necessary when using Room mailbox, so just remove the permissions. Also check via File -> Account settings -> More -> Advanced and if the mailbox is listed there, remove it.

If you want to keep the Full Access permissions for some reason, you can at least remove the Automapping: http://www.michev.info/Blog/Post/1382/

2) Similar to the above, this is most likely a side effect of having the mailboxes automapped.

Author

Commented:
Thanks Vasil I will check into this. Will this effect everyones' ability to be able to post to them? Outside of the Vacation calendar which has 2 delegates. I need all 20 employees to be able to schedule the rooms. Are you saying that resource mailboxes require no permissions?
Most Valuable Expert 2015
Distinguished Expert 2018

Commented:
You're not supposed to create entries directly into the room mailbox' Calendar. Instead, you designate the room in the meeting request, the message gets sent to the room mailbox and the room calendar assistant automatically approves/declines it. By default everyone can send requests to room mailboxes and they will be approved unless there is a conflict. You can customize the permissions if needed or designate some delegates.
Yes they don't want full permission to book the conference room, when it was shared box those users have full permission with automap enabled, for that reason the mailbox are reside in outlook client. Just remove the permissions from the box.

You can add the appropriate permission to this particular Conference rooms using add-adpermission command.

Also, make sure the RBA (Resource Booking Attendant) is enabled in that conference room.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial