Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 102
  • Last Modified:

VB.net Excel VSTO Add-in version compatability

HI

I have an Excel VSTO Add-in that I developed for Excel 2007 that I want to transfer over to a new machine.
In Visual Studio 2017 there is an option to create an Excel 2010 VSTO Add-in but nothing for Excel 2007.

I want my Add-in to run on machines with as many versions of Excel as possible. Should create an Excel 2010 VSTO Add-in
or should I rather create an Excel 2013 and 2016 VSTO Add-in and just use my old machine for Excel 2007 and 2010.

I just need some advice on the best way to create an Add-in that will run on Excel 2007, 2010, 2013 and 2016 etc

Thanks
0
Murray Brown
Asked:
Murray Brown
1 Solution
 
Miguel OzSoftware EngineerCommented:
IN principle, it is possible to build an Excel 2016 add-in that runs on multiple versions as long as your add-in  does not use features that are new in the lowest Office target as shown here. For example, your add-in could be used in Excel 2010 as long as you do not use new features of Excel 2013 or 2016.
My suggestion is always to support only the 2 previous versions of Excel to limit your coding and testing efforts.
0
 
Murray BrownMicrosoft Cloud Azure/Excel Solution DeveloperAuthor Commented:
Thanks very much. I appreciate the help
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now